Port 1200 timed out.


#1

I’m installing a FlightAware receiver on a network which has a proxy server and get port 1200 timed out when trying to send data to FlightAware.

*06/12/2016 13:30:19 35731 msgs recv’d from dump1090-mutab (31 in last 5m); 0 msgs sent to FlightAware
06/12/2016 13:30:42 Connecting to FlightAware adept server at 70.42.6.197/1200
06/12/2016 13:31:12 Connection attempt with adept server at 70.42.6.197/1200 timed out
06/12/2016 13:31:12 reconnecting in 115 seconds…

06/12/2016 13:45:07 Connecting to FlightAware adept server at piaware.flightaware.com/1200
06/12/2016 13:45:19 36205 msgs recv’d from dump1090-mutab (204 in last 5m); 0 msgs sent to FlightAware
06/12/2016 13:45:37 Connection attempt with adept server at piaware.flightaware.com/1200 timed out
06/12/2016 13:45:37 reconnecting in 103 seconds…*

The receiver works fine on a network with direct connection but I’m wanting to set it up in another area but the only network available is behind the proxy server.

The Raspberry Pi with Jessie installed has the proxy details setup in the .bashrc and can can get out on port 1200 successfully.

$ wget -qO- portquiz.net:1200
Port 1200 test successful!
Your IP: yyy.yyy.yyy.yyy

Any suggestions what else needs to be configured to get this receiver to send data to FlightAware?

Thank you.


#2

Currently you need to be able to make a direct outbound connection, there’s no support for proxy servers.

If you can get a tunnel outbound to piaware.flightaware.com (e.g. socat might do this, IIRC it knows how to do a HTTP proxy CONNECT) then you can point piaware at the tunnel with the “-serverhosts” / “-serverport” options. mlat won’t work.


#3

i have a same problem