FlightAware Discussions

Overhead Signal Loss

Seems that I am losing messages to high altitude aircraft flying directly overhead. Mt setup is the Flightaware 26" antenna with 10 metres of LMR400 -> RTL-SDR Blog 1090 MHz ADS-B LNA -> Airspy -> raspberry pi.

I have tried increasing and decreasing gain but cannot understand why I am losing messages when aircraft are overhead. This isnt just limited to directly overhead but from about 10 miles out i start having issues. When its line of sight?

Any help would be appreciated.

What are your command line options or settings for airspy?

Edit:
It is normal for the signal to get weaker when airplanes are directly overhead.
That is a characteristic of a good antenna in a sense because it improves reception on the horizon by having weaker reception the higher the inclination.

Also the planes have vertically oriented antennas which radiated less power directly underneath or sometimes at a certain angle depending on their pitch and how the antenna is mounted.

Still you shouldn’t be having this problem because the airspy with an LNA should be very sensitive.

I have mostly observed what you speak of with planes around 1 nautical mile away and closer but i have a less horizon focused quarter wave antenna.

My Airspy options are

airspy_adsb -c 127.0.0.1:30104:BEAST -l 30005:BEAST -l 30001:AVR-STRICT -f 1 -m 12 -g 16 -p -n -w 4 -d 6 -b -v

Most of those options are no longer required.

Did you download airspy_adsb a bit over a week ago as your flightaware stats suggest or have you had it longer?

In addition to the network option these options should be enough for the current version 1.37:

-v -f 1 -m 12 -g 16 -p -b

(you can check the version with: airspy_adsb -h)

Apart from that to reduce the cpu load you can use the piaware relay function using this command line for airspy:

airspy_adsb  -l 29999:BEAST  -v -f 1 -m 12 -g 16 -p -b

and changing the piaware-config:

sudo piaware-config receiver-type relay
sudo piaware-config receiver-host localhost
sudo piaware-config receiver-port 29999

(There is quite significant cpu load for every network connection with airspy_adsb.
With -m 12 that usually shouldn’t be a problem but reducing cpu load never hurts.)

This shouldn’t have any effect on the planes flying directly above though.

1 Like

Initially it was a RTLSDR dongle but swapped it out for an airspy last weekend.

I have changed those settings thanks! Although CPU load is about the same.

I think I am not sure on optimising gain. Where is the sweetspot?

Yeah it shouldn’t be a huge difference.
(If you were to try -m20 this would be important, but i don’t think it would work for the amount of planes and messages you have. best stick to -m12, it’s usually not a big difference if any so no real loss)

What number of messages per second does SkyView typically show?

In my experience there is no sweetspot but rather a wide range of gain settings with equally good reception.
I have set it to 16 as well with the same LNA but a quarter wave antenna that is not as good as yours.

So i don’t really have a recommendation.
Try 15?
My guess is anything from a gain setting of 12 to 19 is gonna produce pretty much the same results.

Avg message rate is in excess of 2000 messages/sec peak periods it goes to around 2300 sec.

1 Like

Working very nicely.

@phasma
Why do you need so many listeners and connectors? I use only one listener.

I get 1,800 messages per second in NYC. That is close to the limit.
You may be triple counting the traffic. This could also affect the CPU load.

Europe has more messages on 1090 MHz.
@navzptc reports over 2500 messages/s

Maybe less Mode C only traffic in europe but more Mode S messages? Not sure.
Fact is that the ATC interrogation rate is much higher for Mode S in Europe.

This results in much higher message rates.
Sometimes even i get 1800 messages/s and that is with only around 120 planes in view.

He used the configuration suggested on the airspy website.
(and already changed it on my suggestion)

1 Like

Wow 15 msg/sec per aircaft. That seems a lot.

If I enable Mode A/C on my radarcape it surges to 6,000/sec and kills most feeders.
(3 major airports plus a busy GA airport, heaps of helos and a dozen smaller airports within range).

At night the average goes up:
image

Some aircraft close by with good reception i’ll get up to 45 messages per second from them.
This is a screenshot of a modified SkyView displaying Message rate instead of absolute count (sorted by message rate):

I wonder if the EU has different TCAS broadcast requirements.

I am getting around 20 msg/s/aircraft here in Virginia. They might be more demanding in EU…

Europe has real problems with over-interrogation - it’s mostly Mode S reply traffic not ADS-B.

1 Like

I fired up my airspy (the odroid it was on has been down for a while) on an RPI3.
Only getting about 7msg/s/aircraft.

The commands above only work on the piaware image.
I have to remember how to get it to work with the add-on package.
(I did a work around to get it to work, however, it chews a lot more CPU).

If you want you can just use my script it does the complete setup including creating a service file so it automatically starts. (HOWTO: Airspy mini and Airspy R2: Piaware / dump1090-fa configuration)
(autostart per rc.local you would need to remove if you have it set up like that, it would clash with the service)

But setting it up manually is not a problem either:

airspy network options:

-c localhost:30104:beast

dump1090-fa: default config

RECEIVER_OPTIONS="--net-only"
DECODER_OPTIONS="--max-range 360"
NET_OPTIONS="--net --net-heartbeat 60 --net-ro-size 1000 --net-ro-interval 1 --net-ri-port 0 --net-ro-port 30002 --net-sbs-port 30003 --net-bi-port 30004,30104 --net-bo-port 30005"
JSON_OPTIONS="--json-location-accuracy 1"

important is those two options:

--net-bi-port 30004,30104 --net-bo-port 30005

And piaware then works with default settings, so no need to change anything, but if you have already put something in, then you can go back to the defaults with these:

sudo piaware-config receiver-type rtlsdr
sudo piaware-config receiver-host localhost
sudo piaware-config receiver-port 30005
sudo systemctl restart piaware dump1090-fa

Also check if you have version 1.37
airspy_adsb -h
(that might be different depending on where the program is located)

phasma
Are the disappearing aircraft Mlat aircraft? if so if above you and you need at least 4 servers to see the said aircraft if it were over you theres only 3 to decode hence its disappearing untill clear of you and making up the 4th server again
this does happen to me on flightaware in my location but not on my other radar service i use more coverage

Actually i think especially with good MLAT coverage you are likely to lose MLAT aircraft when they get close to you.
The algorithm for MLAT will select stations for MLATs which are sufficiently far away from the MLAT target to optimimize the multilateration.

But with ADS-B aircraft you shouldn’t lose them for more than maybe 5 miles of the track.

Vertical antennas have a deaf spot directly above.

1 Like