FlightAware Discussions

No WiFi connection with PiAware

I followed the instructions ‘Do you want to build your own FlightAware PiAware ADS-B Ground Station?’ and got everything running but not wireless. If I connect using Ethernet, it works.

In step 3 Optional: Enable WiFi, I opened piware.config.txt in notepad and entered my wireless-ssid and password:

I attached a screenshot that shows piaware connection as ethernet and status as OFF. I rechecked my wireless-ssid and password and they are both correct.

I reopened piware.config.txt and under # WIRED NETWORK CONFIGURATION, Should piaware use the wired Ethernet port for network access? I changed it to no and that didn’t solve the issue.

when you login to the device and you lookup the config of the device itself does it give you an ip adress ?
the command is:

ifconfig

Output should show you the eth0 and wlan0 interfaces and their associated ip adresses.
What type of Pi are you using ? type 1 and 2 don’t have Wi-Fi on board.
If you have a type 3 or 4, did you configure the Wi-Fi on the device itself ?

Is your WiFi even working and properly connected to the router?

check also via command
sudo iwconfig
on command line

You should receive something similar to this:

wlan0     IEEE 802.11  ESSID:"xxx"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: DC:39:6F:xx.xx.xx   
          Bit Rate=72.2 Mb/s   Tx-Power=31 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=68/70  Signal level=-42 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:984  Invalid misc:0   Missed beacon:0

Also check the router logfiles to see if the device at least try to connect to the router.
Can also be a router security setting. In some devices you can limit the access to known devices, new devices will not be able to connect, even if SSID and password are correct

Yes, the WiFi is working. When I got the Raspberry Pi 3 B+, I installed Raspberry Pi OS and it connects to the WiFi just fine. See ifconfig image attached.

When I switch the micoSD card with the one with PiAware, then it doesn’t connect to the WiFi, only with the network cable.

Here is my sudo iwconfig screenshot which shows my wlan0.

I am still looking into the router logs files. My ISP said I may have to set up another instance of piaware and input its profile definitions so it can pass through the firewall. See screenshot.

foxhunter
August 14

Is your WiFi even working and properly connected to the router?

check also via command
sudo iwconfig
on command line

You should receive something similar to this:

wlan0     IEEE 802.11  ESSID:"xxx"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: DC:39:6F:xx.xx.xx   
          Bit Rate=72.2 Mb/s   Tx-Power=31 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=68/70  Signal level=-42 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:984  Invalid misc:0   Missed beacon:0

Also check the router logfiles to see if the device at least try to connect to the router.
Can also be a router security setting. In some devices you can limit the access to known devices, new devices will not be able to connect, even if SSID and password are correct

The correct image:

foxhunter
August 14

Is your WiFi even working and properly connected to the router?

check also via command
sudo iwconfig
on command line

You should receive something similar to this:

wlan0     IEEE 802.11  ESSID:"xxx"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: DC:39:6F:xx.xx.xx   
          Bit Rate=72.2 Mb/s   Tx-Power=31 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=68/70  Signal level=-42 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:984  Invalid misc:0   Missed beacon:0

Also check the router logfiles to see if the device at least try to connect to the router.
Can also be a router security setting. In some devices you can limit the access to known devices, new devices will not be able to connect, even if SSID and password are correct

A05.png

WiFi gets an IP adress, so at least this part is working.
As far as i know WiFi is automatically disabled once a LAN cable is connected.

Did you leave the LAN cable connected while trying WiFi?
The status on your router shows “Connection Type: Ethernet”. This is nomally not WiFi but still connected viaLAN

I tried it without Ethernet cable connected and it the WiFi still did not work. I also edited the piaware-config.txt to say no to wire-network and that didn’t make the WiFi work. I also made sure my SSID Password and password were correct.

WIRED NETWORK CONFIGURATION#

Should piaware use the wired ethernet port

for network access?

wired-network no

# Should piaware use a wifi adaptor

# for network access? You will need to attach

# a supported USB wifi adaptor for this to work.

# change this to "yes" to enable wifi

wireless-network yes

Raspbian Lite: ADS B receiver · wiedehopf/adsb-wiki Wiki · GitHub

There really isn’t much upside to using the piaware image if you know how to work the command line at least a little bit.
You can just install dump1090-fa / piaware and be done with it.

The reservation in your router points to IP adress 192.168.1.85.

The Pi itself is using 192.168.1.66 when on the Raspberry Pi image. Did you set a fixed IP for it or is it DHCP assigned ? When looking at your router screen shot it is expecting a DHCP adress.

Check what is set in the network file
sudo nano /etc/dchcpcd.conf
It should look like this when you have an static IP adress:

interface wlan0
static ip_address=192.168.1.85/24
static routers=192.168.1.254
static domain_name_servers=192.168.1.254