FlightAware Discussions

New FlightFeeder app for Android available for beta testing

Might have just been the manufacturing quality for the one I received then.
Like I said it would not even power the attached USB device.

The Newegg comment I was just going off the sellers description which states:
“The extra USB cable is to power up USB gadgets, e.g. hard disk drive or keyboard. It is not for charging the cell phone / tablet.”

Maybe being your device is rooted things worked out for you. :slight_smile:
Rooting is out of the question right now being I do not wish to void my warranty at this time by tripping KNOX.

Maybe. That I’m not sure of…

If you are using a Samsung tablet, these adapters work great for power, USB and LAN. I have a fleet of about 1,000 of these in production.

sears.com/samsung-galaxy-usb … 1086899998

To: Flightaware Staff
Kindly consider opening port 30005 on the FF Android App so that its data can be fed to on WiFI/LAN to dump1090 running on a RPi and aggregated there.
Thanks.

I connected my Android (with FA android feeder running) to same LAN as my RPi, using WiFi. Then gave following command:


sudo socat -u TCP:<IP address of Android on LAN>:30005 TCP:127.0.0.1:30004 & disown   

Response was:


[1] 2530
2015/10/12 19:20:29 socat[2531] E connect(3, AF=2 <IP address of Android on LAN>:30005, 16): Connection refused

Just got a Valarm Micro USB Host OTG Y-Cable with Micro USB Power Charging for Samsung Phones which is one of the USB OTG cables or docks recommended by FlightAware. All I can say is I wish I didn’t try to pinch pennies before breaking down and getting this one.

Pictured here is a Verizon Galaxy S4 running the latest updates available from Verizon with NO special kernel and the device is NOT rooted.
(Picture was taken indoors using a stock antenna hence the reason there is not much showing…)

The cable is much cleaner without scraps of molding hanging around on the edges and the plugs fit nicely together as opposed to the cheaper made shipped directly from China versions which were posted here of which I tried two. Also there no need for a special kernel or rooted device. You can plug things in using any order with no need to trick things into working. Simply put this cable just works period.

As you can see the device sees itself as cradled and also is indicating it is in fact charging with the RTL-SDR device plugged in and running.

I highly recommend saving the time and headaches and drop the extra bucks and buy one that works instead of rolling the dice on cheaper cables as I did.
(Of course make sure that your device is supported by this cable before ordering one.)

This is very nice looking, neat & clean!
I am highly tempted to order one, though it is costly (Price USD 17.00 + Shipping to Canada USD 13.00 = USD 30.00 = CAD 38.83), the price of a Raspberry Pi :frowning: !

Unfortunately before knowing about Valarm cable, I ordered following items on eBay from Hong Kong. I am waiting delivery. I will first try these to see how these perform. If I am not satisfied, I will order Valarm one.
(1) wireless charger (CAD 9.39 + Free Shipping).
(2) OTG with external power supply to run the external device (CAD 4.19 + Free Shipping).
TOTAL for 2 items = CAD 13.58

… image snipped …
Pictured here is a Verizon Galaxy S4 running the latest updates available from Verizon with NO special kernel and the device is NOT rooted.
(Picture was taken indoors using a stock antenna hence the reason there is not much showing…)

You can improve performance of stock antenna by
(1) Placing antenna near a large window or attic.
(2) The whip is too long for 1090 MHz. Cut it to 67mm height.
(3) Place the whip on a metallic can/box/plate to enlarge groundplane. If can/box/plate are made of iron/steel, you get added advantage of antenna’s mag base getting stuck to the can/box/plate and stay stable & upright.

Please see this thread: How to improve performance of whip antenna of DVB-T

.

Agreed the price is a bit much at $26.00 USD with shipping.
But I made the mistake of wasting $12 dollars on cheap cables trying to save a few bucks that could have gone towards almost half the cost of this one without the wait…

Instead of a powered OTG-cable, you can also use a powered USB-hub in combination with an normal USB OTG-cable.
But it’s also possible to connect dongle to powered Android devices, such as Android Mediaplayer Box or Android HDMI Stick. Most of these devices have a “normal” USB connection, so OTG-cable isn’t necessary :smiley: .

Instead of a powered OTG-cable, you can also use a powered USB-hub in combination with an normal USB OTG-cable.
But it’s also possible to connect dongle to powered Android devices, such as Android Mediaplayer Box or Android HDMI Stick. And there are also Android Car Entertainmentsystems and TV-sets (running Android TV or Android 4.4+). On TV-sets one probably have to side-load the Flightfeeder app. Most of these devices have a “normal” USB connection, so OTG-cable isn’t necessary :smiley: .

Android Mediaplayer Box:
dx.com/p/rk3368-octa-core-an … lug-417593

Android HDMI Stick:
dx.com/p/guleek-mk903v-quad- … -tf-351698

Android Car Entertainment:
dx.com/p/6-2-full-touch-andr … ack-373111

Android Box and Android Stick can also run standalone, like Raspberry Pi.

I was looking at one these to try and see if they would work with flight feeder app.

amzn.com/B00WON0Q8W

amzn.com/B00XHTK876

Both devices should work. I self have connected a dongle to Android-Box running Android 4.2.2 .

My Android-Box:
amazon.ca/CS918-Android-RK31 … B00J1O6672

My Dongle:
amazon.de/gp/product/B013Q94 … KR87KHQ834

I should buy one with at least 2 GB of RAM. And maybe an octacore processor (like Rockchip 3368). But these are of course more expensive. But if you only use it for running Fligtfeeder with dongle, than a box or stick with qaudcore processor (for instance Rockchip 3188 or 3288), 2 GB of RAM and 8 GB of ROM will do the job :slight_smile: .

Cool. Thanks for the input.

You’re more than welcome :smiley:

To FligtAware staff:

Dear FligtAware staff,
As posted before, I use a dongle in combination with Flightfeeder on an Android-Box running Android 4.2.2. . Nearly all the time I’m connected to the internet/network through Lan/Ethernet .

The problem is that the Flightfeeder-app doesn’t seems to detect an internet/network-connection when I’m connected through Lan/Ethernet. I use beta-version 1.0.21 of the Flightfeeder-app, but in the public (non beta) version it will occur also of course.
In found the next workaround; first of all before I open the Flightfeeder-app I have to switch of the Lan/Ethernet in the Android-settings. Than I have to switch on the Wifi and wait till it has connected. Than I open the Flightfeeder-app and wait till it’s connection/sending information to FligtAware. I also check on my stats-page on the website if it’s “Live”. Then I switch on the Lan/Ethernet in the Android-settings again, so both Lan/Ethernet and Wifi are connected. I then check Flightfeeder-app and website if I’m still feeding. Then I switch of Wifi in Android-settings and check Flightfeeder-app and website again. Then it keeps working, but I have to follow this procedure again, every time I power up or restart the device :cry:.

Okay thanks. I’ve logged this issue as ticket 58818.

My setup with samsung S4, OTG cable and dongle, worked fine until yesterday. When I connected the OTG cable the app started and RX worked fine. However no TX. The app was not able to login. I tried uninstalling/installing but that did not help. Suggestions anyone?
(version 1.0.21)

Have same problem since yesterday. App doesn’t seems to connect with Flightaware server :frowning:

IMPORTANT URGENT
Flightfeeder app doesn’t feed anymore. Tried everything, also feeding over mobile internet. Tried also on a different device.
App doesn’t seems to connect with Flightaware server.

Same problem over here since yesterday
Cant login to the server

Edwin

Can you try terminating the app and restarting it? Although there was renewed SSL certificate installed yesterday, we can’t reproduce your problem here. Perhaps your device still has the old cert cached?