FlightAware Discussions

Need a little help with new ADS-B setup

Hey guys, I just set up a couple Raspi’s. One with FlightAware software the other with Radarbox software just to compare the two. On both systems, I have am using a Navair 1090 antenna. It comes with 30 feet of cable and their dongle. See Amazon. It is on a mast 3 feet above my chimney, approx 35 feet off the ground. Because of the long run to my office, I had to extend the run with another (30 feet) of cable Navair sells. The cable does not say what exactly it is but it’s small and has SMA connectors. Easy to run. So it is a long run, but that’s what I needed to get from the antenna, to my room. I do have several pine trees in various locations around me but I do have a clear view North, south, east, west. But, my horizon is obscured in some of the 360 horizon. I am using the FlightAware blue dongle and the Radarbox dongle. One thing for sure, the FlightAware dongle pulls in much more aircraft. I’ve switched it between the two Pi’s running the two systems and wherever the FlightAware dongle is the range is extended 50 miles and several more aircraft are pulled in. My max range so far has been 134 miles. So, my problem is this. I want to get out farther. I can’t control my horizon, trees here and there. I plan to get a second flight aware dongle. What about the cable? Will different cable make a difference where I will get out to 200 or 250 miles? Is it worth the effort? If so, what type of cable? I’ve seem post on the LMR400. I know shorter is better for cable, but what is the optimum run? How short? I need to get it to my office. I’ve also considered sending the antenna back and getting the one FlightAware recommends. Any help is appreciated. Thanks!

As always i recommend to check Heywhatsthat.com first to identify your max range per your geography. Maybe your max range is limited that much already.

Thanks! I had not been shown that site before. I am mostly limited by tall pine trees in a few areas. Not much land in the way. On another topic, I’m traveling to Florida and want to check in on my two Raspi’s running. How can I do that? I know I can use the internet IP, but what goes after the first part of the IP? Do I need to add it to UPnP my router?

Thanks,
John

In your router you need to forward the incoming packet to the RPi system.
For example I connect to my router at xxx.xxx.xxx.xxx:7080 and forward that port to the internal ip at 192.168.1.x:80. How you do it depends on your particular router. Typically you do it on the router admin web page at [router ip]:80.

In addition to what Foxhunter said, yes, the antenna cable is critical. Look at the marking on your current cable and compare signal loss (Coax Calculator). LMR400 is great cable for 1GHz, but not cheap (I have dual radios for 1090 and 978 and the cable is the most expensive part of the system). The Navair antenna is probably fine, but only if the included 30ft of cable works for you. The FA antenna and the correct/minimum length of LMR400 will likely get you more signal (LMR400 with N connector on one end and SMA connector on the other is available on Amazon). I’m in Rochester, MN (fairly flat terrain) about 20 feet off the ground. I can get 200nm for planes at altitude. Use the graphs FlightAware provides on your account (My ADS-B link)-- look at the circular graph that shows counts at distance away. It should match your Heywhatsthat.com graph. (I’m no expert at this… had my setup for ~1 month.)

Thanks for the reply. So, I asked Navair what type of cable it was because there was nothing on it. They said 3D-FB cable. Never heard of it. Looked it up and its supposed to be decent cable. I’m leaning towards sending the Navair stuff (Antenna and cable back) and getting the flightaware recommended antenna and cable. I have several dongles ive used for SDR radio. The best one so far is the Flight aware Blue dongle. The NooElec and RTL-SDR.com dongles work great for radio, but hardly pull in anything on flightaware. As far as my location, I have several large pine trees around me. I do have a clear view in most areas but some are obstructed. So far I’m getting out 147 miles on Navair Radarbox. Screen shot attached. Seems to be about 100 on flightaware…

Hmm, I’m a bit lost with your directions. Its not you, its me. I have a Netgear R6400 Router. I dont see a RPi setting in Admin. I have port forwarding. I have a couple cameras port forwarding but they set themselves up via software. I feel like I’m close to figuring it out. just not there yet. Thanks

You need to set up forwarding rules for each port you wish to forward from the outside to the inside.

Here is an image of the rules I have to access my RPi from the internet. The first entry shows a rule that says that when an external connection arrives on port 7002 it is forwarded to internal ip 192.168.1.2 port 8080. That is the PiAware/SkyAware page on the RPi on my network. At the bottom of the list of rules are disabled entries to forward SSH connections.

Thanks! I’ll tinker around and see if I can get it working.

To clarify one point from the replies you have seen above, when you port forward, the “external port” is an arbitrary number that you make up. It can be anywhere between 1 and 65,535, but in practice should at least be higher than 1024 because most common services already use numbers in that range.

For example, standard web services (http) are on port 80, so you wouldn’t want to use that. But you could use 4080, if you find that easy to remember. Or 18000, or 1452. Whatever.

The “internal port” points to the port that is actually serviced by your pi.

So when you set up your port forwarding, you set your external port to say, 4080. Your internal port will be [pi-ip-address]:80 (or 8080 if that is how you are set up).

Does that help at all? The point is really that for the external port you can use any number that is not already in use by another service. On my system, I have a registered domain name, so I go to “mydomain:8000/dump1090-fa”, or “mydomain:8000/graphs1090”, etc

Great instructions! Worked like a champ. Thank you!