Multilateration (MLAT) now available on PiAware!

Try or uninstall 1.2 then install 2.1.x.
Maybe also try
sudo apt-get update
sudo apt-get upgrade
And a reboot.

Have you restarted piaware after upgrading it? It doesn’t auto-restart on package install (because usually the package install is driven by piaware itself)


Thanks guys! Didn’t even think about restarting my Pi :slight_smile:

Feeder Type: PiAware (Debian Package Add-on) 2.1-5
Multilateration (MLAT): Supported / Enabled

Everything is working now :slight_smile:

You may want to take another look.
It looks like mlat stopped after the reboot.
It says enabled but no neighboring receivers. Have you set the antenna location on the piaware website?

Check out this thread. It looks similar to your issue.

Now I’m seeing this message:

This feeder is not being used for multilateration because its timing information appears to be unreliable. This can be caused by the site location being incorrect, or because your Pi is running out of free CPU.

What is timing information? Location is correct, CPU is running high, but not at 100%.

dump1090 uses Mode S messages to get timing information. It uses this to triangulate positions of Mode S aircraft.
If the information is not accurate or reliable, it cannot be used.
Do you have anything else running on the RPI? Is it a version one or two?

My RPI is version two. The only other thing that is running on my Pi is PF feed.

3655 pi 20 0 15788 6060 908 R 34.7 1.4 35:16.54 dump1090
3665 pi 20 0 75776 32m 5424 S 33.7 7.3 34:06.73 node
2132 root 20 0 11232 6812 2476 S 21.3 1.5 285:17.04 fa-mlat-client
3659 root 20 0 2352 708 596 S 2.9 0.2 3:01.98 nc
2025 root 20 0 17348 6484 3004 S 2.2 1.4 27:27.47 piaware
3660 root 20 0 2404 808 672 S 1.3 0.2 1:41.75 nc

FA MLAT client runs around 20% of the CPU

Thanks for the detailed replies. In summary then, if I understand correctly, for MLAT we usually have a non-corrected pressure altitude and that is displayed, otherwise an extremely noisy attempt is made to compute it. However it seems there is no way for me to know which was done. I get I could look for non-smooth changes which would indicated a computed result.

In any case it looks like I still have to do the altitude compensation based on the actual current atmospheric pressure myself.

Any chance of getting a FlightAware feeder with MLAT for x86 or x64 based PCs? Even the first gen Intel sticks run circles around the newest RPi in the way of memory and horsepower.

Have you tried compiling it?

I did this for the dev 3.0 version
(remove the “-b dev” for the current version).

sudo apt-get install build-essential debhelper tcl8.5-dev autoconf python3-dev python-virtualenv libz-dev tcl8.6-dev python3-venv dh-systemd
(There may be other dependencies. Just add them too).

git clone -b dev
cd piaware_builder
./ jessie

cd package-jessie
sudo dpkg-buildpackage -b
cd …
sudo dpkg -i piaware_3.0~dev_armhf.deb (Change to whatever it creates)

Not in Alaska where I live! ADS-B will not effect most of the State, only the Class Charlie airspace in Anchorage and Fairbanks. We have more aircraft than all other States combined, but most will not be converting.

I am already running Ubuntu and Dump1090 on this stick. It seems I remember trying to install some packages from a script and got errors alluding to the package only being compatible with Arm.

At this point, with Dump1090 running normally on Ubuntu on this x64 device, can I now install some form of PiAware that is not locked to Arm processors or is that not relevant?

There’s nothing arm-specific in piaware.
(the binary packages provided by FlightAware are only built for arm, but if you’re building it yourself that doesn’t matter)

Perfect. SO, what I’m looking for is some assistance in the way of a more detailed procedure to install said hardware agnostic PiAware package onto this stick. Not very Linuxy here.

There are instructions for building it in Jon’s post

Still no working PiAware. Lots of errors. Dump1090 works.

Seems to be a problem with finding python3-venv

found something on the web about changing it to python3.4-venv Did that, installed, but the builder still looks for python3-venv and fails…


You’re not giving us enough information on what’s going wrong for anyone to help.

the thing that keeps failing and retries 5 times is the python3-venv

ted@tedsb:~/piaware_builder$ cd package-jessie
ted@tedsb:~/piaware_builder/package-jessie$ sudo dpkg-buildpackage -b
dpkg-buildpackage: source package piaware
dpkg-buildpackage: source version 3.0~dev
dpkg-buildpackage: source distribution UNRELEASED
dpkg-buildpackage: source changed by Oliver Jowett
dpkg-buildpackage: host architecture amd64
dpkg-source --before-build package-jessie
dpkg-checkbuilddeps: Unmet build dependencies: python3-venv
dpkg-buildpackage: warning: build dependencies/conflicts unsatisfied; aborting
dpkg-buildpackage: warning: (Use -d flag to override.)

OK. This is saying that the python3-venv package is needed to build the piaware package, but it is not installed.

You should be able to install it by “sudo apt-get install python3-venv”.

Something is wrong here. Alaska ranks no better than sixth in the number of registered aircraft.

Maybe you mean:
per capita?