Mouse not working


#1

Hi! My Pi seems to be running Piaware without a problem but when I enter startx to go to the main screen, I find my mouse is no longer working. This is preventing me from accessing the WIfi Config icon to set up wifi.
Any thoughts on why the mouse wont work? I loaded a regular copy of Raspian in my Pi and everything was OK so I suspect it is the Piaware version.

Thanks, Bryan


#2

Mouse connected wifi or usb? If wifi, try usb.


#3

My mouse is connected by usb. lsusb shows that the usb ports are active, so the problem is not there. Neither the mouse nor my keyboard can wake up my screen.


#4

I am desperately seeking help with this problem. I have searched rpi forums for several days now and stil cannot get either my mouse or keyboard to work.
Can anyone help me please?


#5

I’m not sure what the solution is to your mouse issue. Configuring requires no GUI and mouse.

To setup WiFi, see:
http://www.raspberrypi.org/documentation/configuration/wireless/wireless-cli.md

Err, I see you have issues with your keyboard too… Have you disconnected the mouse and tried just the keyboard or used a different keyboard?


#6

I’ve tried with and without both mouse and keyboard. I’ve tried different mice, different keyboards, I’ve tried different power adapters. I’ve tried plugging in direct to the rpi and into a powered hub. I’ve removed the sd card and used a NOOBS card which I bought with the rpi and all the keyboards and mice work when it is installed. The keyboard works on the black screen with the piaware card fitted but when I do startx to go to the gui neither mouse not keyboard works. I cannot access any of the icons on the gui so I’m unable to get into the wifi setup. The wifi dongle has a steady blue led which should flash, so it’s not working either. However, piaware is connected to FlightAware and my stats are being recorded (using the fixed cable connection to my wifi).
This problem started AFTER I had done sudo apt-get update and loaded 1.20 so I suspect something in the 1.20 set up which needs to be altered.
I’ve tried imaging another copy of 1.20 but I cannot get that to work either. I’ve tried several sd cards and I’ve just sent for another one so that I can start completely afresh.
I’m rapidly getting to the point of ditching the whole project and finding something else so do with my rpi!


#7

Bryan,
It doesn’t solve the keyboard/mouse issue, but can you connect to the pi using a terminal emulator like Putty? The local IP address is listed on your stats page at FA.
Personally i’ve never ever attached a monitor to the PI leave alone used the desktop with startx. There are many tutorials about getting WiFi to work from the commandline. Let us know if you need help…
/paul


#8

No mouse required. :exclamation:


#9

Many thanks for your help. You’ll notice I wrote “The wifi dongle has a steady blue led which should flash, so it’s not working either.” on my last plea for help.
Because of this, I can’t use the command line to start the wifi. The rpi does not recognise that the wifi dongle is inserted into one of the usb sockets and so trying the command line method comes to nothing. Funnily, it’s not the usb integrated hub on the rpi that’s not working because the tv dongle works in any of the four usb sockets and sends info to FA when the rpi is connected by cable to my wifi.
So although I appreciate your assistance, I’m actually no further forward with this problem. Note that wifi works when I insert the NOOBS sd card instead of the piaware imaged sd card. I’m still of the opinion that is it is something in 1.20 that’s causing the issue (unless you can tell me otherwise.) Could it be something as simple as missing drivers?


#10

If you have a sdcard image that works, perhaps you should start from that image and install piaware etc on top of it.


#11

NOOBS is an image to THEN install the OS. NOOBS isn’t a full OS. I personally don’t understand why NOOBS exists.

Download Raspbian from http://www.raspberrypi.org/downloads

I believe you’re using windows. Install the image as per http://www.raspberrypi.org/documentation/installation/installing-images/windows.md

If you’re having issues with that image, it time to move away from blaming the software and towards looking at the hardware. I suspect you have a hardware issue.


#12

Just to finish this one off, my problem was a corrupted piaware download (don’t know why this happened but suspect it happened during an incomplete download of Iceweasel) and the solution was to take a new, fresh SD 8gb card and re-download the image again.
Everything now works as it should have including mouse, keyboard and wifi dongle.
Hope this helps anyone having the same difficulties I had.