FlightAware Discussions

Mlat client problem

Hi everyone
I’ve just got started submitting data to FA but seem to be having some trouble with the MLAT client on my Pi.

On my stats page I have manually set my location, however, the MLAT button is red and says “MLAT disabled/not synchronized/Latitude Longitude not set” and in the list of info at the right I see “Multilateration (MLAT): Supported / Not Enabled”.

In the PiAware log I see the following regarding mlat:

Dec 27 17:40:35 raspberrypi piaware[508]: Starting multilateration client: /usr/lib/piaware/helpers/fa-mlat-client --input-connect localhost:30005 --input-type dump1090 --results beast,connect,localhost:30104 --results beast,listen,30105 --results ext_basestation,listen,30106 --udp-transport 70.42.6.225:7164:23928814

Dec 27 17:40:36 raspberrypi piaware[508]: mlat-client(1259): fa-mlat-client 0.2.10 starting up

Dec 27 17:40:36 raspberrypi piaware[508]: mlat-client(1259): Using UDP transport to 70.42.6.225 port 7164

Dec 27 17:40:36 raspberrypi piaware[508]: mlat-client(1259): Listening for Beast-format results connection on port 30105

Dec 27 17:40:36 raspberrypi piaware[508]: mlat-client(1259): Listening for Extended Basestation-format results connection on port 30106

Dec 27 17:40:36 raspberrypi piaware[508]: mlat-client(1259): Connection to localhost:30005 lost: [Errno 111] Connection refused

Dec 27 17:40:36 raspberrypi piaware[508]: mlat-client(1259): Reconnecting in 0.5 seconds

Dec 27 17:40:36 raspberrypi piaware[508]: mlat-client(1259): Beast-format results connection with ::1:30104: [Errno 111] Connection refused

Dec 27 17:40:36 raspberrypi piaware[508]: mlat-client(1259): Input connected to localhost:30005

Dec 27 17:40:36 raspberrypi piaware[508]: mlat-client(1259): Input format changed to BEAST, 12MHz clock

Dec 27 17:40:37 raspberrypi piaware[508]: Lost connection to adept server at piaware.flightaware.com/1200: server closed connection

Dec 27 17:40:37 raspberrypi piaware[508]: multilateration data no longer required, disabling mlat client

Dec 27 17:40:38 raspberrypi piaware[508]: fa-mlat-client exited normally

Dec 27 17:40:38 raspberrypi piaware[508]: reconnecting in 51 seconds…

Dec 27 17:40:38 raspberrypi piaware[508]: mlat-client(1259): Disconnecting from localhost:30005: Lost connection to multilateration server, no need for input data

Dec 27 17:40:38 raspberrypi piaware[508]: mlat-client(1259): Exiting on connection loss

I’m not sure what to try next! Any would be great. Thanks.

Do you use the pi for other things? That looks like really strange networking errors.

Are you using the piaware image or a raspbian image on the pi?

Please use this command

sudo journalctl -u dump1090-fa -n30 --no-pager

and post the output.

Set your location on your piaware webpage. This looks OK.
Check enable MlAT too. It looks like yours is disabled.
Then restart your piaware.
It should then work, if you have enough other receivers in range.