Map details not displaying

I’m relatively new at PiAware and am running a Pi 3 with PiAware 3.1.0. I haven’t looked at my Dump 1090 page in a few days. When I logged in this afternoon my aircraft show up fine however no mapping details show. The background is completely white. The OpenStreetMap logo shows in the lower right corner.

I have tried the following with no change: Reset map, Restart Dump 1090, Restart PiAware, Reboot Device

I would appreciate any suggestions.

Try clearing your browser cache.

I tried clearing the cache as well as shutting the Pi all the way down and restarting. Still no luck.

I’ve nothing on :8080 now! Same problem?

The page no longer loads in IOS. But it’s fine in OS X. Odd …


Thanks hughjmilsom. I have tried it from a couple of devices. It is always a white background on my PC. I had sections of the map appear on my iPad for a while this morning but it’s back to an all white background now as well.

NOTE: I provided this to hughjmilsom on another thread but I think it may also apply to the blank screen with no map details issue as well. BTW I am running iOS 10.2 (one of the betas).

I recently had the same experience on my iPod Touch. I found out by accident if you browse with Safari in “Private” mode for some reason you cannot access the web interface.

The Private Browsing switch is located at the bottom left when you open a new browsing page. Link to Apple’s instructions –

Hope this works for you.


Thanks Richard. The iPad is safari, however it is not set to private browsing and the PC is Windows Vista running Firefox also not on private browsing. I am away from my home network and havent had a chance to try it again today. It has me a bit puzzled as nothing has changed with my set up.

I should have read your question a bit more carefully. I was in the mode of iOS and Safari when I wrote.

Recently I made some changes to the html script files in /usr/share/dump1090-fa/html and discovered with Windows 7 and Google Chrome that if I didn’t completely clear the browsing data (not just reboot the machine or restart the browser) any changes I made to the html scripts wouldn’t take effect.

Hope you find a solution.


My problem continues. Today, I tried viewing the data directly from the Raspberry Pi via the HDMI connection. I see the same white background with 150 plus aircraft. I assumed something must have corrupted my Pi software so i reformatted the SD card and reinstalled a new version of PiAware. Following the fresh install I still have the exact same problem. It’s as if the map data isn’t making it through.

Does anyone know how the map data is received by the PiAware device? Maybe that would help me understand why it’s not making it through.

The map tiles are (by default) from OSM:
(They are not stored on the piaware device, they are fetched from OSM directly by your browser)

Can you view the map at the URL above OK?

Outstanding, thanks for the help obj. Maps wouldn’t load from the address or openstreetmaps ip address from any device on my network. Double checked router settings and the ip address hadn’t been blocked. I reset my modem by powering down and voila, now it works. I guess it must have been some type of conflict. Not sure what happened. Thank you for pointing me in the right direction.