Intel Compute Stick revisited..

I finally got a 32GB, 2GB RAM Intel Compute Stick running with 64 bit Ubuntu Desktop, headless, with Dump1090. Why is this interesting? Soon, as the Cherry Trail stick is now available, the original Compute Sticks sticks will become cheap. They have a case, and an integrated fan, and are a bit smaller than the RPi, overall. And they have more CPU, memory and storage, for whatever.

So far, I’ve noticed that running Dump1090, the fan doesn’t come on, and the stick runs at about 36-39C. Not too shabby. It’s running the Atom Z3735F compared to the RPi 2 ARM Cortex-A7.

They look like powerhouses for the size. A quad core 1.3GHz processor and 2GB ram rocks. Up in the air about the integrated 32GB of storage being that flash memory seems so fragile. Honestly I am sure I am not the only one who has had to swap out SD cards quite occasionally. Wouldn’t mind this for the “full” Windows 10 experience but the price better drop big time for apps like this… US$130.00 equals 4 Raspberry Pi 2’s or 26 Raspberry Pi Zeros which are starting to make their way to stores as of late.

That being said would still love to hear about your experiences with the device.
How hard was it to move from Windows which seems to be the default OS to Ubuntu?

Migration wasn’t really difficult.

I’ve been running these sticks for months 24/7 on Win10 Pro as video servers with no issues, so the SSD fragility isn’t really a problem. Inventory onboard is about 17GB and it plays no problems, and gets refreshed regularly.

I opted to blow away the Win partitions altogether and go all Ubuntu.

Details here: … stick.html

The headless ops are:

Install latest grub from git:

apt-get install git bison libopts25 libselinux1-dev autogen m4 autoconf help2man libopts25-dev flex libfont-freetype-perl automake autotools-dev libfreetype6-dev texinfo

git clone git://

cd grub


./configure --with-platform=efi --target=x86_64 --program-prefix=“”


cd grub-core/

…/grub-install -d . --efi-directory /boot/efi/ --target=x86_64

cd /boot/efi/EFI/ubuntu/

mv grubx64.efi

cp …/grub/grubx64.efi .

Edit grub to look like this ( /etc/default/grub )




GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian

GRUB_CMDLINE_LINUX_DEFAULT=“quiet text reboot=pci”


Furthermore, You need following setting for uninterrupted fsck checking

in /etc/default/rcS, FSCKFIX=no changes to FSCKFIX=yes

And, execute update-grub2

Try boot with HDMI monitor.

Everything OK, unplug HDMI cable and try to boot!

And if having logged in on the console you find you want to start your default GUI, then simply run ‘service lightdm start’ as root.