FlightAware Discussions

HOWTO: Airspy mini and Airspy R2: Piaware / dump1090-fa configuration

Thank you. ul_tracks=2000 now. Still on “-w 3”. Here is what it looks like. I’ll now switch to “-w 2” and let it run for an hour and see what it looks like.

dump1090-localhost-tracks-6h

1 Like

I certainly like it when you boffins hook onto something when I am on a night shift. It certainly makes 12 hours go by quickly and generally it has been sorted out by the time I get home with all the bugs ironed out … lol :rofl::rofl:

1 Like

Whats your -e setting for that graph??

Mine?

I am running a PI4 with Debian Buster Lite, piaware 3.7.2, an Airspy R2 @ 20 MHz with “-e 8.6 -w 3”. I changed to “-w 2” a short while ago and it pretty much looks the same as “-w 3” . So I’m going to leave it at “-w 2”.

I’m presuming that “-w 1” (the default) is the same as previous versions of airspy_adsb without the -w option.

Mike

Will you post the w2 graph after your hour?? Or might you go in the other direction, say 4??

-w 1 will still remove some non-crc frames with unknown icao’s. The assumption before is that dump1090-fa could still manage to fix/use them, but now they are removed. Maybe -w 1 will reveal better after your tests.

I will not do “-w 4” testing. From what I can tell, “-w 3” and “-w 2” totally cleaned things up for me, and I don’t believe I’ve lost anything legitimate. I will post a “-w 2” after at least an hour of tracking has gone by, and then I’ll switch to “-w 1” and test that.

@prog: yes, I will test “-w 1” today.

Mike

1 Like

Request:
I’m about ready to move from AirSpy mini and Pi3B+ sampling @ 12 MHz to AirSpy mini and Pi4 @ 20 MHz.
The >500 posts with myriad variants of -w and -e is bewildering.
What version should I load and what settings are mainstream to start?
My RF cascade is already well optimized; I’m just asking where to start with the Pi4.

airspy_adsb -h will tell you the defaults.

-e on the Pi4 with 20 MHz, i believe it can handle -e 7 fine.
You can increase further depending on CPU.

-w is still very much in flux, just go -w 4 for now, but it’s changing a lot, so no telling really :slight_smile:

1 Like

For airspy_adsb:

  1. Don’t use bit packing (-p) You won’t need it anyway.
  2. Latest version is v1.62 (and will probably change in the next day or so)

I’m not running a mini, but rather an R2. But my PI4 runs the Airspy R2 @ 20 MHz just fine with “-e 8.5”. However, I am in an area / have an antenna system that affords me only about 1300 msg/sec maximum on a good day. If your setup routinely yields much more than that, you will likely have to user a value lesser than '-e 8.5".

Mike

Hello @wiedehopf @abcd567
Nice installation script and thanks for sharing this and assisting the ADS-B community.
I tried the automatic install and had it running fine but it crashed and had to re-install and now I can’t get it to work on RPi4B 4GB with an airspy mini.
After doing the sudo bash -c "$(wget -O - https://raw.githubusercontent.com/wiedehopf/airspy-conf/master/install.sh)" on a fresh Raspian Buster download, I can’t get the dump1090-fa to run. It will load the webpage (127.0.0.1/dump1090-fa) but unable to view (decode) any airplanes (Checked antenna and it is fine as I can see the ADS-B traffic on a spectrum analyser).
When doing sudo systemctl status dump1090-fa.service and dump1090-fa it says no SDR found.


Checked the airspy on a Win10 using the Windows SDR Software Package from https://airspy.com/download/ and all OK so the airspy is working.
Any ideas what I can check/look for to make the airspy mini work again on a RPi 4B?
Thanks, Marc

sudo journalctl -u airspy_adsb
cat /etc/default/airspy_adsb


Try a sample rate of 12 for now.

Oh turn off -p -x

Try that first with 20 as sample rate.
Might need to reboot as well.

Thanks

removing the -p and-x did the trick

Thanks again.

Pi4 you say?

Add this to the options:

-w 4 -e 8

But check here if you lose samples, then -e needs to go lower :slight_smile:

sudo journalctl -u airspy_adsb
2 Likes

Yes PI4 indeed.

I added the options -w 4 and -e 8 which loads the CPU a lot. I tested with the -e 4 setting and then back to -e 8 and that changed a lot. CPU load increased
dump1090-localhost-cpu-24h%20with%20comments
but also 200+ more messages/sec


That’s just lost samples on startup and not an issue.
(unless this continues, you chose a kinda useless portion of the log to show.)

If you want to run higher -e, it’s recommended to used force_turbo=1 in /boot/config.txt which doesn’t overclock anything, it just disables energy saving so to say.
This isn’t necessary though, you just need to understand when lost samples are to be expected (startup)

Thanks for the info @wiedehopf
It was indeed the end of the log. I had more lost samples when using a 2m USB extension cord in between airspy and PI4. This has now been taken out so the airspy mini connects straight to the USB 3.0 on the Pi4.


Added the force_turbo 1 to the /boot/config.txt to test it.