FlightAware Discussions

Gap in Push Notifications

We are developing an integration with your API and ran into some anomalies last week.

We’ve had success otherwise but one night I setup 8 new flights to track at the end of the day, and I’m not seeing any updates having come through from those flights.

I can provide additional examples, but here is one of that alerts with all the technical details:

alert_id = 33462102
ident = UAL909-1580795135-airline-0088
alert_created = 1581033877 (Thursday, February 6, 2020 6:04:37 PM GMT-06:00)

Based on the web portal info (https://flightaware.com/live/flight/UAL909/history/20200207/0009Z/KORD/EHAM)

We should have gotten a departure alert at takeoff (06:19PM CST) and landing (08:45AM CET).

I traced through every log we have and there is no record of those alert updates. And I verified in your test interface (https://flightaware.com/commercial/flightxml/send.rvt) that no push notifications were attempted.

Why did these alerts fail to send their push notifications? Was there a service outage?

There was in issue discovered with alert processing during a maintenance window that occurred on Feb 6. It’s most likely that the alerts were missed during the service restoration.

Understood. Thanks for the update!

Interestingly I had an unexplained change in my PiAware setup’s apparent gain on Feb 6 from 1200 to 1600 ish. Could that maintenance have had anything to do with it?

change_in_gain

No, they’re unrelated systems and anyway we don’t have a mechanism (or a desire!) to change your piaware config remotely.

Thanks, I suspected not, just ruling it out for sure.