FlightAware prostick directly on the antenna?


#1

First… Helle my name is Remon and i’am from holland. i am a flightAware user.

Well i have an antenna on my roof with 7.5m cable to the flightaware pro sick. Well i recieve 250 planes then (averrage). When i connect de flightaware stich directly to the antenna then i recieve about 100 planes less (about 160 planes averrage). So i receive less planes without coax cable and i touht i reduce the lengt of the cable to make the signal better but that isn’t.
Is it better to have a cable between the antenna and the flight aware stick?? or are there other soluions to make the sinal better?
Now i’m thingking to place a cable, about 2m to look if it is better then, now i have a 7.5m cable what is to long now, beceause the stick is nearly the antenna.
Well hope someone has ideas…
Thanks so far.

Remon


#2

My guess is that your signal was too strong to start with and you made it even stronger. Signals that get clipped are discarded.
Adjust the gain.


#3

Ok yes that could also be the problem. but how can i change the gain? I have read about somthing about t change the gain in a newsletter from flightaware by changing piaware config file, but i don’t have that file. Link from the news letter: flightaware.us14.list-manage1.co … 10443339ee

Well i read it again perhaps i forgot something.


#4

It’s a whole thread here about that.


#5

well the link from the newsletter doesn’t work anymore.
The problem is the file piaware-config.txt file doesn’t exisist. And if i creat e a file it give no change. so perhaps someone can help me a bit.
perhaps a link to a topic???


#6

ok if i understud it then i can change the file, and the gain by typing:

sudo piaware-config rtlsdr-gain (a number)

ok that wil work. my question is this ok? and whagt range can i give it. is it between -1 and -10 (default) or can it be positive? and do i need to restart piaware? if i change it now it does not change somthing but now i have my coax cable 7.5 m. Ok i can remove it and test it without the cable.


#7

@remondolinski:
(1) Which image you have written to your microSD card?

Piaware 3.5.0 image downloaded from
http://flightaware.com/adsb/piaware/build

OR

Raspbian Jessie image downloaded from
https://www.raspberrypi.org/downloads/raspbian/

(2) Gain should be positive number between zero and 50. The ONLY negative value used is -10, which sets gain to AGC (automatic gain control). Any other negative number sets the gain to Zero.

(3) Value of gain depends on location and placement and type of antenna, length of coax cable. It varies for each receiver. Generally gain is set between 25 and 40 by most users. For my setup, 30 gives good result. I found this by trial & error. For your setup, you have to try different gain values to find which one gives you best result.


#8

Ok thanks for your reply.

I have a piaware image downloaded.

Ok i will play with the settings between 0 and 40. i need also remove my (to long) coax cable, so i need to go on my roof.
If i change the value, do i need restart dump1090, piaware, the device or has the changes effect without any restart??
thanks…


#9

** (1) Set gain**
pi@piaware:~$ piaware-config rtlsdr-gain 25
Set rtlsdr-gain to 25 in /boot/piaware-config.txt:60

** (2) Restart dump1090-fa to implement the new gain value**
pi@piaware:~$ sudo systemctl restart dump1090-fa

** (3) This step is optional, if you want to check the value of gain actually in use**
pi@piaware:~$ systemctl status dump1090-fa -l



─6457 / usr / bin / dump1090-fa --net-bo-port 30005 --fix --device-index 0 –gain 25 --ppm 0 --max-range 360 --net --net-heartbeat 60 --net-ro-size 1000 --net-ro-interval 1 --net-http-port 0 --net-ri-port 0 --net-ro-port 30002 --net-sbs-port 30003 --net-bi-port 30004,30104 --json-location-accuracy 2 --lat 43.xxxx --lon -79.xxxx --write-json / run / dump1090-fa --quiet


#10

ok, if i change the gain it will not change?

first i set the gain to 40:
pi@raspberrypi:/boot $ sudo piaware-config rtlsdr-gain 40
Set rtlsdr-gain to 40 in /etc/piaware.conf:9


#11

ok i go on, (went somthing wrong or post was to long, so i cut it)

i do a restart: sudo systemctl restart dump1090-fa

i check:
pi@raspberrypi:/boot $ sudo systemctl status dump1090-fa -l

dump1090-fa --device-index 0 --gain -10 …

the gain is still -10 ???

so i can change the gain with no error so it looks like it is ok.
but the gain is still the same

if i look in the /boot directory i can’t find the piaware-config.txt file.

now i see that it is in the etc directory : etc/piaware.conf
if i open the file then the gain is changed:

This file configures piaware and related software.

You can edit it directly or use piaware-config from the command line

to view and change settings.

If /boot/piaware-config.txt also exists, then settings present in

that file will override settings in this file.

allow-auto-updates yes # updated by fa_piaware_config
allow-manual-updates yes # updated by fa_piaware_config
rtlsdr-gain 40 # updated by fa_piaware_config

i don’t know if my changes take effect.
do i something wrong?


#12

Are you using a piaware sdcard image? /boot/piaware-config.txt exists in a sdcard image.

“rtlsdr-gain” is only used on sdcard images. You should reboot after changing it.

If you are using a package install, not a sdcard install, then edit /etc/default/dump1090-fa


#13

In your above quoted post, you said Piaware image

Your subsequent post quoted below shows Raspbian image with dump1090-fa & piaware package install.

Piaware image (sd card) command line
pi@piaware:

Raspbian image command line
pi@raspberrypi:

As obj already mentioned above, for package install, dont use piaware-config command. Instead edit file /etc/default/dump1090-fa


#14

ok obviously i have the rasbian installation and not the piaware image. I have done some installations before also the piaware image. i did some experiments and i think this when this was working i used it. so i didn’t know it anymore.

Well if i eddit de file dump1090-fa in /etc/default en do a restart sudo systemctl restart dump1090-fa then i see effect. so that works for me.

Now i want to experiment with the piaware stick directly on the antenna and play with the gain and hope that i receive better.
Well i also orderd a new antenna special for receiving ads-b signals (i have one, but this one is also longer).

I will let it know if i fif some experiment without the to long coax cable (and with my new antenna.

Thanks so far for the help. it was usefull


#15

Side note: You don’t need to remove the cable if you lower the gain anyway. Only if you need the maximum gain, then you can add a few dB by eliminating the cable. For me, I have a 5m cable, a filter (2.2dB loss) and still use only 42dB gain (from the max around 55).