Flight Aware Raspberry Pi Zero W


#1

After much faffing around I now have Flight Aware working on my Pi Zero W :slight_smile:


#2

Mine arrived today. The main gotcha is that the piaware 3.3.0 sdcard image won’t boot on a Zero W as it needs a newer bootloader + kernel. It should work OK if you start from the latest Raspbian image and do a package install.


#3

I used this image (Raspian Jessie WITH Pixel Desktop)https://www.raspberrypi.org/downloads/raspbian/
Worka a treat with the package install. Very happy indeed :stuck_out_tongue:


#4

What is the CPU load like?


#5

CPU load on the Raspberry Pi zero W is around ~40% with MLAT off and about 60-80% with MLAT on (depending on traffic).
Power usage is very low at around 150mA to 200mA for the Raspberry pi zero board.
Wifi is good for a PCB antenna.
The system runs very cool compared to other raspberry Pi boards (4 degree C cooler).

I definitely recommend using a USB micro to USB A pigtail cable to connect the dongle.
If you want to connect a monitor you would also need a mini HDMI to HDMI adapter.


#6

Good to know,
Thx


#7

The PiAware 3.5.0 sdcard image (just released) has the updated kernel/bootloader needed to support the zero W, so you should be able to just run that image with no special tweaking.


#8

[quote=“david.baker”]CPU load on the Raspberry Pi zero W is around ~40% with MLAT off and about 60-80% with MLAT on (depending on traffic).
[/quote]

Hi David - based on your testing do you think one of these can handle a high traffic area? In general terms 80% CPU utilization would be considered borderline too high. Did you measure while running Skyview?


#9

Tried getting piaware and beast-splitter running on pi-0W - FAIL

The pi-0W doesn’t have the horsepower. I’ve reimaged my old PiB+ and threw the pi-W in the junk drawer. I might use it for when I have to control Christmas lights in the winter…

P.S. I wish the piaware image had the SSH enabled. <<<<<-------------------

I’ve been up in the rafters 4 times now. I tried the trick of putting “ssh” in the /boot directory and it worked on the pi-0W but not the pi-B+.

I’m trying to decide if I even need to connect to it anyway…

Turn on the f’n SSH damnit! :slight_smile: <<<<<<<<<--------------------


#10

Thanks for the info on the Zero not being a hero. Think I will stick with my current setup

Rasp Pi has an admin interface to enable SSH. Worked well for me:

Launch Raspberry Pi Configuration from the Preferences menu
Navigate to the Interfaces tab
Select Enabled next to SSH
Click OK
Alternatively, raspi-config can be used:

Enter sudo raspi-config in a terminal window
Select Interfacing Options
Navigate to and select SSH
Choose Yes
Select Ok
Choose Finish

Link here: https://www.raspberrypi.org/documentation/remote-access/ssh/


#11

Creating /boot/ssh is 100% reliable for me.


#12

The 0W has a faster CPU than the 1B+, so I’m not sure what you’re doing…

1B+ is a BCM2835 / ARM1176JZF-S @ 700MHz
0W is a BCM2835 / ARM1176JZF-S @ 1GHz


#13

I noticed also, the flightaware control panel would try and send a command and I would get a blank screen, and the command never arrived at my computer.

I didn’t see a whole lot of CPU being used by beast-splitter or piaware, but when I connected to the dump1090 it would have no planes. Then about a minute later maybe 2 planes.

I tried telnet to port 30005 and whoosh there was a bunch of data coming in from the beast.

The data wasn’t going to flightaware, or dump1090 though.

My feeling was that the beast binary just wasn’t being processed fast enough.

But I didn’t analyze it to death, it was either it works or it don’t, using the stock config, or into the junk drawer. The PiB+ works out of the box, I did nothing. Out of the box the pi0W just took a nap.


#14

OK. My 0W works fine here with the piaware 3.5 image and a rtlsdr. Without more info I can’t say why yours doesn’t work.


#15

Which adapter is needed to not saturate the device?