Filter not producing desired result

When I connected the FA filter, the message rate dropped by almost half. There are a gaggle of cellphone antennas a little under 1/2 mile from here so I thought a filter would help. Anyone else seen this problem?

I moved the filter to another Pi/dongle/cantenna set up and saw similar results. …I’ve double checked all connections were tight too.

The production setup is FA antenna, 2 ft RG-6, RCA amp, 25 ft RG-6, power inserter, Fmale-Fmale adapter, Ffemale-SMAmale adapter, FA filter, pigtail to dongle on Pi. The production setup without the filter removes the Ffemale-SMAmale adapter, FA filter, and a different pigtail is used to connect the Fmale to dongle.

Thanks in advance.

Just some quick thoughts.

You say it is a filter but you show an RCA amp in the line. If it is truly an amp, it will amplify the noise as well as the signal you want.

Take your trusty DVM (You have one, I hope) and measure the voltage insertion at the end that attaches to the amp. Is it within the specifications set for the amp? (Either too high or too low would be bad.) Measure the AC component as well as the DC to see if there is ripple on the DC line.

Measure the resistance of all the passive pieces hooked together, cable, pigtails, etc. There should be infinity between core and shield, near 0 ohms between ends (core to core, shield to shield).

Ensure the amp, filter, whichever meets the frequency specifications (1090 mHz).

Ensure the amp and power inserter are in the line in the correct polarity.

I hope you don’t find these suggestions patronizing. That is not my intention. I’ve been troubleshooting stuff for customers for many years and have found it is best to start with the the obvious rather than assume these factors have been eliminated.

Good luck.

Thanks for the suggestions tdrane… much appreciated, and not patronizing at all.

The amp is an RCA D903 and its been functioning well for several months now. Its used by many others in this group. When I installed the amp there was a significant improvement in both aircraft and positions. Today I added the filter. I didn’t mention the timing in my original post. …probably should have. So I think the amp, power supply and inserter are OK since they are doing the job they were suppose to do. But it’s not a bad idea to do the checks you suggested anyway.

As far as measuring the voltage at the cable end going into the amp, yes, i can do that, but the amp is on the mast on the roof. That might have to wait until spring at this point. …snow and ice up there today :slight_smile:

I will check continuity on the new bits that I’ve added with the filter. That’s something that’s all inside the house.

Thank you

Have you looked at spectrum power (rtl_power or similar) with and without the filter?

tdrane: I checked DC continuity on the new pigtail, adapters and filter. There is continuity on the shielding all the way through to the end of the pigtail. The center core has no continuity through the filter, but it is OK on the other bits. Is the filter suppose to have DC continuity on the center core? I’ll have to look into that.

obj: You’ve got me… do you mean this: Rtl Power: Basic scripting. ? …haven’t used it, but happy to give it a try if this is the right tool.

Thanks again

if the filter doesn’t pass dc your amp should be after it.

Antenna → amp → power injector → filter → SDR
Do you have it setup in a different manner?

Yes, Antenna → amp → power injector → filter → SDR is the setup.

There is no DC connectivity through the filter. I’ve learned that this is normal, but that wasn’t my problem since I had it between the SDR and the power injector anyway.


… this combined filter/amp works great for me anthony is a nice guy and ships very fast …

Yes there should be a copy included with the rtlsdr tools. There are some scripts around to turn its output into something like a very wide spectrum waterfall. You can use it to look at power between say 800mhz and 1200mhz to see if there are actually strong signals you would benefit from filtering.

Here is a quick recipe for building/running rtl_power (you probably want to rebuild it from github as the ‘stable’ version is a bit buggy):

$ sudo apt-get install git build-essential cmake libusb-1.0-0-dev python-imaging
$ git clone
$ mkdir rtl-sdr/build
$ cd rtl-sdr/build
$ cmake ..
$ make rtl_power

$ ./src/rtl_power -f 800M:1200M:100k -i 30 -c 50% -e 30m -g 30 -F 9 >scan.csv

(wait 30 mins)

$ wget
$ chmod +x
$ ./ scan.csv scan.png

This will produce a very wide image (4000 pixels!) that shows spectrum power from 800MHz - 1.2GHz.

If you want a narrower image, increase “100k” above to something larger, it controls the bandwidth that corresponds to one pixel on the x axis.
-i controls the integration interval (time for one pixel on the y axis)
-e is the total runtime, longer gives you a taller image.

1 Like

Thank you obj, for the very detailed instructions. I will give that a try later today.

Here’s the sort of thing it produces (this is just a 15-min low res example I generated quickly):

You can see the (fairly faint) ADS-B band @ 1090MHz and the GSM bands around 920-960MHz. (they are not loud enough here to need a filter)

edit: here is the same thing with the FlightAware filter in place. The filter’s rolloff doesn’t really start until 940MHz so it doesn’t make a huge dent in the GSM band.

I gave this a go. If I’m reading this correctly, there is a bunch of stuff in the 850MHz to 890Mhz range, which I’m guessing would be cellular in the 850MHz band. I’m in Canada so we are on the North American GSM freqencies.

So I’m thinking the filter should help, but perhaps I’m reading these graphs incorrectly. …the brighter the yellow, the stronger the signal? although obj said in his post that the GSM 920-960 was not strong enough to benefit from a filter, and it looks like a fairly bright yellow. So I may be off base here.

Thanks again!

Yeah, brighter yellow is stronger. You may need to play with reducing the gain (-g parameter) so that the strongest signals don’t clip. There’s nothing that jumps out at me as a problem, maybe that signal at 930MHz but I don’t know, it doesn’t look all that strong.

The other thing to do is try a run with the filter in place. You should see basically everything below 900MHz disappear (or close to it). If that’s the case then the filter is probably working as designed, it’s just that you don’t benefit from it in your environment.

Did a run with the filter. Most everything below 900 is gone. The stuff around 930 is still there, as expected. I guess the filter is working as designed.

I’ll fiddle a bit with the gain to see if that changes the picture. I’ve been using “agc” in dump1090-mutability, and 30 for the -g parm in rtl-power. Spot checking a few stats from dump1090-mutability.log shows 5-8% of the messages are above -3dBFS (without the filter).

Thanks for your help.

I get an error after executing the the command before (wait 30 mins)

“Using device 0: Generic RTL2832U
usb_claim_interface error -6
Failed to open rtlsdr device #0.”

I am running it on a RPi with the latest piaware image, and a flightaware stick (blue).

I already tried stopping the piaware service and some other google recipies, but to no avail, so what am I doing wrong?

Edit: A map full of planes led to finding the solution. Piaware and dump1090-fa need to be stopped. Makes sense if you think about it :smile: