FlightAware Discussions

Feeding VRS without installation

Hi all,

i am running VRS on a Server whic is accessible in public. My devices at home are feeding it via rebroadcast which is working fine.

I’m wondering now if there is a different way feeding VRS without having a VRS instance installed on a local device? I would like to have it linked to the devices of two friends.

I know, i can pull the data from the running dump1090 instead of push, but that’s not feasible as the client IP changes frequently. I also do not want the clients to setup a DynDNS for it including opening ports on their routers.

Thanks in advance

edit: just saw the tutorial someone created recently.
Is this “socat” thing the right way to do so?

You can use socat.

You can use some scripting that wraps around socat:
https://github.com/wiedehopf/combine1090#install-data-redirection-only

Or you can use readsb:
https://github.com/wiedehopf/adsb-wiki/wiki/Building-readsb-from-source#net-only-forward-data-from-12700130005-to-1921682730004

Very good, thanks for the quick reply. I will dig into that.

@wiedehopf
I have it working with your combine1090 script. Both devices are feeding now to the VRS, works perfect!

Two questions:are unclear to me

  • Do i need to set up two more receivers in VRS for getting the MLAT data? How do i need to configure combine1090 for it? I only changed the TARGET section and left the PORTS untouched (30005 and 30105)
  • What happens if the pipe is broken, will it connect automatically again? I tested it manually with the socat command and this got killed everytime the connect stopped

Thanks in advance

It autoreconnects yes.

Well if you want separate MLAT in VRS (i think that’s better in VRS), then you’ll need to just use the CUSTOM field in combine1090.
Forward each port individually.
And open two ports in your router for different inputs.

Or rather you’ll need SOTA.


# for even more custom combination of soure/target, each pair specified in the SOTA variable is connected
SOTA="source:port/target:port source2:port/target2:port"

Just leave SOURCES at the top empty and this part will be disabled.
Then use SOTA do make it do exactly what you want.

Thanks for your response. Will check it.
I am using the VRS 3.0 Beta and i can select “MLAT” as checkbox if i merge the two feeds in VRS, whatever this option is for.

image

Quick update:

Both receivers are feeding the server now with your combine1090 script.
A small problem is that one of the receivers is not getting the connect again once it dropped. The other receiver is doing this perfectly.

I was able to reproduce it by disabling the receiver for this device for a moment and start it again. The logs are then telling me “connection refused”

Any idea at which point i should look at?
Currently i have a workaround set which restarts combine1090 every hours. This reconnects the stream if it got lost previously

Show the log for combine1090.

Also let’s check the config you are using.

OK, will provide the information later when i am back home

I’ve set up combine1090 on both Raspberries and configured it again in VRS.

Now it’s working and reconnects if the stream goes down.
was easier than trying to find the root cause of the problems.