Failed to start fa-mlat-client.service: Unit fa-mlat-client.service failed to load: No such file or directory [SOLVED]


#1

Rpi 3
Piaware SD 3.5.0 upgraded to 3.5.1

I had been feeding with this unit for nearly three years. Power outage killed the SD card. Performed a fresh install of 3.5.0 on a new SD, expanded file system, rebooted and updated. Fa-mlat-client will not start due to this error:

Failed to start fa-mlat-client.service: Unit fa-mlat-client.service failed to load: No such file or directory.

Everything is working except mlat, see below:

pi@piaware:~$ sudo piaware-status
PiAware master process (piaware) is running with pid 560.
PiAware ADS-B client (faup1090) is running with pid 927.
PiAware mlat client (fa-mlat-client) is not running.
Local ADS-B receiver (dump1090-fa) is running with pid 556.

dump1090-fa (pid 556) is listening for connections on port 30005.
faup1090 is connected to the ADS-B receiver.
piaware is connected to FlightAware.

dump1090 is producing data on localhost:30005.


#2

Resolved. It seems that replacing a failed SD card means re-claiming the device and losing the ability to continue uploading data to the same historical station ID. It’s working now, but no longer accumulating data under the original station ID.


#3

You can configure the feeder ID from your old site on the new install: piaware-config feeder-id <feeder ID from the stats page>


#4

Awesome, thanks. Took a few minutes to connect and initialize but it’s green on the local page now. Just have to wait for sync with other receivers now.