FlightAware Discussions

Error message when upgrading pi

pi@Pi-Flight:~ $ sudo apt update
Hit:1 http://repo.feed.flightradar24.com flightradar24 InRelease
Hit:2 http://flightaware.com/mirror/raspbian/raspbian buster InRelease
Hit:3 http://flightaware.com/adsb/piaware/files/packages buster InRelease
Hit:4 https://apt.rb24.com buster InRelease
Hit:5 http://flightaware.com/mirror/raspberrypi/debian buster InRelease
Hit:6 https://opensky-network.org/repos/debian opensky InRelease
Reading package lists… Error!
E: Problem parsing dependency 64
E: Error occurred while processing med-bio (NewVersion2)
E: Problem with MergeList /var/lib/apt/lists/flightaware.com_mirror_raspbian_raspbian_dists_buster_main_binary-armhf_Packages
E: The package lists or status file could not be parsed or opened.
pi@Pi-Flight:~ $

What kind of Pi? What OS?

Might be sdcard corruption. You may need to wipe out the bad copy of the lists file (the path under in /var/lib/apt/lists/ that you quoted) and try again; apt should re-fetch the file.

Raspberry pi 3b+

Linux Pi-Flight 5.10.63-v7+ #1459 SMP Wed Oct 6 16:41:10 BST 2021 armv7l

obj,
your suggestion work fantastic. I am now back up and running. Thanks
Mike