FlightAware Discussions

Dump1090-fa no longer appears when i do 'top'

Not sure if this is the correct forum to post this problem.

Been a feeder for over a year. Suddenly, past day or two, my PiAware isn’t running properly and isn’t feeding.

When i ssh on my home network to the Pi, and run ‘top,’ dump1090-fa is no longer in the list. When i run ‘sudo systemctl restart dump1090-fa’ it is still not on the ‘top’ list. Re-boot doesn’t remedy the issue.

I thought that perhaps i needed to do the software update, so i followed the instructions in the email that was sent out. As far as i can tell, no update occurs. I’m not sure that an update can even occur, since i’m sending the update command from a computer other than the Pi. My ISP changed its networks recently – one person said it is now NATed but i don’t know if that is the case – and for some other apps of mine (for which i’d set up port forwarding), those apps won’t work. (The ISP said i would need a static IP.)

I’m wondering if that could explain why no update is happening. FA can’t find a return path to my Pi. Is there a way to do a command-line update of PiAware from the Pi itself?

Thanks for help.

Orrin in NE California

Now it’s a couple hrs later and my device is functioning again, and dump1090-fa is back on the ‘top’ list.

Also, i was able to upgrade to 3.7.1 using the console, and i see that version number on my stats page, and my MLAT is working.

So i’m not sure what was going on. I’ve never experienced quite this, before. Thanks for any comments.

You replied as I was typing this, but it may be useful for future reference.

You can check if dump1090 is running by doing:

piaware-status

which will show whether the various piaware components are running or not.
You can also see if dump1090-fa is running directly by doing:

sudo systemctl status dump1090-fa

That will tell you directly the status of the dump1090-fa service, and may show any error messages from it failing to start.

You can search the system log for error messages relating to dump1090 by doing:

sudo journalctl -u dump1090-fa.service

which will print any recent messages logged by dump1090 and may give some clue as to what was happening.

As far as NAT is concerned, that is not a problem at all for feeding data - the piaware client makes an outgoing connection to the server, so there is no need for you to have a static IP. If you ping flightaware.com on the pi and get a response then you should have no issues feeding data.

It’s possible the rtl dongle became unstable for a period which does sometimes happen due power supply fluctuations and has since recovered.

1 Like

If nothing had changed on the software side when this happened, then this is probably a hardware issue that’s developed over time - the most common cause is your power supply going bad. Try swapping the PSU.

Thanks caius and obj.

Thanks caius for all the syntax examples. Am copying those to my journal.

There have been a couple very short power outages here lately. One of these days it’ll result in a corrupt SD card (happened once about 14 months ago) and i know what to do in that case.