FlightAware Discussions

Another "Problem fetching data from dump1090"

Hi,
Evrything was working perfectly and after trying to use my RTL-SDR dongle v.3 with DVB-T (unsuccessfully), it stopped working and now I have an error message and no planes on the map:

Problem fetching data from dump1090.
AJAX call failed (error). Maybe dump1090 is no longer running?
The displayed map data will be out of date.

After digging around, I think there is a problem with lighttpd which doesn’t want to start. Here is the journal:

Jan 27 20:24:28 Romanopi systemd[1]: Starting Lighttpd Daemon…
Jan 27 20:24:29 Romanopi lighttpd[4142]: 2021-01-27 20:24:28: (configfile.c.1296) source: /etc/lighttpd/conf-enabled/89-dump1090-fa.conf line: 75 pos: 1 parser failed somehow near here: (EOL)
Jan 27 20:24:29 Romanopi lighttpd[4142]: 2021-01-27 20:24:28: (configfile.c.1296) source: /etc/lighttpd/lighttpd.conf line: 47 pos: 15 parser failed somehow near here: (EOL)
Jan 27 20:24:29 Romanopi systemd[1]: lighttpd.service: Control process exited, code=exited, status=255/EXCEPTION
Jan 27 20:24:29 Romanopi systemd[1]: lighttpd.service: Failed with result ‘exit-code’.
Jan 27 20:24:29 Romanopi systemd[1]: Failed to start Lighttpd Daemon.
Jan 27 20:24:29 Romanopi systemd[1]: lighttpd.service: Service RestartSec=100ms expired, scheduling restart.
Jan 27 20:24:29 Romanopi systemd[1]: lighttpd.service: Scheduled restart job, restart counter is at 5.
Jan 27 20:24:29 Romanopi systemd[1]: Stopped Lighttpd Daemon.
Jan 27 20:24:29 Romanopi systemd[1]: lighttpd.service: Start request repeated too quickly.
Jan 27 20:24:29 Romanopi systemd[1]: lighttpd.service: Failed with result ‘exit-code’.
Jan 27 20:24:29 Romanopi systemd[1]: Failed to start Lighttpd Daemon.

Although I got it to start by removing the 89-dump1090-fa.conf file, it didn’t solve the issue.
Finally, here is the piaware status :

PiAware master process (piaware) is running with pid 6163.
PiAware ADS-B client (faup1090) is running with pid 6200.
PiAware ADS-B UAT client (faup978) is not running (disabled by configuration settings)
PiAware mlat client (fa-mlat-client) is not running.
Local ADS-B receiver (dump1090-fa) is running with pid 6128.
dump1090-fa (pid 6128) is listening for ES connections on port 30005.
faup1090 is connected to the ADS-B receiver.
piaware is connected to FlightAware.
dump1090 is producing data on localhost:30005.
Your feeder ID is 34465f58-06a3-4141-88b2-61c43fe971a4 (from /var/cache/piaware/feeder_id)

I don’t know why ADS-B UAT client (faup978) and mlat client (fa-mlat-client) are not running, if it is normal or not and how to update the configuration settings.

After having digged around quite a bit in this forum, I decided to ask you directly if someone could help me. Please.

Best regards.
Romain

What sdcard image did you start with?
What modifications did you make?

faup978 only runs if you have configured a dongle to recieve 978MHz (UAT) signals instead of 1090MHz signals. (That is why it says “disabled by configuration settings”)

mlat require a claimed ADS-B site that has had its location configured. You don’t appear to have any claimed sites. Claim your site and then configure the site location at https://flightaware.com/adsb/stats/user/romton

Thank you for your fast answer.
I started with an official Debian image from Raspberry website and I installed oppenplotter which includes ADS-B software and dependencies as well as GQRX that works perfectly, and a DAB and DVB-T options (that I cannot make working either).
Happy to hear that faup978 and malt are not the issue.

You’ll probably need to look at what changes, if any, that openplotter made to the lighttpd config.

Well first one would need to restore the deleted 89-dump1090-fa.conf file.
The easiest way would be to purge dump1090-fa and install it again using apt.

Then check what’s in the line that fails:

I’m not sure what you used to get that log i believe you might have some stuff cut off.

sudo journalctl -u lighttpd | tail -n30

The above command will give you everything you should need.
Though if you have this file: dump1090/89-dump1090-fa.conf at master · flightaware/dump1090 · GitHub

Then the error doesn’t really make sense.
You could one by one disable other lighttpd config modules and find which module it’s conflicting with …

lighttpd-disable-mod
lighttpd-enable-mod

Both to be used with sudo.
This will give you a list of enabled modules:

ls /etc/lighttpd/conf-enabled

When using those names with the enable/disable you have to not include the number- and .conf of the files.
Just note down which you disable so you can reenable them …

Hi, thank you for your answer and your help.
That was indeed 89-dump1090-fa.conf that was the source of the problem.
Although I had tried to uninstall and reinstall lighttpd as well as dump1090-fa, it didn’t solve the issue.
However, as you suggested, downloading the 89-dump1090-fa.conf directly from GitHub solved everything.
I should have tried that earlier. I just thought reinstalling those two softwares would fetch the fresh file from GitHub as well.
Anyway, thank you so much.
Hopefully, that will be useful for someone else someday.
Best regards.
Romain

purge and install will.
Well … if it’s solved it’s solved i suppose.

Yeah, I guess it didn’t purge well enough. :slight_smile:
Thanks again.

The folder /etc/lighttpd and all it’s content stay undeleted even if you use command sudo apt-get purge lighttpd. I always manuay delete this folder after uninstalling/purging lighttpd.

You’d need to reinstall all kinds of stuff i you have multiple applications with configs in there.
So i wouldn’t recommend it.
I also vaguely remember making a PR for dump1090-fa to delete the dump1090-fa config file in conf-available and the symlink in conf-enabled … at least that’s the sensible thing to do for a purge.
Anyhow can’t be bothered to check :confused:
I suppose it would be in the postremove script in the debian folder?

True, but I dont have any other installation except dump1090-fa which use lighttpd.

The lighttpd cannot be uninstalled alone, being depaendency of dump1090-fa, so I purge both, first dump1090-fa, then lighttpd, and then delete folder /etc/lighttpd.

Later I install dump1090-fa, which installs lighttpd automatically (as dependency) as well as lighttpd config files for dump1090-fa.

Here’s the relevant bit of postrm that cleans the symlinks. (note that purge runs both “remove” and “purge” steps)

dpkg itself handles removing the underlying config files on purge.

Not directly related to this thread but of academic interest (it is about lighttpd and dump1090-fa on Arch Linux):

(1) Remove packages with following command

sudo pacman -Rns dump1090-fa
sudo pacman -Rns lighttpd

Where:

-R, --remove

Remove package(s) from the system. Groups can also be specified to be removed, in which case every package in that group will be removed. Files belonging to the specified package will be deleted, and the database will be updated. Most configuration files will be saved with a .pacsave extension unless the –nosave option is used.

-n, --nosave

Instructs pacman to ignore file backup designations. Normally, when a file is removed from the system, the database is checked to see if the file should be renamed with a .pacsave extension.

-s, --recursive

Remove each target specified including all of their dependencies, provided that (A) they are not required by other packages; and (B) they were not explicitly installed by the user. This operation is recursive and analogous to a backwards –sync operation, and it helps keep a clean system without orphans. If you want to omit condition (B), pass this option twice.

(2) The lighttpd folder /etc/lighttpd/ contains only the file lighttpd.conf. It lacks folders conf-available, conf-enabled or conf.d.

(3) In lighttpd config, module_alias is not enabled. It has to be enabled by user.

For above reasons, I manually create directory /etc/lighttpd/conf.d and manually add following two lines in file /etc/lighttpd/lighttpd.conf

server.modules += ( "mod_alias" )
include "/etc/lighttpd/conf.d/*"

(4) If dump1090-fa package (built on Arch Linux using source code) is installed:

The dump1090-fa package installs lighttpd also as dependency. It then configures it by adding above noted two lines in file /etc/lighttpd/lighttpd.conf. In addition it creates folder /etc/lighttpd/conf.d and copies files 88-dump1090-fa-statcache.conf and 89-dump1090-fa.conf to this folder.