FlightAware Discussions

Airspy R2 Pi4 mlat loosing sync

Hello all, I upgraded to an Airspy R2 (in readiness for my antenna being mounted at height on the side of my house).

Pi4 running off SSD - new clean install of OS / Piware / used wiedehopf(@wiedehopf amazing work) script to get airspy up and running and the only other thing I have installed is graph 1090.

I have UPUTRONICS ADS-B 1090MHz Filtered Preamplifier connected to the airspy and that connects to a ADS-B 1090 MHz Antenna (1.2m, 8.5dBi) - I have a decent power supply and the pi is running 31c.

I keep loosing mlat sync when connected its syncing with circa 600 nearby receivers - Im seeing this message in the logs mlat-client(1008): Server status: clock unstable

my airspy is set up in options as follows
Gain=21
Options= -v -f 1 -b -e 8.5 -w 4 -t 120 -m 24
Sample_Rate=20

What am I getting wrong ? I have read and read the forums and can’t figure it out… Any help would be very gratefully received.

Just run 20 as the sample rate … you added -m 24 which means 24 MHz sample rate.
Either way … you’re specifying it twice.

Might be the USB isn’t keeping up or maybe the -e setting is too high and you’re losing stuff (check syslog).
But -e being too high usually doesn’t cause MLAT issues.

Oh now just read … an SSD is not a good fit with the airspy as you have two things on the USB bus, that can cause issues.
See if it works with 20 MHz … maybe even try 12 MHz most people only have minor differences between the sample rates.

Or don’t run off an SSD … really should’t be necessary unless you also do other stuff on that pi.
You could also try overvolting a bit that helps for some USB stuff on the pi apparently. (/boot/config.txt)

1 Like

swapped out the USB SSD for SD Card. Reset up and now it looks good. Thank you…

defo the SSD - running for >12hrs now without desynchronisation from MLAT. Thank you