Swapped my RPi3 for a pi0W and destroyed my range! [SOLVED]


#1

Hi Trackers!

So I’ve had my system up n running for 32 days and have slowly been improving it. So far, for what it is, I am pretty happy with my results. I am feeding FA, FR24, Plane Finder (love their 3D polar plot!) and Radarbox24.

I have been running a headless RPi3 with an el-cheapo DVB-T R820T dongle that I bought from ebay, connected to a 12 segment collinear that I made which is on top of a 5.8m mast. No amp, no filters. My max range has been 235Nm and I average around 108Nm, so pretty happy with that given my location and basic set up.

Some pics.
Pic 1
Pic 2

My pi zero W arrived yesterday, this was to permanently replace my RPi3 so that I could use it for other projects. I copied the image across and got it all fired up and left it overnight. By this morning it was obvious that my range had dropped significantly.

Although the zero is working a bit harder (40-80%) I don’t think it is a ‘grunt’ problem. I am suspecting that the micro USB adapter is getting some interference from the power cable being located right next to it. Either that or the dongle I am using has a problem running through a USB adapter as I did have a similar problem when I tried a much longer extender (different one) with my RPi3.

Currently I am going to try a completely fresh install of everything rather than an image of initial setup from from RPi3, though it might be a couple of days before I get the chance to try this.

Has anyone had similar or have any suggestions?

Cheers.

[Solution: Swapped my RPi3 for a pi0W and destroyed my range! [SOLVED] ]


#2

i used dongles on short (3-5") usb-cables and never experienced any problems - so i think it is just a problem with the cable you use -> try a different (short) one. on the other hand i used pi zero w alternative to rp2 rp3 and exactly got the same aircrafts and message-rates. i tested the pi zero w on my roof antenna with up to 300 aircrafts in parallel and mlat enabled - worked just fine cpu-load was about 80%.

so - seems to be just a minor problem - and as soon as you overcome this you will be happy with the results your pi zero delivers and have a spare rp3 to tinker :slight_smile:

btw. very very cool antenna-mast!


#3

Thanks for the feedback. I will experiment some more over the next few days and see if I can nail down the cause.

Thanks! This is Antenna mast V2.1. It’s not my house so I can’t make any permanent fixtures so this is what I came up with. Been getting tested lately too with some strong winds and it works well.


#4

Update.

I have tried a clean install without any improvement. Running the zero, my range drops off significantly. Reconnecting the RPi3, my range almost immediately returns. Other hardware/settings remain unchanged.

It seems to me that the pi zero w isn’t up to the task for a long range, mid traffic volume tracker. Running “$ top” it shows the load average regularly above 1 and sometimes over 3 whereas it is around 0.20 on the RPi3. It looks to me like it is just too much for a single core.


#5

ill do a short test on my splitter and replace one of the rp2 with a pi zero for 5 minutes and see what happens. give you feedback in 10 minutes.


#6

took some minutes to find usb-micro-male to usb-a-female cable for dongle and until mlat sync.
both ran in parallel behind minicircuits splitter and uputronics lna/filter using the same jetvision antenna and two cheap/lightblue nooelec standard dongles.

result pi-zero w:

  • total aircraft 253
  • with position 194
  • messages/sec 1,313
  • cpu-load 66.4% (dump/mlat/piaware/faup) overall load 56.4%

result pi2:

  • total aircraft 249
  • with position 194
  • messages/sec 1,352
  • cpu-load 49.7% (dump/mlat/piaware/faup) overall load 9.6%

cheers
tom


Post your PiAware setup
#7

Could the issue be heat…? Seeing the Zero is running harder!


#8

On a RPi Zero W the dump1090-fa decoder uses about 50% of the CPU and usually about 30% is used by the MLAT system. The dump1090 decoder doesn’t vary too much in amount of processing vs incoming message rate but the MLAT system can vary a lot. I have seen the MLAT system use CPU more than the dump1090-fa decoder.

My suggestion is to try to turn off the MLAT system using piaware-config. Then check what CPU usage you are seeing.

Command to turn off MLAT
"piaware-config allow-mlat no"
then reboot

Webpage that explains piaware-config
https://flightaware.com/adsb/piaware/advanced_configuration


#9

@david.baker

that was my thought too - as in usa there is often a very high mlat percentage within flights which costs lot more cpu than ads-b data. but when i looked two days ago at his stats and saw that he has just 15% of the aircrafts i have and only 7% the mlat aircrafts i see per day - i was thinking this effect couldn’t be the reason?!?

http://flightaware.com/adsb/stats/user/Ant73#stats-63695
https://flightaware.com/adsb/stats/user/TomMuc


#10

The receiver dongle pushes out blocks of data at a very constant rate. The dump1090-fa decoder process these blocks and then outputs how many ADSB messages are in that block of data.
It cost about the same amount of CPU if there are 10 ADSB message in the block or 0 ADSB message in the block.

I am not sure if there is something else going on with his RPi Zero W system. But turning off MLAT will isolate whatever the problem is to a very predictable part of ADSB decoding.


#11

I wanted to do some testing and set up a Zero W in the loft with a spider. I received a maximum of around 110 aircraft which was far lower than I expected with a message rate maxing out at around 500/s.

I took the SD card out, put it in a Pi3 and rebooted, instantly up to around 250-270 aircraft and messages up at 1500/s

Here’s the difference between the overall CPU Utilisation on the performance charts. It was sitting around 60% on the Zero W and 15% on the Pi3.

Pi


#12

did you use the fa rady to go sd-card-image or did you install anything from scratch. i’m wondering what happens here with ant73 and your pi-zero - as mine works like a charm up to 300 aircrafts and above running from the same sd-card i use in the pi2! what dongle do you use? did you try different usb cables to connect the dongle? i’m wondering if it could be possible that there is so much noise on other frequencies that the workload from usb-dongle increases so much that the zero is not able to compute all incoming data …

this was my setup for test above - but i used the standard lightblue nooelec dongle connected to the splitter


Poor performance with antenna plugged directly into ProStick+
Antenna Length
#13

Thanks everyone for the help.

I’m installing everything from scratch on Raspbian and using dump1090-fa. I’m wondering whether mutability would make any difference?

Tom, I presume you are using a FA stick, so it is amped and filtered? I wonder whether the zero could be more sensitive to an un-amped, unfiltered signal?

Although it is running much harder, it doesn’t seem to be running any hotter than the RPi3 strangely, so I don’t think that is it. It seems to run around the 40-45C mark according to the panel temp monitor.

I haven’t tried switching off MLAT but, as TomMuc says, I don’t really see a lot of MLAT data.

Here’s some pics. I only have one dongle and don’t have a splitter so I can’t ran both pi’s at once unfortunately. I was going to try making a USB splitter to run both off the one dongle but I’m not sure that would even work.

I have been doing most of my testing during quiter times.


Zero [left] vs RPi3 [right]. I waited until the aircraft to the west dropped off the zero and quickly switched after the dropped ACFT came back + more.


Zero after running all night. I don’t see a lot of traffic overnight but the ranges should be much higher.


A few minutes after switching to the RPi3


Although not conclusive, I couldn’t have been lucky enough to match the peaks and troughs with switching pi’s.


#14

Tom, I just saw your last post after I submitted.

Here is the dodgy dongle I bought.
http://www.ebay.com.au/itm/New-Receiver-DVB-T-DAB-FM-RTL2832U-R820T-Tuner-Mini-USB-RTL-SDR-ADS-B/252895415029?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2057872.m2749.l2649

No doubt a better quality one would work better but I wanted to see whether I could get it working first. Now I am trying to decide whether to get one with a built-in filter or not. Not sure I need a filter. I did try setting up gqrx to see if I could see what frequencies my antenna is picking up but I couldn’t get it to work. Perhaps the dodgy dongle isn’t compatible?

I only have one USB/micro USB adapter that I ordered with my zero.

I have tried a few various power cables though including the official pi power supply.

edit
This is the overnight 3D polar for my RPi3 for last night.


#15

Try upping the usb output current. By adding max_usb_current=1 in the /boot/config.txt


#16

@Ant73

i’m using the super-cheap 18€ nooelec standard dongles behind low-noise-amplifier with saw-filter and splitter: https://www.amazon.com/NooElec-NESDR-Mini-RTL2832-Antenna/dp/B00P2UOU72/ref=sr_1_9?ie=UTF8&qid=1506559069&sr=8-9&keywords=nooelec


#17

Given you’ve replace almost everything, I’d be looking very hard at your PSU. Many USB PSU’s supply slightly under 5V and this will affect the gain and stability of your dongle.
Try using the ‘brand name’ charger that came with your phone rather than a ‘no-name’ unit from your junk box.

As for your “dodgy dongle”, they are cheap and cheerful, but work great. Yes you can do better, but they still perform very well.


#18

Yea I’ve tried a few different ones already including the official raspberry pi power supply.


#19

I’m trying this out but I have to reflash the SD. I’ll report back when I’ve tested it.

edit

While waiting for the img to copy to the SD, I found this. Not sure this mod will have an effect now.


#20

Nope! No change setting max_usb_current=1. I’m not sure that the zeroW is limited like earlier models though.I have run out of things to try I think.

Perhaps a better dongle and/or filter would give better results with the zero? Maybe the RPi3 can compensate better for el-cheapo dongles performance?


Zero [left] after 30 mins Vs RPi3 [right] about 2 mins after shutting the zero down.