Raspberry OS / Raspbian updated to Debian 11 "Bullseye"

Or simply change it. That’s what i did
Replacing “buster” with “bullseye” should not be that challenging, even if you need to revert it.

This is possible in Raspberry Pi OS Buster image.

I upgraded Piaware SD Card Buster image ver 6.1.
In this image the Buster repo is mirrored through Flightaware.
I changed Buster to Bullseye, but got warning during update that Bullseye repo does not exist in Flightaware mirror. I then commented out the line for Buster which was mirrored through Flightaware, and added line for Bullseye which was direct to raspberrypi.org repository

Oh, that’s what i did not read…

I upgraded 18 Pi’s and Orange Pi’s in the last few days
Upgraded from buster to bullseye without reimaging the cards.

Orange Pi’s went without a hitch ( 3 of them are flightfeeders) and were up and running in about 45 minutes.

Raspberry Pi’s complained all about an issue with libc6-dev package.
That could be fixed using sudo apt install gcc-8-base
After that a sudo apt full-update runs perfectly.
This sidestep took another 15 munites so raspberry’s were around 1 hour of upgrade time.
Longest time needed was for a Pi 2 upgrade, that took almost 4 hours to complete.

No reinstallation of any FA,FR24 or ADSB package was needed, all were up and running after the reboot.

1 Raspberry Pi to go but that will have to wait. My home automation depends on Phyton and the Bullseye version of 3.9.2 is not yet incorporated into the home automation software.
It knows version 3.4 and 3.5 but not 3.9
When that software is updated I can do the last upgrade from buster to bullseye.

I know I could do a remiage and work around the Phyton issue that way but It would be very time consuming to export and import all my Phyton scripts again :wink:

And i thought i have too much with four devices.
May i ask what they’re all doing?

You can answer per PN as it has nothing to do with the thread.
I am interested on other Raspberry projects for my spare devices

If Bullseye runs just fine on the PiAware SD card image build, why isn’t the upgrade available from the default FlightAware hosted repositories? Just curious.

This will be the case in version 7, when it will be relaxed, no indication yet.
That’s what I understand, when version 6.1 was released buster was the stable release and bullseye was still in the testing phase

My already bullsey-upgraded Raspberry 3 reports now the following packages are held back:

  alsa-utils apt apt-utils aptitude aptitude-common build-essential cpp cpp-8 dh-python g++ g++-8 gcc gcc-8
  gcc-8-base gdb gir1.2-glib-2.0 groff-base hardlink htop iproute2 iptables jq libalgorithm-diff-xs-perl
  libasound2 libasound2-data libatlas-base-dev libatlas3-base libbrotli1 libc-bin libc-dev-bin libc6 libc6-dbg
  libc6-dev libcairo2 libcommon-sense-perl libfcgi-perl libfile-fcntllock-perl libgcc-8-dev libgfortran5
  libgirepository-1.0-1 libglib2.0-0 libhtml-parser-perl libhttp-message-perl libipc-sharelite-perl libiptc0
  libiw30 libjq1 libjson-xs-perl liblcms2-2 liblocale-gettext-perl libluajit-5.1-2 libluajit-5.1-common
  libpam-systemd libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpixman-1-0 libpng16-16
  libpolkit-agent-1-0 libpolkit-gobject-1-0 libpython2-stdlib libpython2.7-minimal libpython2.7-stdlib
  libpython3-dev libpython3-stdlib librrd8 librrds-perl libslang2 libsqlite3-0 libstdc++-8-dev libstdc++6
  libsub-name-perl libsystemd0 libtext-charwidth-perl libtext-iconv-perl libtiff5 libudev1 libwbclient0 libwebp6
  libwebpmux3 libxapian30 libxml2 libxtables12 locales luajit mawk mc mc-data perl perl-base pigz policykit-1
  python2 python2-minimal python2.7 python2.7-minimal python3 python3-apt python3-cffi-backend python3-cheetah
  python3-dev python3-distutils python3-gi python3-lib2to3 python3-minimal python3-pil python3-rpi.gpio
  python3-six rpi.gpio-common rsyslog sqlite3 systemd udev wpasupplicant

This occurs on every usage of apt upgrade. Usage of apt full-upgrade was required to get them updated.

Just in case someone has the same problem

 
That is exactly why I posted following procedure twice
NOTE: The command apt full-upgrade performs same function as apt-get dist-upgrade
 

 
 

After upgrading by command sudo apt full-upgrade OR sudo apt-get dist-upgrade, one must also issue command sudo apt autoremove to cleanup packages which were installed, but are no longer required.

 

Time. It takes time to update and test new things.

We don’t mirror bullseye yet because no image configured to use that mirror would do anything with it - it’d just be a waste of bandwidth and storage.

Note that even after the sdcard image moves to bullseye, we have no plans to support an in-place update from buster to bullseye for existing installs.

It was working without the procedure. I never used “dist-upgrade”

 

Old timer “dist-upgrade” and relatively new “full-upgrade” do the same thing, but “upgrade” does somewhat different thing.

I initially used only “upgrade”, and noticed warnings whenever tried later to update or install a new package.

I then again wrote the image to microSD card, and this time used “dist-upgrade”, and there were no warnings when subsequently tried to update or install a new package.

I then again wrote the image to microSD card and this time used “full-upgrade” and it behaved exactly same as “dist-upgrade” i.e. no problems when subsequently tried to update or install a new package.

1 Like

I ran into a nice quirk that took me some time to figure out so let’s document it here :wink:

Bullsey has a new feature hidden in the graphical user interface called Connman ( Connection manager).
All my Raspberry Pi’s I’ve upgraded claimed a DHCP adress on the network and they also have a static IP adress.
I wanted to get rid of the DHCP addresses and couldn’t figure out how.
Dhcpcd.conf file was set correctly, i could release the address with the command sudo dhclient -v -r and within 24 hrs it was back again. :face_with_monocle:

After a few days of trial and error I stumbled upon this post describing the feature:

Turns out that Connman is set to automatic by default by Bullseye and that way is claiming a DHCP address.
So if you have this issue then loging into the Pi then this might be the solution.

Either use the GUI interface by running raspi-config and let the system login to the desktop.
Under preferences you will find the Connman option.
Set the IPv4 adress from Automatic to Manual and set the Static IP address.
Then hit apply and your address wil be changed to the static IP adress.
When done rerun the raspi-config and revert back to the CLI if you are running your Pi from there.

Other option is to use the CLI variation of the Connman program
http://manpages.ubuntu.com/manpages/bionic/man1/connmanctl.1.html

I was able to resolve my issue with double IP adressing ( on the same interface 2 ip adresses) and all is the way I want it once again :wink: :relaxed:

1 Like

After experimenting with successful upgrade to Bullseye in following ways, I came to conclusion that currently there is no real advantage of doing so (EXCEPT for Pi Zero 2 W which has some issues with Buster):

  • In-place upgrade of Piaware SD card image from Buster to Bullseye
  • In-place upgrade of Raspi OS Buster to Bullseye
  • Re-imaging with Raspi OS Bullseye, and package install by building packages from source code.

It is better to continue with “Piaware SD card image 6.1 (Buster based)”, OR “Raspi OS Buster” with package install, till Flightaware releases Bulseye based SD card image and packages for piaware & dump1090-fa.

PiAware Image on Raspbian Linux 6.1 ZIP

Raspi OS Buster armhf Lite.zip

Raspi OS Buster armhf.zip

 

1 Like

If my primary laptop crashes - shit happens
If my cloud device crashes - my wife will deny serving food until it’s fixed

:joy: :joy: :joy:

One problem with trying to upgrade Buster to Bullseye while holding back current versions of PiAware 6.1’s dependencies is that you end up with a FrankenDebian that’s part Bullseye, part Buster and that can lead to issues later on (plus I suspect that FlightAware staff won’t support such a system.) See DontBreakDebian - Debian Wiki. Problems may not occur right away but start happening weeks or months later. Not good if your Pi’s in a remote or difficult to access location. You’re better off freshly installing Raspbian Bullseye from scratch then either compiling PiAware from source so it builds for the versions of system libraries etc. that come with Bullseye or even better, waiting for PiAware 7 packages to be available before installing Bullseye. Buster will be supported by Debian until June 2024 so there’s no reason to hurry and upgrade now. You have plenty of time.

 

Yes, very true, except for Pi Zero 2 W, which has issues with Buster, and it’s only option is to use Bullseye.

 

Early adopters often have issues like this.

 

 

Package install of piaware 6.1 on Bullseye 32-bit & 64-Bit