FlightAware Discussions

PI working, FA says no connection/data

Got the outage email this morning. Went to check my PI site

I see live data and my server sees live data but not FA?

Any ideas?

(*note) I am at work til evening so cant pull any logs or stuff but welcome any comments or suggestions)

Have you restarted the service or rebooted the RPi?

That is live data from VRS. The data is coming from local dump1090-fa installation.
Piaware is the part which delivers data to Flightaware.

Very likely that your local dump1090-fa is running, but the piaware service has been stopped.

You need to SSH into your Raspberry and check the status of the Piaware Service with

sudo systemctl status piaware

It should return something similar like this:
Active: active (running) since Thu 2020-11-19 14:17:22 CET; 3 days ago

if this is not the case, (re)start the service with

sudo systemctl restart piaware

and verify it afterwards again with the command above.
If this is not working, try it with restarting your device. If still not working, follow the instructions to get piaware installed again (see Step 2 in the install documentation):

I restarted the device when I got home, and seems to be working fine now.

Just never had it supply data to server but not FA before.

Thanks guys!

If you log into FA and go to the sites stats page. Go to the settings page (select the little paddle wheel).
You can restart the Pi or just PiAware without needing to be on the local network.

I tried that at first, but seeing it was not connected to FA kinda not a viable option at the time.

Never had issues like this before (old pi lasted 3 years streak before lighting took it out)