FlightAware Discussions

Multilateration (MLAT) Beta

How about removing the MLAT info at 60 seconds so they just appear as white in the table. (or is that what you meant?)

Yes I guess that’s what I meant: remove the MLAT info after 60 seconds, revert to White in the table AND remove icon from the map.

Seen my 1st MLAT results this afternoon.

How do i upgrade my dum1090-mutability to 1.15, so i have a different color for MLAT Positions? Thanks!

As far as I know, there is no packaged version available. So you will have to build it yourself. Instructions here:
post177419.html#p177419

obj has great instructions here to use his repo to install the pre built packages which works very well

ads-b-flight-tracking-f21/raspbian-ubuntu-packages-for-dump1090-mutability-available-t19619.html

I have a question. I know this is probably a dumb question. How do I know or check if Mlat is working? I am running a Pi with Dump1090-Mut. When I bring up the map to see the dump running on the right side, it says V1.14.

Thanks.

The tally/grid board highlights MLAT targets with a blue background (along with the white and green backgrounds for no position and co-ordinate positions). Also when you select one of those targets, you’ll see MLAT in the flight data breakdown.

Ok. Thanks for the reply. I never seen a blue line on the right side. I have a lot of white and green, but no blue.

Which PiAware are you running? That’s the key program that sends back the mlat data for dump1090-m to display.

Also, I believe you need to run dump1090-mutability v1.15~dev OR the FA-supplied dump1090 to be able to see the blue lines. dump1090-mutability v1.15 has not been released yet as a pre-built package but you can build it yourself from source. See post177419.html#p177419 on how to do that.

piaware will also log the rate of mlat results it’s receiving periodically to /tmp/piaware.out, which is another way to check if you’re not running a dump1090 that highlights them.

I got it working. Thanks everyone for the help. :smiley:

Doing some work on the server side at the moment which may impact returning results to receivers. If you seem to have stopped receiving results, try restarting piaware, that should fix it.

Had to that this morning. Working ok now. Thanks for the heads up Obj… :smiley:

OBJ: no longer receiving MLAT birds. Restarted piaware etc. Joe K4AA

You may need to restart it a couple of times (basically only one of the two servers that piaware connects to are currently returning results, you need to end up connected to the right one, and it’s a bit random which one you get each time)

OBJ: OK 4th reboot hit the right server. Thanks . . .Joe K4AA

Is this the display from the dump1090 output? Can someone post a screenshot as to what it should look like if you are display MLAT hits?

This is done in dump1090-mutability now, it seems to work fairly well. If you select the plane from the table it’ll show the last position / track.