MLAT issues?


#1

This just started happening. I see it in the logs repeating constantly

[2016-04-19 10:27 CDT] Starting multilateration client: /usr/lib/piaware/helpers/fa-mlat-client --input-connect localhost:30005 --results beast,connect,localhost:30104 --udp-transport 70.42.6.198:5342:539399416
[2016-04-19 10:27 CDT] mlat(29117): Fatal Python error: PyImport_GetModuleDict: no module dictionary!
[2016-04-19 10:27 CDT] this is a little unexpected: the system told us that process 29117 exited after receiving a SIGABRT signal
[2016-04-19 10:27 CDT] got EOF from multilateration client

Was there an update recently? I have automatic updates turned on.


#2

No there were no updates recently.

I vaguely recall seeing this before and it turned out to be sdcard corruption.


#3

I restarted and the errors seemed to have stopped. I assume the corruption was correctable when the fsck was run on startup. I’ll check the logs in more detail. The funny thing was that my “Other” category which is normally less that 100, jumped up to a 1000 and my MLAT went way down. Let me watch it for a while to see if it goes back to normal. I might reflash the SD when I get a chance.

Thanks…


#4

Yeah, if fa-mlat-client is not running then you generate no mlat positions and all mode s, non ADS-B, aircraft will fall into the ‘other’ category rather than possibly being found by mlat. The total should stay the same.


#5

As you suspect your SD card I suggest you clone it now before it finally fails. Unless you already have a backup :wink:


#6

Anybody ever tried these: swissbit.com/products/nand- … ory-cards/ ? They are “industrial strength” / high temperature SD cards. They even have SLC models. More expensive, but perhaps more robust as well. They are made for industrial applications.

–Dan