FlightAware Discussions

MicroSD cards are write protected now

Two of my three MicroSD cards currently in ADS-B stations show they are write protected. It prevents formatting as well.

I searched on the web for a way to fix this, but the methods I tried did not work.

What could have caused them to become write protected? Is this recoverable or are new cards needed?

Are you using a direct reader or putting them in an SD card first?
The SD cards have write protect switches.

image
URL http://i.fixya.net/uploads/images/bea21a9.jpg

1 Like

Which methods did you try?
Are you using the FA image or a home brew install?
Some FR24 images are write protected by default

Not quite that.

fr24feed brings a buggy script with it that remounts / readonly.
Can happen on any installation if the buggy script runs while no files are open for writing (which is normally not the case, so the readonly remount fails)

Isn’t that a non-electronic plastic tab that’s ignored by most card readers?
Anyway good thing to check.

If sd-cards reach their flash cycle count i could imagine they could become read-only to protect you from data loss.
But that’s speculation, didn’t even look that up.

1 Like

I remember reading something similar as well, to protect pictures etc.

They are dead. It happend to me on a couple of cards too.
That’s why I minimized the number of writes that Pi does on my SD card.

sudo tee /etc/sysctl.d/07-dirty.conf <<EOF
vm.dirty_ratio = 40
vm.dirty_background_ratio = 30
vm.dirty_expire_centisecs = 360000
EOF
2 Likes

I’ll go with this option.
I shut down a Pi to swap PSU’s and it wouldn’t reboot.
After several hours trying different utilities and getting different reports (one said it couldn’t be formatted, one said it had formatted it, but on inspection, the old files were still present, one claimed to have written the image, but the old files were still present).
I gave up, flicked the card binward and blew $7 on a Sandisk 32G card claiming 80Mb/s.*

Burn image, boot Pi, get on with my life.

*(Did I need these specs? - No, but it was $0.50 more than a 16G card.)

1 Like

100 MByte/s read and 60 MByte/s write:
https://www.amazon.com/dp/B06XX29S9Q

Note that that’s only for the 64 GByte version.
The 32 GByte only has 20 MByte/s write :wink:

Direct reader, but I tried the SD card adapter as well.

Yes, that’s what I use.

One of the methods I tried. Still no go.

That’s a neat feature, even if it’s unwanted right now.:wink:

I have reached that conclusion as well. My free time is more valuable than the cost of a new micro SD.:slightly_smiling_face:

3 Likes

You’ve linked a Samsung card, but yes - it’s the read speed that is always quoted because it looks better.

The actual cards I purchased are still on special.

Sandisk don’t seem to quote a write speed at all

Just installed a Samsung EVO Plus 32 GB card. Impressed with the speed so far. It claims read speed of up to 95MB/s. Write speed of up to 20MB/s.

Not bad for CDN$14.88 at Best Buy.

At my neighbourhood Store “Canada Computers”.
http://www.canadacomputers.com
Branches in many cities of Canada.
Delivery in-store only.

  • Make ADATA (I am using 4 microSD cards of this make since last 4 years without any problem)

  • 32 Gb, Class 10

  • Read 85 Mb/s, write 20 Mb/s

  • Canadian $5.99

Thank you for the tip. My neighbourhood store has 5 in stock. I’ll go there tomorrow.

@Dxista
Glad to know “Canada Computers” has a branch in your city also.