latest piaware buggy??

is latest build buggy??
now for the 2nd time this week that i needed to reboot my pi that is was not sending data.
and a restart/reboot on console didnt work…

If you can provide a useful bugreport, I can look into it.

i check what i can find.

Mine has been stable for weeks but since upgrade has stopped twice in the last 24 hours

There are no known bugs like this in the current release and it does not happen on my systems. I need a usable bug report before I can do anything.

That means I need to know:

  • what site it affected
  • the time (and timezone) when it happened
  • what piaware version you were running
  • if you are not using the standard unmodified piaware sdcard image, a list of what you’ve changed
  • a description of what you saw fail (“it stopped” is not a useful description; describe what you observed that made you decide it had failed. Was it that FA stats stopped increasing? Or the FA stats were no longer “live”? Or that you could reach the local dump1090 map but it showed no aircraft? Or that you couldn’t reach the local dump1090 map at all? Or what?)
  • what you did to recover
  • a copy of /tmp/piaware.out after the problem happened but before you rebooted (if you can still access the Pi after the problem happens)

If you have time it is worth reading this too: (now translated into over a dozen languages!)

It is stable for me. The symptoms you are describing are similar to what I experienced when I tried to overclock Pi 2

Hi Obj

Site #2827
After 1800Z 28 Dec
After 1100Z 29 Dec
PiAware (Debian Package Add-on) 2.1-5 [automatic updates]
Also uploading from dump1090 to but no modifications made to programming for last few months.
Could not connect to
Stats page showed Data Feed and Check-in several hours ago
Removed power from RPi and started again
FA Feed restarted
Didn’t get to read piaware.out file - if it occurs again I will open it.


Thanks. Did the mlat-radar feed go down at the same time too? It sounds like the whole Pi crashed or had network problems.

I didn’t check the mlat-radar. Could be network probs.


Same for me. Piaware crashed at 6PM yesterday evening, fadump1090 still working (PP was displaying normal amount of planes). I have lost 12 hours of traffic.
A restart of the PI from the console solved the problem.


Happened again after 1000Z this am. Can’t log into Pi to get piaware.out report until it is rebooted.
No other equipment on the local network was affected.

OK so that does sound like a power or network problem rather than a piaware issue.

Yes on closer inspection it appears to have coincided with router resets by my ISP! Sorry guys.

i did a small work around, i let the pi reboot each night as 1 AM.
didnt found time to look for log files, and ya, my isue is also posted above…

I’ve had issues too where I’ve had to restart my Raspberry Pi, but I think my issues are power related. I recently upgraded my USB dongle and added a GPS hat, but was still powering my Pi from a USB port on my computer. Before the upgrade the PiAware was very stable except for a few ISP issues. Afterwards I’ve had to restart my Pi every couple of days or so when it became unresponsive. USB ports are only designed to provide 500 mA. I’m now using a 2A USB wall wart now to power the Pi. It’s only been a day or so time will tell if that was the issue.

I do have a feature request for PiAware. When I’m forced to restart my Pi it appears that piaware.out gets overwritten. Is it possible to append to piaware.out instead of overwriting it for diagnostic purposes?

The piaware log isn’t on the SD card. /tmp is in ram. As a result, at reboot, anything in /tmp is gone. You could add a script that is run at shutdown to copy the log to the SD card. Standard log locations are /var/log .

Oh right, never mind.