FlightAware Discussions

How to install dump1090-fa & Piaware on Nanopi K2 (arm64/meson64)

Hello,

I believe there are few forums here discussing on installing dump1090-fa & piaware on armbian 64bit.

I am here asking because I am unable to install successfully for dump1090-fa & piaware.

I have a extra Nanopi K2 SBC with specs:-

Amlogic S905, Quad-core ARM Cortex-A53@1.5GHz
RAM: 2GB.
OS: armbian buster

I hope someone here experts / guru can guide me to install for dump1090-fa & piaware successfully.

Thanks in advance.

Brows this howto. It may help and guide you in right direction

Howto Install Piaware ver 3.8.0 on OrangePiPC / Armbian Buster

Hi adcd567,

I follow the instruction and get this error. Too long the logs and I just copy from the last few rows.

 -Pdebian/dump1090 -UMulti-Arch
            echo misc:Depends= >> debian/dump1090-fa.substvars
            echo misc:Pre-Depends= >> debian/dump1090-fa.substvars
            install -d debian/.debhelper/dump1090-fa/dbgsym-root/DEBIAN
            dpkg-gencontrol -pdump1090-fa -ldebian/changelog -Tdebian/dump1090-fa.substvars -Pdebian/.debhelper/dump1090-fa/dbgsym-root -UPre-Depends -URecommends -USuggests -UEnhances -UProvides -UEssential -UConflicts -DPriority=optional -UHomepage -UImportant -DAuto-Built-Package=debug-symbols -DPackage=dump1090-fa-dbgsym "-DDepends=dump1090-fa (= \${binary:Version})" "-DDescription=debug symbols for dump1090-fa" "-DBuild-Ids=18dcc110d63ea90edae3077f6a4ed584ac4036b1 d6d9fcb4336355e8afb4fb4dc2f7e6a66bc642f4" -DSection=debug -UMulti-Arch -UReplaces -UBreaks
            chmod 0644 -- debian/dump1090/DEBIAN/control
            chown 0:0 -- debian/dump1090/DEBIAN/control
            chmod 0644 -- debian/.debhelper/dump1090-fa/dbgsym-root/DEBIAN/control
            chown 0:0 -- debian/.debhelper/dump1090-fa/dbgsym-root/DEBIAN/control
            dpkg-gencontrol -pdump1090-fa -ldebian/changelog -Tdebian/dump1090-fa.substvars -Pdebian/dump1090-fa -UMulti-Arch
            chmod 0644 -- debian/dump1090-fa/DEBIAN/control
            chown 0:0 -- debian/dump1090-fa/DEBIAN/control
       dh_md5sums
            cd debian/dump1090 >/dev/null && xargs -r0 md5sum | perl -pe 'if (s@^\\@@) { s/\\\\/\\/g; }' > DEBIAN/md5sums
            cd debian/dump1090-fa >/dev/null && xargs -r0 md5sum | perl -pe 'if (s@^\\@@) { s/\\\\/\\/g; }' > DEBIAN/md5sums
            chmod 0644 -- debian/dump1090/DEBIAN/md5sums
            chown 0:0 -- debian/dump1090/DEBIAN/md5sums
            chmod 0644 -- debian/dump1090-fa/DEBIAN/md5sums
            chown 0:0 -- debian/dump1090-fa/DEBIAN/md5sums
            cd debian/.debhelper/dump1090-fa/dbgsym-root >/dev/null && xargs -r0 md5sum | perl -pe 'if (s@^\\@@) { s/\\\\/\\/g; }' > DEBIAN/md5sums
            chmod 0644 -- debian/.debhelper/dump1090-fa/dbgsym-root/DEBIAN/md5sums
            chown 0:0 -- debian/.debhelper/dump1090-fa/dbgsym-root/DEBIAN/md5sums
       dh_builddeb
            dpkg-deb --build debian/dump1090 ..
            dpkg-deb --build debian/dump1090-fa ..
            dpkg-deb --build debian/.debhelper/dump1090-fa/dbgsym-root ..
    dpkg-deb: building package 'dump1090-fa-dbgsym' in '../dump1090-fa-dbgsym_3.8.0_arm64.deb'.
    dpkg-deb: building package 'dump1090-fa' in '../dump1090-fa_3.8.0_arm64.deb'.
    dpkg-deb: building package 'dump1090' in '../dump1090_3.8.0_all.deb'.
     dpkg-genbuildinfo --build=binary
     dpkg-genchanges --build=binary >../dump1090-fa_3.8.0_arm64.changes
    dpkg-genchanges: info: binary-only upload (no source code included)
     dpkg-source --after-build .
    dpkg-buildpackage: info: binary-only upload (no source included)
     signfile dump1090-fa_3.8.0_arm64.buildinfo
    gpg: skipped "Oliver Jowett <oliver.jowett@flightaware.com>": No secret key
    gpg: dpkg-sign.DM7qwf6P/dump1090-fa_3.8.0_arm64.buildinfo: clear-sign failed: No secret key

    dpkg-buildpackage: error: failed to sign .buildinfo file
    root@nanopik2:~/dump1090-fa#

I cannot proceed any installation after this.

Thanks.

Just continue, it’s not really an error.

@abcd567 When you get a change, change the buildpackage commands like this:

dpkg-buildpackage -b --no-sign

Also … that really doesn’t need sudo unless you used sudo on it before creating files that are not owned by the pi user.
Anyhow … sudo doesn’t matter i guess.

1 Like

Finally the installation completed.

Unfortunately after command the pi to reboot, it won’t boot and eth0 LED no longer blinking / ON.

No idea what is going on with it…

Anyway, thanks.

Thanks @wiedehopf .

Added --no-sign to the dpkg-buildpackage -b command at 3 locations (piaware, dump1090, and dump978) in each of following 2 Howto:

Howto Install Piaware ver 3.8.0 on OrangePiPC / Armbian Buster

Howto Install Piaware ver 3.8.0 on Ubuntu & Debian amd64

Easiest solution: Format microSD card and re-image, then install dump1090 & piaware.

Hi abcd567,

I have done it twice (Buster & Stretch) and having the same issue, done installation then reboot, no longer booted.

Format microSD, re-image the armbian then install dump1090-fa & piaware.

Not booting after all… Changing other SD card also the same. Change from Buster to Stretch also the same.

Better go for armhf SBC like Orange Pi PC or Raspberry Pi.

Thanks again.

OrangePiPC is great value for money if someone wants to use it for ADS-B.

I have been using it since 2016 to feed flightaware, flightradar24, planefinder, adsbexchange, radarbox24 & opensky without any issue.

The computer board itself is US $15.
The complete Set 5 is US $28 (price $23 + shipping $5), and comprises of all what is needed:

  • Computer board
  • Power Supply 5V DC
  • Plastic case
1 Like

@abcd567,

I have 2 x OrangePi PC & 2 x OrangePi Zero H2+ run for years, unfortunately my 2 x OPi Zero H2+ & 1 x OPi PC will hang about every 5-7 days. Left another 1 running without any problem. The 3 Pis’ sd card formatted and re-image to new image also the same, will hang every 5-7 days. Even replace to another new sd card also the same.

To me, the price is reasonable for the boards, can consider to get another 2-3 for extra stocks.

Regards.

I purchased 1st OrangePiPC in begining of 2016. It worked OK till begining of 2019, then started hanging every few days, and finally died in July 2019. I purchased a new one 6 months ago (August 2019), and the new one is working OK, no hanging yet.

1 Like

Seems we are having the same problem…

But yours OPi is last longer… May be due to the location as your location is in Canada (Cold), and my location is East Malaysia (North Borneo) a bit warm / hot.

Hopefully my the other OPi PC can last longer…

Regards.

Better go for Raspberry Pi. These are costlier than Orange PI but seem to be more durable.
My RPi Model 2B is running continuously for ADS-B without any issues since mid 2015, almost 5 years now.

1 Like

Yeah. Consider for more durable, which can last longer.
As we can see that the Flightfeeder provided by FlightAware, running 7/24/365 without any issue.

Better go for the Raspberry Pi.

For the Nanopi K2 (Amlogic S905 CPU), I can install rtl-airband without any problem, so just leave as is for LiveATC purposes.

Best regards.

That’s pretty strange because neither dump1090-fa nor piaware do anything special to the boot process, they’re just normal services that get started along with everything else, and they run as an unprivileged user. Even if they failed to start entirely, I would not expect that to affect your ability to log in to the system etc.

My only guess would be that dump1090-fa’s use of USB is triggering a hardware or kernel problem in the USB stack which hangs the system.

I have tried the dump1090-mutability, also having the same issue, once everything installed, have to reboot it so that dump1090-mutability will be running, and also not booted. Really strange on this. So I decide to leave as is, installing for RTL-Airband and reboot without any issue.

Well, will still stick to the Raspberry Pi or Orange Pi which is easier to fix the problem.

Thanks and regards.