Help requested with outdoor setup with poor reception


#1

Last week I received three FlightAware antenna’s and FlighAware Pro Plus sticks from an UK supplier. The delivery was decent, and I created a test rig in the attic. Results in compare to the Chinese antenna’s were immense. Reception was marvelous, even indoors at a maximum of 10m altitude from the ground.

The outdoor setup was a virtual clone, with a longer antenna cable, 5m instead of 1m. The target, a roof of an apartment building hosting several P2P-links, FM and DAB equipment, both for reception as broadcasting.

The setup:

  1. RaspberryPi3, ArchLinux, Dev version of Dump1090
  2. FlightAware Pro Plus + USB extension cable
  3. dAISy HAT
  4. Extra Chinese stick for POSTAG reception
  5. 5V@3A power supply
  6. 5m sma/n cable
  7. Flightaware Antenna using self-amalgamating tape for the connector + N plug.

Edit: everything in a box to prevent dust indoor. No shielding :slight_smile:

Going, with two cables.

The results were dramatic. Virtually no reception at all. Since this is one of the tallest buildings, having a complete free horizon, and an usbstick which was supposed to do filtering, this is a bit disappointing to put it mildly.

I have replicated the setup including longer cables in the attic again, there is no worst reception using the 5m cable or improvements of using the 1m cable. At this moment (1:55am) a few targets around 300km remain in sight.

Obviously I could go back on the roof hook up a short antenna cable directly to my laptop to see if that improves reception. I could also take a replacement antenna and/or usb-stick. But since I also have access to the PiAware setup changes in software are also viable. I have already tried to change the gain, which did not really change. Any guidance is appreciated.


#2

The most likely explanation is that the transmitters right next to your antenna are interfering.
The filter on the prostick is after the first LNA which is OK most of the time but it does not help if you are in a high noise environment that saturates the LNA before the filter gets involved.

You probably need a separate external filter, or move your antenna well out of the transmitters antenna patterns.


#3

This equipment is pumping so much RF power into the front end of the poor ProStick that it gets saturated resulting in poor performance.
Remedy (1)
Add an external filter … yes I know ProStick Plus has an integral filter, but being located AFTER the RF pre-amp, it does not eliminate interfering signals from RF pre-amp, resulting in its overload and cross-modulation. The integral filter does protect down stream (tuner & demodulator) circuits.

Remedy (2):
Place your ads-b antenna as far away from other communication antennas as possible.


#4

The broadcasting transmitter (105MHz / 190MHz) is about 1.5m lower than the Pi is currently standing. If this will never going to work without shielding that is something I would like to know. Yes, I bought the “plus” stick because I assumed (wrongly) that the function would be exactly the same. If this is not the case I do hope this is going to be updated.


#5

The 105MHz - 190MHz transmitting antenna only few meter away will sure saturate the front-end of dongle even if the height difference is 1.5 meter.
You do need

  1. A Filter
  2. Shield your equipment by wrapping in a copper gauze connected to shield of coax and the USB shield.
  3. Keep your equipment as far away as possible from the RF Pump (i.e. Transmitter Antenna)

#6

The antenna’s are pretty close the DAB are the vertical poles, the FM is out of the photo, but is in the top of the mast. But I was actually more worried about the two transmitters, which are in the same room as the Pi is.

Thanks for the support. I just ordered the filter. Next will be creating a box.

Obviously I’ll update this thread if I got some more information.


#7

@skinkie very good error description!

  1. buy a rtl sdr dongle without filter/amp https://www.amazon.com/Receiver-RTL2832U-Low-Cost-Compatible-Packages/dp/B015DN4DP6/ref=sr_1_9?ie=UTF8&qid=1509351916&sr=8-9&keywords=rtl+sdr

  2. make a scan over whole frequency band Filter not producing desired result

  3. according to scan results use different/better antenna run cable, shielded pi case, filters and lna e.g.


#8

Exactly the same as what?


#9

My assumption: Orange + External Filter would be equal to Blue. This is not the case.

Quoting https://flightaware.com/adsb/prostick/
“Only $20.95. Over 40% cheaper than a Pro Stick and FlightAware external filter”

The above statement is misleading and suggests that The Pro Plus stick has the same functionality. So now I have and more expensive sticks, and have to buy external filters, and I have to get back to the site. This is just not nice.


#10

Thanks for the tip. These are the results of the scan (note: image below doesn’t have PPM correction). The antenna used here is next to all the cables going to the transmitter 105MHz/190MHz, straight above it.

Regarding to shielding. Would you have any tips? I am currently running a scan on both devices simultaneously, including PPM correction. Might also give interesting results.


#11

You don’t have to change anything.You have all what is wanted to have a good ads-b receiver. Just change the location. As I see other transmitting antennas,bumper to bumper filtering won’t help.


#12

These kind of comments don’t help. There is a problem with radiation, so in V/m how much distance needs to be separated to get the SNR that is required for this kind of setup to work at this height. Because changing location sounds easy, especially if it is a few meters. But changing rooftop will not really help if it is GSM/LTE that is the cause of the problems.

As I wrote in my initial post: I have a non-horizon location that works flawlessly. The whole optimisation to add height was to improve on that.


#13

the ppm correction has nearly zero evidence to ads-b - so forget about this item. your scan looks extremly ‘loud’ - what was your gain setting? as you have very strong signals at 960mhz (cellphone downstream) the external flightaware filter is worth nothing to solve your problems. you can try to move the ads-b antenna on the roof away from the transmitters and use a real good filter e.g. the 3-pole(cavity) i mentioned above. moreover i’d go for an unamped and unfiltered dongle.

=> 3-pole filter -> lna -> dongle

p.s. what dongle did you use for the scan?

p.p.s maybe this thread is helpful in your situation: The Final Filter Shootout


#14

Chinese (indoor)
Dongle is the typically blue one.
rtl_power -p 61 -d 1 -f 800M:1200M:100k -i 30 -c 50% -e 30m -g 30 -F 9 > scan.csv
Found 2 device(s):
0: Realtek, RTL2832U, SN: 00001000
1: Realtek, RTL2838UHIDIR, SN: 00000001

Using device 1: Generic RTL2832U OEM
Number of frequency hops: 286
Dongle bandwidth: 2797202Hz
Downsampling by: 1x
Cropping by: 50.00%
Total FFT bins: 9152
Logged FFT bins: 4576
FFT bin size: 87412.56Hz
Buffer size: 16384 bytes (2.93ms)
Reporting every 30 seconds
Found Rafael Micro R820T tuner
Tuner gain set to 29.70 dB.
Tuner error set to 61 ppm.
Exact sample rate is: 2797202.148434 Hz

Flightaware (outdoor)
rtl_power -p 0 -d 0 -f 800M:1200M:100k -i 30 -c 50% -e 30m -g 30 -F 9 > scan-piware.csv
Found 2 device(s):
0: Realtek, RTL2832U, SN: 00001000
1: Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U
Number of frequency hops: 286
Dongle bandwidth: 2797202Hz
Downsampling by: 1x
Cropping by: 50.00%
Total FFT bins: 9152
Logged FFT bins: 4576
FFT bin size: 87412.56Hz
Buffer size: 16384 bytes (2.93ms)
Reporting every 30 seconds
Found Rafael Micro R820T tuner
Tuner gain set to 29.70 dB.
Exact sample rate is: 2797202.148434 Hz

(hope I have answered all your questions)


#15

please make the same scan again but change the dongles: flightaware indoor - and generic blue outdoor

p.s. the outdoor scan is really extreme


#16

Sadly can’t change it now for two reasons;

  1. The chinese one is mcx, the flightaware is sma
  2. I am not at the location.

I could replace the Flightware stick with something like a NoElec SmartSDR. So I’ll receive the external filter hopefully tomorrow, so I will have enough goodies to do a test.


#17

Entirely correct. RF is hard. As the page warns: Filtering benefits may vary and are dependent on the installation location. You have a somewhat unusual installation, most users aren’t installing right next to a transmitter.

Also that page does say (under “setup and tuning” in the Blue/Plus column)

Most users will not need an external 1090 MHz filter, however in very high RF environments users may still benefit from an external 1090 MHz bandpass filter.

I don’t know what else we can really say here. You’re in a very high RF environment, you’ll benefit from an external filter.


#18

:astonished: :open_mouth: Abundant RF on roof top. You need a really good Filter, but first try shielding Dongle+Pi by wrapping the Dongle and Pi in an aluminum or copper coated plastic tape or something similar. This may considerably reduce the RF.


#19

Nah, if this doesn’t work. I’ll build some sort of harmonic resonator and go in the energy harvesting business[/sarcasm]

@abcd567 Both dongles are next to each other. I don’t think the isolation indoor is going to help.


#20

Could you please add something like: The difference with an external filter is that the external filter would filter before the gain is applied, which might help in a very high RF environment. Hence not suggest it is cheaper and has the design. I was honestly thinking that the blue stick was sma-connector => (filter => receiver). It would be good to prevent these kind of mistakes.