Has anyone had success using a SDRplay RSP on a Pi and is receiving MLAT through FlightAware?


#1

I recently posted about “Getting kicked off of FA MLAT” server because of receiving a “Server status: clock unstable” error on the PiAware log once traffic was above 175-200 msg/sec or approx. 30-40 planes.


In talking to @david.baker many of the possible issues were eliminated but the question arose as to whether or not anybody has had success in doing this and thus the reason for the post.
Thanks


#2

Well, it appears no one was able to get it running with the pi using MLAT as there have been no reply’s to the post.

As there is also a version of the SDRplay dump1090-mut built for ubuntu I set it up on there and after seeing a post where @abcd567 had installed piaware on linux using Joe’s scripts I tried it on Ubuntu 16.04 LTS and have been feeding for several days now with only a couple instances of the “Server status: clock unstable” error coming up on the logs so I’m guessing this issue just pertains to using the Pi (Pi3b in my case).

At this point at 2MHz bandwidth it is picking up more planes and more long distance hits on panes that the RTL-SDR so that’s encouraging. The “oversample” mode doesn’t seem to work as well.

I’ve contacted one of the programmers at SDRplay involved with this and hopefully there will be a solution for the issue in the future.


#3

Keep us posted as I am interested in setting up an SDRPlay RSP receiver for ADS-B as well! It’s a great little radio…


#4

+1
I have an RSP2 and this weekend I installed the SDRplay package on a spare Pi 3B, I also installed VRS (with mono) to make it somewhat standalone. Does someone has an optimized 1090-mut command line enabling it to use it as a FA feeder?


#5

@alleyoopie

A very simple line is needed for startup:
[ ./dump1090 --dev-sdrplay --net --quiet –normal] for 2MHz sampling.

When I 1st tried to start it I got a compliant of: ./dump1090: error while loading shared libraries: librtlsdr.so.0: cannot open shared object file: No such file or directory

I installed librtlsdr-dev and it worked.

For FA feeding simply install the FA Piaware add-on package and it will work.

A couple items on the current dump1090_1.3.rpi.tar.gz is that [enable-agc] and the [–gain] switch do not work per SDRplay as they have built a “algorithm that runs to assess the best gain reduction level to use” and it seems to do a really good job from what I’ve seen so far as it appears that it automatically reduces gain during strong high local traffic and adds gain at night to pick up long distance flights.


#6

@Dunnsville

Well, I already figured out --dev-sdrplay --net --quiet but did not use the --normal switch during my test.
VRS on Pi was quite a heavy load for the processor so I replaced it with ModeSMixer2 enabling me to compare the stats and range map with those from my usual Pi with the FA stick.
Here are my findings comparing the RSP2 with the FA stick using the same Jetvision A3 antenna and cavity filter:
On the negative side:
The number of messages/sec with the RSP2 was down from about 1200 to 850.
The range map had the same shape but it was somewhat smaller with planes dropped above 150nmi.
On the positive side:
The number of detected planes with the RSP2 was almost identical.
The representation of the flight tracks had far fewer dotted parts with the RSP2.
All in all, the RSP2 was not too bad but it lacked the extra gain of the FA stick to detect the weakest signals above 150nmi, just a shame we cannot tweak the LNA gain as we can with the FA stick.