FlightAware Discussions

Every day my receiver gets overloaded

Hi,

I have two receivers feeding FA with the foloowing setup:

Both receivers at the same building (Berlin/Germany) just around 10 meters from eacht other. But they cannot see each other.

I. (South-East)
Raspberry 3 B
FA Stick Pro +
5m coax cable (inkl thin coax adapter cable for getting through the window)
FA antenna 26 inch mounted on a 2m aluminium pole mounted on balcony parapet

II. (North-West)
Raspberry 3 B +
FA Stick Pro +
FA 3dBi ADS-B 1090Mhz SMA Magnet Antenne glued right outsight the windows on a big piece of metal - not good looking but well performing

Now my problem: It occurs that my receiver (I) gets overloaded for some reason every day some minutes past 2 o’clock pm. Every day the same time.

I have been reading a lot about issues that can come up, when setting gain values to high. So I have experimented around with gain values (agc, max, values between 30 and 50). Made a table, tried to find a value, that prevent this happening again. Without success. What could be the source of the noise? Or could it be something within my setup?

Here Some Images from my receivers (today’s). You can see clearly a peak shortly after 2 o’clok. The second one doesn’t have it:

dump1090-1-localhost-signal-6h

More Pictures: https://1drv.ms/f/s!AhE767u2PS2lhH8pPOurewZBTYJq

Any help or advice much appreciated.

Regards
bdcinside

edited: Because sent to early.

I am not seeing a question here.
If you have an issue then please state it clearly and include any log files.

It’s most likely external noise, you might need a filter:

https://www.modmypi.com/raspberry-pi/communication-1068/flightaware-1090-mhz-ads-b-bandpass-sma-filter

A filtered LNA would also work and also reduce the loss due to the coax adapter cable through the window.
https://www.rtl-sdr.com/new-product-rtl-sdr-blog-1090-mhz-ads-b-lna/
(Filtering is much better than with the passive filter i linked before)

(You’ll need a bias-t or the rtl-sdr v3 dongle with builtin bias-t to supply the LNA with power)

If you want you can check what frequency the noise is at, do a scan when the noise is present and another one when it isn’t:
Do I Need A Filter?

1 Like

Oh i forgot to mention, don’t get the light blue bandpass filter, it’s not good at attenuating the 900 Mhz area.
The dark blue is the one you want that is focused on 1090 MHz.

And if you get an LNA placing it near the antenna of course makes sense.
Should survive if you wrap it completely with self fusing tape.

1 Like

Thx for your replay. Very interesting what you’ve wrote about 900 Mhz area. Actually I’ve got already a ligt blue FA filter. But it didn’t worked for me. SO, if I understand you right: To provide current to the LAN I need the rtl-sdr v3 dongle?

That dongle has a builtin bias-t that can be activated via software.
(https://www.rtl-sdr.com/getting-the-v3-bias-tee-to-activate-on-piaware-ads-b-images/)

You can also use standard bias-t:
https://www.ebay.de/itm/10MHz-6-GHz-Bias-Tee-Breitband-Radiofrequenz-Mikrowelle-Koaxiale-Bias-T-Stück-g9/283289518784
(I’m using this one)

That needs to be supplied with 5V, you can use an old USB cable and connect the positive wire with the positive terminal on the bias-t

This is another bias-t which should work but isn’t shielded. Probably not a problem though:
https://www.ebay.de/itm/Bias-Tee-Breitband-10-6000mhz-6GHz-FR-Amateurfunk-RTL-SDR-LNA-Lownoise-Amplifier/253713303524

That is my first choice. I’m curios about finding out what disturbes my receiver. Will let you know…

When does the overload stop?

Are you in an industrial neighbourhood?
Still even then i’m a little confused to think of something that switches exactly at 2 PM.

Maybe a local radio station that starts broadcasting?

It might be hard to find out with the spectrum scan because the Flightaware Prostick Plus has an integrated filter.
That filter is behind the amplifier though.

So when the amplifier is overloaded, you won’t necessarily know which frequency is overloading it.
Still it might be visible on a scan.

Yes, you are right. What causes the overloading is unknown to me. It’s a big city. Lots of Wifi, GSM, LTE around. 2km to EDDB. I don’T know what it is. It’s not excatly the same time. It occurs between 1400 and 1420 hours. I will run rtl_power tomorrow capturing this time with minimal intervall “1 second” and see what happens.

Here is, what I have so far:

The second raspberry at the North East side of the building doesn’t have this problem. But the setting is slightly different.

What gain did you run it at?

Run the scan at lower gain, let’s say 10, this should show the relative signal strength better.
(change -g 30 in the rtl_power command line to -g 10)

Seems you have lots of noise right below 1090 MHz which is not good in regards to filters being able to help.

Very strange, I’m not certain what noise would be at this frequency.

But as i said you would need something like the rtl-sdr v3 to make an accurate scan, with the Pro Stick plus you don’t know if you are getting weird effects of the amplifier getting saturated producing wide spectrum noise, which in turn get’s filtered by the SAW filter.

That is actually what you could be seeing on that scan.

What do you mean it didn’t work for you? No changes at all?

Can you think of anything else that happens at that time of day?
Does the sun hit the dongle or Pi?
Does heating turn on at that time?
Does someone charge their phone next to the Pi?

Can you remove the “window pass though” for a day and see if that makes a difference?

Hi again, will think about your further questions later on when I have enough time to do so. For the moment try to have a look at this one. I think I have a snapshot of whatever happens after 2 pm:

Does the overload condition stop at the same time every day, and does it stop just as suddenly as it starts, or maybe gradually fade away? I glanced at the charts, but didn’t see when it stopped. Maybe consider posting some 48hr or 7day charts for us to see as well.

1 Like

have you tried calling your local airport? (do they see this same interference issue?)

I will consider a long time scan. The overloading is actually the vertical short distortion right after 2 minutes and ends after 2 or 3 minutes. And calling a busy air port like EDDB isn’t really an option. I don’t think they are “interested” in me or my Hobby. :wink:

And the problem remains even after the noise subsides?
Does a restart of dump1090-fa help?

You could easily schedule a restart in a cronjob.

sudo crontab -e

paste this line:

 15 14  *   *   *     /bin/systemctl restart dump1090-fa

Then Ctrl-o and enter to save, Ctrl-x to exit

To be clear, I’m not talking about a longer rf scan, but a dump1090 chart that covers more than 6 hours. Notice the “noise” line on your chart. Just after 2:00 it spikes, then dips, then returns to a level that is not quite, but is nearly as high as the spike, then stays at that level until it runs off the right hand side of the chart. Presumably, at some point it comes back down to nominal so it can spike again at 2:00 the next day. I’m wondering if its return to nominal is just as predictable as the 2:00 spike.

1 Like

i was just wondering (re contacting EDDB) if the RF noise was “in your area” or just specific to your site/system. there are many other sites near Berlin, do they have similar issues? you could look on the FA coverage map and ask on of the sites very near you…

Yes, it remains. If I pull the receiver out for some minutes and plug it back in it returns to normal. Otherwise it will stay on a low level reception. May be some kind of resistor that needs to be onloaded?

Just restarting dump1090 or the raspberry doesn’t change anything. I should try out my second identical FA Stick.