FlightAware Discussions

Diapason antenna and Flightaware pro plus dongle and filter

I have an active Diapason antenna and the Flightaware pro plus and the filter. I just got the antenna and now when I try to connect everything it seems the SMA female fron Jetvision and the SMA female from another company isnt the same so I have had to remove the filter.

Two questions:

  1. Will the filter (generally) improve the range with the setup I have
  2. What apapter do i have to get?

This works:
Antenna - Bias tee - Dongle - Raspberry Pi

Is does not work to put the filter between the dongle and the Bias tee… There the sizes in SMA are noticable.

I hope you understood what I meant, just frustrated the filter cant be used now…

You shouldn’t need it. Your antenna already does filtering.

But the filter should fit if the dongle fits.
Some SMA connections need some careful strongarming though.

You will need to reduce the gain though.
For Beginners - How to Set / Change Gain
Thoughts on optimizing gain

If you want to make it easier, you can use automatic adjustment: https://github.com/wiedehopf/adsb-wiki/wiki/Automatic-gain-optimization-for-dump1090-fa

No matter the method, start at a gain of 20.
You have two amplifiers in use which increase the signal significantly.

Thank you very much for your reply!! Great!!

pi@RADAR:~ $ sudo /usr/local/bin/dump1090-fa-autogain
cat: /var/tmp/dump1090-fa-autogain/strong: No such file or directory
cat: /var/tmp/dump1090-fa-autogain/total: No such file or directory
Set rtlsdr-gain to 49.6 in /boot/piaware-config.txt:60
Decreasing gain to 49.6 (122.181% messages >-3dB)
pi@RADAR

Those errors on first run are normal.

Just run it every 10 minutes or so until it settles.
You can just use the up arrow on the console to call up the last command used.

Great, so when you say “until it settles”, can you explain a bit more what it actually does? Find the correct signal strength?

Does the same you can do manually as explained here:
Thoughts on optimizing gain

There are adjustable amplifiers inside the stick, that’s what you adjust when adjusting gain.

In short it turns the volume knob until it’s not too loud and not too quiet.
That’s approximated by the number of messages louder than -3dB.
0 dB is very loud, -40 dB is very quiet.

Many thanks for the explaination. Will run that command every ten mins now to see :slight_smile:

You can save yourself some time by just setting it to 20 and then letting the automatics take care of it.

But if you already have the graphs installed you can of course look for what changes. https://github.com/wiedehopf/graphs1090#graphs1090

Or just look at the local map what changes.

you mean i set it to 20 and then do " ```
sudo journalctl -eu dump1090-fa-autogain

No just adjust the gain manually to 20.
For Beginners - How to Set / Change Gain

Did that, thought something else needed to be set. Thanks, you are a champion!

I hope you dont mind me asking since you seem very skilled in the subject. I installed graphs1090 and i get nice graphs. ADS-B Aircart seen (average 62), ADS-B tracks seen I am unsure what that is, ADS-B range peak range 213,5 (is that an ok range or have I done someting stupid?) and ADS-B signal peak -1.7.

Do those values look ok? What sticks out in my beginner eyes is the last thing with minus. Should it be minus?

Anyways, do you see anything out of the ordinary? Pardon my newbie questions…

The level of 0 dBFS is assigned to the maximum possible digital level.[2] For example, a signal that reaches 50% of the maximum level has a level of −6 dBFS, which is 6 dB below full scale.

See this for further explanation about signal levels.
https://en.wikipedia.org/wiki/DBFS

tracks: statistics on aircraft tracks. Each track represents a unique aircraft and persists for up to 5 minutes after the last message from the aircraft is heard. If messages from the same aircraft are subsequently heard after the 5 minute period, this will be counted as a new track.

Did you even check the unit? :slight_smile:
It can be changed to km by the way via a configuration file.
https://github.com/wiedehopf/graphs1090#configuration-optional

Anyway if you want to try for more maximum range you can try if increasing the gain helps.
Most likely it won’t change much.

Post your signal graph.
Click it so it’s displayed on its own, press Ctrl-C to copy it.
Then here in the textbox just press Ctrl-V.

Note my signal graph is different because i’m using the Airspy Mini as a receiver.
Yours isn’t really able to receive stronger signals that -1 dBFS or so, they get lost because they are too strong.
Or rather near the top the scale isn’t too accurate anymore anyway.

image

image

Run the automatic gain adjustment a few times more with 5 minutes in between.

Will probably reduce the gain some more.

Ok, doing this:
pi@FLIGHTRADAR24:~ sudo /usr/local/bin/dump1090-fa-autogain Set rtlsdr-gain to 48.0 in /boot/piaware-config.txt:60 Decreasing gain to 48.0 (53.371% messages >-3dB) pi@FLIGHTRADAR24:~

I really appriciate your help… Want long range of course and correct settings :slight_smile:

Seems you didn’t reduce the gain to 20 after all :wink:
Probably followed the instructions not suited to your installation (2 different methods).
No matter, just continue running the automatic, it’ll get you there eventually.

The range won’t get any better while the gain decreases. But it shouldn’t get any worse either.
The advantage with lower gain is that you will be able to receive local planes properly.

hm i did, i follow your instructions like a slave… hmm i might have messed something else p maybe. Maybe I have to save? :slight_smile: So it is better i set it to 20 now?