FlightAware Discussions

Bounced by Router

Just want to confirm there is no piaware (or Debian) problem needing a fix for keep my piaware static ip from repeatedly being bounced. It seems to me to be a wifi issue because I can restart the gateway and recover real-time skyview data. Any comments?

Thanks.

I don’t know of any problems with static IPs, but your post is very short on information. What do you mean by “bounced”? What sdcard image are you using? How have you configured it?

Thanks for your reply. I keep losing dynamic skyview for no apparent reason. Rebooting the router restores skyview buy it will drop again. I am using 3.7.2 and the piaware-config text file is:

NETWORK CONFIGURATION

wired-network no
wireless-network yes
wireless-ssid TC8715D3E
wireless-password [mypassword]
wireless-type static
wireless-address 192.168.0.22
wireless-netmask 255.255.255.0
wireless-broadcast 192.168.0.22
wireless-gateway 192.168.0.1
wireless-nameservers 209.18.47.61

1090MHZ RECEIVER CONFIGURATION

rtlsdr-gain max

OTHER CONFIGURATION

allow-auto-updates yes
allow-manual-updates yes
allow-mlat yes
allow-modeac yes

Additional settings can be added below.

wireless-country US
use-gpsd yes

A separate, unrelated device is assigned a static ip also, is an ethernet wired device, and also drops video content.

That’s wrong.

I’m not sure why piaware is even asking for the broadcast address as it can be calculated from the address and the netmask.

Try this:
wireless-broadcast 192.168.0.255

I’m not 100% positive on this, but i’m pretty sure.
See this here: https://www.calculator.net/ip-subnet-calculator.html

Note that the subnet is the same as the netmask, which can be written in long and /xx notation.

You also want to stay out of the DHCP address range of the router.
So in the router you can usually configure which addresses it will give via DHCP.
Don’t use any of those addresses or it could lead to problems.
Maybe just try 222 instead of 22 as the IP address if changing the broadcast address doesn’t help.

How is your router configured? If it is using DHCP, a fix is to make reservations (by mac address) for the device ip addresses because the router may be assigning a different ip for the mac address.

I’ll give it a try, then. Thanks. I didn’t even think of DHCP conflicts with a static ip so, I’ll want to check the DHCP range to stay out of it lol.

Good point. Device and FA-reported mac addresses differ.

It uses dhcp except for two static devices.

I reduced my router’s dhcp range and assigned pi’s static ip outside of that. Works great! Thanks, everybody!