Authorization Required problem


#1

hello there,
I am having problem in the php code with soap client.
It is saying that SoapFault Authorization required…

the reply is something like as

SoapFault Object ( [message:protected] => Authorization Required [string:private] => [code:protected] => 0 [file:protected] => C:\wamp\www\Demo2.php [line:protected] => 61 [trace:private] => Array ( [0] => Array ( [function] => __doRequest [class] => SoapClient [type] => -> [args] => Array ( [0] => {true lifeguard}10 [1] => flightxml.flightaware.com/soap/FlightXML2/op [2] => FlightXML2:SearchBirdseyeInFlight [3] => 1 [4] => 0 ) ) [1] => Array ( [function] => __call [class] => SoapClient [type] => -> [args] => Array ( [0] => SearchBirdseyeInFlight [1] => Array ( [0] => Array ( [query] => {true lifeguard} [howMany] => 1 [offset] => 0 ) ) ) ) [2] => Array ( [file] => C:\wamp\www\Demo2.php [line] => 61 [function] => SearchBirdseyeInFlight [class] => SoapClient [type] => -> [args] => Array ( [0] => Array ( [query] => {true lifeguard} [howMany] => 1 [offset] => 0 ) ) ) ) [faultstring] => Authorization Required [faultcode] => HTTP )

thanks in advance…


#2

Make sure you are supplying a FlightXML API key and not your website password in the authentication. You can obtain a key from flightaware.com/commercial/flightxml/key


#3

Hello, I’m getting the same error when attempting to load the php SoapClient example here:
flightaware.com/commercial/fligh … t#examples

I’m of course replacing the username and api key with my own. Is there a way to check if perhaps there is some sort of block on the account? It was up and running for a long time until about a week ago.

Thanks!


#4

Your daalmase user account has not ever requested any FlightXML API keys. You need to visit flightaware.com/commercial/flightxml/key to obtain your API key first. If you’re actually using another user account, then let me know and I can check that account instead.


#5

Sorry, I should have explained. I’m using the account ‘uebersee’ and it’s corresponding api key. I didn’t realize I could use that account within this forum. Thanks in advance!


#6

The key for that user should be enabled again. Be advised that you will need to contact Mark Duell shortly before May 1, 2013 to avoid the next expiration.


#7

Thank you, seems to be working now!


#8

Hi, I’m facing same authorization problem, I also have API key with status “Never Expired” , kindly check for “ameel”


#9

Your problem is different. You have manually disabled/revoked your own key by clicking on the “X” on flightaware.com/commercial/flightxml/key.rvt

You may use that same page to request another key to be generated and added to your account, at no cost.


#10

Hi,

I recently subscribed to Starter pack of FlightAware and I found that it gives access to only FlightXML Ver3 and NOT FlightXML Ver2?
I tried accessing Ver2 apis and got Authorisation errors while for Ver3, it worked.
Documentation for Ver3 has lot fewer apis than ver2.
Some of interest not present in Ver3 are AllAirlines() and AllAirports() to get ICAO identifiers of supported ones.

Can you suggest how I can do a workaround on that or by what timeframe(weeks/months?) all those api(s) would be available for Ver3 also?

Thanks.


#11

You can sign up separately for FlightXML2, it’s lower on the pricing page. However you will need to setup billing as there is no free tier available for FlightXML2.