FlightAware Discussions

Airspy: MLAT - not synchronized with any nearby receivers

Inside the box would be interesting.
But it’s probably at least 40C as the Odroid has an active cooler and i wouldn’t expect more than 20C differential from the CPU core to the air around it.

My suspicion holds: The airspy is just getting too hot to use it at 20 MHz reliably.
Stick some sticky tape heatsinks on it or something.
I’m using a computer case 12 V fan running on 5 V.
It runs nice and slow but reliably.

I guess the enclosure is quite bit with all that gear in there?
No matter my recommendation stands, build a non rain proof well ventilated “shade box” for the actual enclosure.
Much better than insulation as the heat generated in the box is kept inside by the insulation.

With the insulation in place you would need a fan ventilating the enclosure to the outside, but that’s problematic due to water ingress.
But i guess if you stick on 30 cm of duct below the fan where the fan sucks in the air, it shouldn’t be a problem.

The fan across the Airspy i’d still recommend even after reducing the temperature in the box.

I went to my preferred electrical wholesaler and have a look at some enclosures. It is poly-carbonate at the moment, they suggested perhaps going to metal. Either way, it needs to be bigger so there is a bit more air space around things. I will go up and take a pic tomorrow and post it here, so you can see. We will be having our first 30c + day on Thursday, so it will be interesting to see what the temps of the odroid core are like.

I’ve never gotten MLAT to synchronize when using airspy_adsb with -m 20. When using -m 12, MLAT works great.

1 Like

RPi <4? That’s pretty much expected.

You can do it with the 3B+ under the exactly right conditions.

…with the 3B+, no dropped samples. My gut feeling (I don’t know why) has been that something gets mangled when the data passes through BeastSplitter.

prog said elsewhere that samples can be dropped internally without it being reported in the log. It’s more likely than beast-splitter mangling things.

1 Like

I never understand why people choose to put the CPU outside, instead of running coax cable and punt the sensitive electronics inside indoors. The only thing that I have outside is the antenna and a cheap ADS-B amplifier.
Now OP has a device that runs hot by default, in a closed box with the sun that adds heat, with holes that will let humidity go inside.

PS: My Airspy gets hot inside a not-AC cooled garage (don’t know how you “King’s” English people call the thing that is meant to park your car in, at your house), so I have added heat spreaders:

Interesting… swapped the USB lead from the Airspy onto a USB 3 Odroid port… sync’d MLAT receivers now showing and using 20 !!

2 Likes

If you use the -m20 (20MHz MLAT) and didn’t use the -p (packing), you certainly can overload the USB 2.0 connection, at least that’s true on the Pi3+ hardware.
I don’t even know if MLAT 20MHz brings any advantage…

20MHz does make a difference, especially when it’s busy. It’s more able to decode overlapping signals. It seems to give about a 10% improvement to message rate. It’s not an enormous difference but it’s definitely noticeable.

I run the Odroid N2 with -m20, and do not use the -p option. The -p option has previously resulted in some lost samples. The N2 has USB 3. YMMV on a RPi.

I’ve seen more problems with packing enabled than without it.
So if it doesn’t work without packing, just don’t even try using -m20.

The USB channel on Pi3 has very restricted bandwidth. The difference in CPU utilization with the -p option doesn’t push my Pi3 more than 2% extra, plenty of headroom there.

Odroid N2 might be better.

The only time I get 100% usage is when 20MHz is enabled.

The chip on the Airspy Mini also needs to do more calculations, and that’s where the problem can be.
That’s also where you won’t see the lost samples because they are dropped before they get to the software.

Remember that the RPI 3B+ and below share the USB 2.0 bus with the ethernet port and , I think, the SD card.

1 Like

I don’t think is that much work needed to pack three samples in two words. But that’s just me…

1 Like

I have the same problem wonder why is that !!

You are also using the Airspy Mini?

If not, please open your own thread.

Edit:
You are using a FlightFeeder, thus this thread does not apply to you.
Your problem is most likely intermittent as MLAT synchronization requires enough ADS-B planes to be in sight. The air traffic near you is relatively low, thus synchronization with enough other receivers only happens when enough ADS-B aircraft are visible to you and the other receivers in the area.

Please open a thread describing your problem, maybe the antenna position can be improved. This will improve range and in turn allow your receiver to synchronize with more receivers.

2 Likes

I am using AirSpy R2 and an Odroid XU4, no problems with MLAT sync and M:20 . I did get a few dropped msgs in the logs until I used armbian-config prog to set the processor min-max to between 1.5 and 2 meg with board set to “performance” mode. I am running Armbian on the XU4 with an eMMc mem module.

Thanks for the reply. Raises a few questions from me.

What OS type and version are you using?

How are you accessing the ambrian-config program, via SSH or desktop?

How do you find the eMMc module and what size are have you got?