3.1.0 Working Not Perfectly . . .HELP!


#1

This is a mystery:

  1. 3.1.0 install after 2.0.5, 3.0.4, 3.0.5 via stats page commands
  2. Data is being uploaded to FA normally
  3. Originally a Wheezy base (still is)
  4. Ports 80 and 8080 inaccessible via port forwarding or VPN
  5. Site is 1200 mi away
  6. I can access via 22 ssh
  7. I have done every combination of update/upgrade
  8. I have edited sources.list to change wheezy to jessie. I get the infamous NODATA1 NODATA2 error
  9. Lighttpd is there but have no way to debug it because sysctl is not present.
  10. Yes I can FedEx a new chip to someone but it won’t be easy

I would appreciate any help before I attempt the FedEx fix Thanks . . .Joe K4AA


#2

Try “sudo service lighttpd start” and see what it logs (both to your session & to syslog)

Remote administration is tricky.


#3

OBJ: here it is:

pi@piaware ~ sudo service lighttpd start ....] Starting web server: lighttpd2016-09-29 14:50:58: (configfile.c.1256) base-docroot doesn't exist: /var/www/html 2016-09-29 14:50:58: (server.c.649) setting default values failed failed! pi@piaware ~

Nothing in /var/log/syslog but older entries

Joe K4AA

(yes remote admin is tedious )


#4

I don’t know why that directory would be missing, but you could try just creating it, then maybe lighttpd will be willing to start.


#5

OBJ created directory “base-docroot” in /var/etc/www/ and in /etc/lighttpd/ to no avail after reboot. Joe K4AA


#6

What? Why did you do that? The directory it is complaining about is /var/www/html, read the error message.


#7

OBJ: Stupid me!! Lack of knowledge coupled with stupidity leads to disaster.

GOOD NEWS!!! created /var/www/html and the map page fired up!

Thank you so much for putting up with Linux novices. Joe K4AA