FlightAware Discussions

WiFi response time bad

This is more going to be a general network question for Raspberry.
Did anyone experience a performance degraded WiFi network over time?

I did not move my device for at least two weeks and the router is less than 2 meter away.
Today i wanted to access the box via SSH and it was very slow in response time. I’ve identified that also the response to ping was way too high between 100 ms and up to a timeout.
I know that this wasn’t the case until yesterday where i accessed the device without issues.
Also a reboot did not help.

Anyone having an idea what could have caused this?
CPU load is normal, nothing which could block the device from handling network requests.

I have it connected now via cable but this is in the way to a door and i would like to get this removed again.

What kind of RPi do you have? I saw an issue on Pi Z W’s that had > 40,000 msg / min - The wifi would start to degrade (iirc, I saw a post about USB/Wifi sharing some processor on these – I’m not a heavy hardware guy so sorry for lack of good explanation) and I’d get ICMP response times that were in the 200-400ms RTT and then a cascading failure of things like dns lookups, connections to FA, ssh logins stalling etc. The solution for me was to upgrade to a Pi 3b+ for high volume nodes - and the problem went away.

The device is a Raspberry 3 B (non plus).
Do you mean the messages/minute on the dump1090?

This was higher today as i brought the antenna outside.
However, during daytime i always have > 50.000 messages/minute and never that problem.

I was also confused that even a reboot did not bring the WiFi performance back.
I will test it tomorrow again because the LAN cable across the room is not my preferred solution.

Did you restart the router?

Did you change the RPi orientation, the antenna is sensitive to that.
Shouldn’t matter at that distance but still.

1 Like

both questions can be answered with “no”. The router is running meanwhile since more than 150 days and does habe other clients connected as well without issues.
The Raspberry wasn’t moved until i connected the LAN cable. But the WiFi issue occured before. A bit strange that it worked a day before

Meanwhile the device even did not get an IP adress assigned.
Is this the symptom because the LAN cable is still connected with an IP adress from the router?

Loooooong shot. Ensure the MTU setting in the router is a multiple of 8.

Also, ditch the ISP DNS, if that is what you use.

that cannot be the reason. The device was working for two weeks and accessible without issues during that period.

The rest of the whole home network is working flawless.
Your settings would work if also LAN connections are slow which isn’t the case

Still easiest to restart the router and check if it helps.

Check how many WAPs are nearby and what channels they use. My system can see 100 but I have 6 WAPs in the house and three are high in the attic.

Nothing spectacular around me. Only the router on the basement where the router upstairs is connected via LAN cable and the neighbor AP. But this is up and running since years without issues.

I cannot connect directly to the router on basement because the signal is too weak and disappears from time to time.

And before somebody is asking: The router upstairs is not a “real” router, i’ve reconfigured it as AP extension to the main router. IP adress and DNS is delivered from the one downstairs.

Will check with the suggestion of @wiedehopf later

It would make it easier for those trying to help if you called it an Access Point if all the router functions are disabled.

Is the AP connected to the router by cable or Wi-Fi?

S

1 Like

See the part in my answer above yours

It is unclear how the router upstairs is connected to the neighbour AP.

S

why should i connect the router upstairs to the neighbour AP? Ah, i see from my previous post. Sorry, that was a typo by me. I am not connected to the neighbor, i only have a connect to my router in the basement.

However i got it fixed.
Thanks to OpenWRT i did not need to reboot the router(AP) completely. Disabling and enabling the WiFi interface solved the problem.

again thanks to @wiedehopf

Wonder why the router caused this issue.

WiFi routers sometimes seem to go crazy.

Really have no clue, but rebooting the routers often fixes problems :wink:

I’m using IPv6 to ssh to my RPi, because with IPv4 ssh sometimes hangs.
I suspect it’s a badly written router mangling the packages.

But with OpenWRT that shouldn’t be the case.

good point. Never tried IPv6, but i can give it a chance if it occurs again.

I thought already about a little script which brings the WiFi network on the router/AP down and up again during night to avoid it.

When new people moved in the house next door, that’s very close to my garage where Pi is located, then they brought in some new routers, extenders that made my 2.4GHz network less reliable in that part of the house. I had to switch to 5GHz everything that was capable and I have wired my Pi3 directly with an Ethernet cable.

Install WiFi analyzer on your phone to check your site.

2 Likes

Nobody moved in or out and i checked of course the environment with different analyzers.
The problem was caused by my router messing up the wifi network. As i wrote the restart of network services on the router solved the issue.

Now I see you have OpenWRT.
In my personal experience with it (and DD-WRT), very few builds are stable enough for normal use. I have only one of those routers in service now, with a specific firmware from 5 yrs ago. Any update breaks the stability.

1 Like

The router/AP is operating since two years without issues. It’s the first time something failed. Now after almost two days it’s still working flawless.

Keeping an eye on it.