FlightAware Discussions

WiFi not connecting

Today i wanted to change my network configuration having both LAN and WiFi enabled and connected.

The interface wlan0 is up and running
I’ve also changed and verified the settings in piaware-config.txt and restarted the service regarding password and SSID

Even the scan from the Raspberry shows the available networks including my two routers. I’ve tried setting up both in config, but the adapter simply does not connect.
Both routers are 2.4Ghz, serving several other clients in my home network

ifconfig shows this:

        wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
            ether b8:27:eb:b6:d0:44  txqueuelen 1000  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

and iwconfig this:

wlan0     IEEE 802.11  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=31 dBm
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on

Could it be that i cannot use both network interfaces at the same time?

Thanks

reboot? …

wanted to avoid it, normally it’s not required with Linux, or?

Given that it’s meant for people whore configure it before inserting the card.

Probably configures the network stuff on boot and then lets the normal services take care of it using that configuration.

Why don’t you just try it … really -.- making me type!

tried it, no change. WiFi interface wlan0 shows available but does not connect. Same status as previous

Syslog shows on every five seconds:

piaware wpa_supplicant[587]: wlan0: Failed to initiate sched scan

What are you trying to accomplish by having 2 nics on the same subnet?
If it is for bandwidth, you can bond the nics.

After a third reboot it works, connected to the second router. For the primary router i want to use it’s still not working.

Anyways, can live with it.

Each router should be on its own subnet along with the nics.

The second router is working as a repeater to extend the WiFi signal to the 2nd floor which cannot be reached by the main router.
So there are good reasons having two routers in one subnet. Of course it should not have full services like DHCP or DNS enabled to avoid conflicts

And to answer your previous question:
I am preparing the move from LAN to WiFi connection. And if i disconnect LAN without having WiFi working properly, i do not have any access and would need to find a display, keyboard, mouse to access the device again.

Too much effort if it could be done by a simple temporary enablement of both interfaces.

OK, your second “router” is really a repeater. The best way to set that up is to use Ethernet cable between the router and repeater so as to preserve bandwidth. If you connect the 2 boxes via wifi, you will halve the bandwidth because only a single packet can be in transit at any moment in time. A search will yield many wifi repeater setup guides.

1 Like

The object that people call “router” consists actually in a router, a DHCP/DNS server, a switch and a WiFi repeater.
I am using two of those in repeater mode. One has that option in the menu, the other I have to turn off manually the DHCP server and connect the incoming Ethernet in one of the four switch ports (autoconfigure).

I have no idea what you’re talking about because it is simply not my setup. Both router are connected through inhouse cabling and i did not ask about this, but why WiFi on my PI is not working
But as you’re asking:
One is operating as DNS and DHCP, the other one is simply open a seperated WiFi for the devices located on second floor.

I never plan to connect the two devices wireless
The problem you’re talking about half the bandwidth has been fixed by some providers already as long as you use devices from one manufacturer only.

But this is not the case in my setup.
For me both are routers, because they are routing signals across different networks :wink:
In reality i agree to SoNic67 that one of them is a repeater

@foxhunter
The advise by @ua549 is good, provided you can run a network wire between main router and secondary router (repeater).

If they are truly different network, you must configure a route between the networks. If they are actually on the same network, be advised that having 2 nics with ip’s on the same network in 1 computer breaks tcp/ip protocol and will NOT work.

You will be better served to direct your networking questions to another forum.

By default in a piaware image both interfaces are enabled and work if the Ethernet cable is connected. By default the cost metric for the Ethernet cable is set lower and lan traffic will use the cable.

Simply removing the cable will remove the eth0 interface from the routing table and all network traffic will switch to the wlan0 interface.

If you plug the cable back in the network traffic will switch back to the cable.

By default it just works out of the box without any configuration changes.

if it doesn’t just work over WiFi when you unplug the cable you have broken something and it may be safer to just reload a piaware image and start again.

If you start with a piaware image all you needed to do was add the WiFi ssid and password.

S

@SweetPea11
The OP is trying to use both interfaces at the same time on a single network. For it to work each interface must be on a different network. That will allow remote nodes to connect to the Pi. To enable the remote nodes to access each other a route between networks must be configured.

1 Like

Do you want data to flow on both interfaces concurrently or just have them both configured?

They can both be configured on the same network but must have different routing metrics.

As pointed out previously the eth0 interface will have a lower metric by default and be used in preference to wlan0 which has a higher metric.

By default, if eth0 is connected it will be used. If eth0 does not exist because the cable is unplugged at either end the interface with the next lowest metric will be used. If you set the route metric the same on both interfaces then the outcome is unknown and there may be no communication between the router and the Pi.

S.

You still did not get my initial qustion, isn’t it?

I am not planning any changes except the connect of my PiaWare from LAN to WiFi
As i am getting my question already answered “Why is WiFi not working on my PI” i am off from this thread

[quote=“SweetPea11, post:17, topic:54329”]
Do you want data to flow on both interfaces concurrently or just have them both configured?
[/quote]I’ve answered that question already in the thread

I am not wanting to route anything just both interfaces enabled for a short period of time for reconfiguring. Nothing else

It must not. I have it right now that both interfaces are running and getting each a different network adress from that single router in the same subnet. It works and has no disruption to feeding etc. The PI is reachable via both interfaces
If it makes sense is a different topic, but not for this thread because i replied to that question already
This double connection will go away later today once i have reconfigured my environment.