FlightAware Discussions

Wifi hotspot sleeping!

Apologies, this is probably not directly a PiAware issue.

I successfully setup PiAware for the first time yesterday and it seems to be working well. However, it is connecting via a Huawei E5576-856 mobile wifi which keeps going offline. Normally an active connection keeps it awake. I have looked at the Huawei’s setup and set it to never sleep, but this had no effect. When the Huawei is awake and connected, I see the PiAware as a normal looking online device. But it seems as though, if only the PiAware has an active connection, the Huawei shuts itself down and needs to be restarted before it is visible again to any device, including my phone and my Mac.

Any ideas would be appreciated.

As in a work around?
Every 5 minutes do an http request and maybe huawei will not sleep?

Install curl:

sudo apt update
sudo apt install -y curl

To enable:

echo "*/5 * * * * pi /usr/bin/curl http://flightaware.com/adsb/piaware/piaware-config.txt >/dev/null 2>&1" | sudo tee /etc/cron.d/wifikeepalive

To disable:

sudo rm /etc/cron.d/wifikeepalive

This enables a recurring download of that small file which should be “activity” to that router.

1 Like