FlightAware Discussions

Wifi drops when ProStick+ is connected

Have been using Piaware 4.0 (one month now from the upgrade) on a Pi Zero W and a Pro Stick Plus (blue) without any problems.

Suddenly Piaware stopped reporting and ssh is unnaccesible. I isolated the problem: Whenever I plug the receiver onto the Pi, wifi drops, if I unplug it, wifi is restored immediatly.

I already checked dmesg and no voltage issues are reported, I changed the power supply but the issue was not solved either. I reimaged my sd card with old backups proved to work (back to 3.8.1) but the issue is still there.

I already disabled wifi power management and iwconfig reports it a being disabled.

Lastly I put the same SD card on another Pi (Pi3B+) and it works perfectly.

So I think the dongle is not faulty and the sd card is working fine. I think it’s a power management issue.

Is there any other power management configuration I can play with besides iwconfig?

It’s really weird it has been working for months 24/7 but now it’s showing such a weird behaviour.

Thanks for your help.

Have you tried different USB slots?

You can try a better power supply with 5.2 V output.

Perhaps try a powered USB hub between the dongle and the Pi? Would give more constant amperage to the dongle. Would eliminate the Pi only power issue.

Gary

What else is connected to the device?

I have a similar setup with a Pi4 the Blue FA stick but nothing else connected.
While my previous Pi4 showed the same behavior, the new one is rock solid since August.

Nothing else, PiZero W, sd card, power supply and Prostick+.

Have tried official power supply (2.5amp power supply), an ipad charger (5.1v), a motorola turbo charger (5v, 3 amps). Nothing makes it work (although it worked for months).

The pi3 with the same components (sd, power supplies, stick) works fine, although it’s supposed to draw more current than the zero.

Amps mean nothing for your Zero. Rather the voltage can be an issue, 5.1V should be fine… I have also used an Amazon Kindle charger with 5.2V.
If none works, probably some of the Zero’s internals are dying.

There is more going on somewhere, especially if SSH is dropping off. This may sound strange, but are there any strange authorized_keys files in /root/.ssh, or does that path exist? Asking because there is a nifty BOTNET going around that targets SSH on IOT/Linux in general and all sorts of strange things happen.

max_usb_current=1

I believe is still applicable to the Pi Zero in the /boot/config.txt file to assist the USB port power somewhat.

Sounds like you’re privy with linux in general and already checked the logs and all that, so have to think on what else recently changed with that setup, or nothing at all and just out of the blue?

i would see this as a consequence of the WiFi drop

I could have misread him as I was more or less thinking about the service itself dropping

1 Like

Yes, could have been read that way.

Some details from the logs might be helpful

I agree.

Switched again the same sd card now to a Pi2, and works perfectly.

I already ordered a new PiZero, maybe that´s what´s failing. Any other component (power supply, pro stick, sd card & image) is working when the Zero is not used.

The other component I have not being able to check is the Pi Zero USB-MicroUSB adapter cable. New Zero kit will bring a new cable just to check.

Yeah so that implies hardware (to me) so the only things out of the picture from that test swap is the PiZeroW and adapter cable itself. I guess either could give up the ghost. It’d be a good test to see what happens with that new cable/adapter. If it still does the same thing, then I’d lean towards the PiZ itself being the culprit. Wouldn’t cost anything but a few seconds to try the usb setting if you don’t already have it in the config.txt as a last-ditch test besides new adapter when it comes in.

I forgot to mention, the max current setting in config.txt is (and always has been) 1.