why piaware 3.0.4 wifi doesnt work?

Hi all.
i have problem raspberry pi3 . i install the new version piaware 304 but wifi not vork. I apply the instruction parameter from web. nothing. how can solve wifi problem. can help me please anybody.
thankyou all.

You need to provide settings and error messages.
Have you checked the log files (/var/log/messages /var/log/piaware.log )
Otherwise we are just guessing

Make sure your router SSID and the SSID you put in the config file are the same.

This is case-sensitive. If one is WiFi, then you can’t use “wifi”. It must be “WiFi”

Also, make sure you are using WPA2.

Do not use WEP.

ewerything is correct but not work wifi. if i scan wifi it show but not connect ower wifi.

i can ask a question. how can i connect my piaware from internet outside

I found my file /etc/wpa_supplicant/wpa_supplicant.conf was built with several parameters and included a syntax error which kept the interface from coming up. I pared it to the minimum of ssid & psk and it worked.
It takes root privilege to read or write it.

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
        ssid="<your network, case sensitive>"
        psk="<your key>"

Hope this is helpful

Was this a config file generated by the 3.0.x piaware sdcard image? If so what was the syntax error? It shouldn’t be introducing syntax errors…

I was building it off Jessie, scripts from the ADSB Receiver Project, and a fewer other things to muddy the waters.
Not your problem. Thanks for checking.

[EDIT] I just went through the process I posted and it doesn’t work :open_mouth: . I must have been working from a different image when I made my notes.

Sorry, I’ve deleted the code[/Edit]

Hi Dave!
Excellent writeup/guide. Thanks.
ab cd

I had the same issue with my copy. I discovered that by default the wifi is turned off, but I managed to get it turned on and working well.

There are several things I did to get it working, one was to configure wlan0 in /etc/network/interfaces by adding the following lines
allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Next, I edited the file /etc/rc.local and added three lines above the “exit” line, which were:
cd /etc/network
cat interfaces.d/wlan >> interfaces
ifup wlan0

Lastly, I went into /etc/wpa_supplicant and created the wpa_supplicant.conf file, adding in the following three lines:
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

You may have to change the country code, if you aren’t in the US.

Now you are set to add in your network info by doing the following:
edit the wpa_supplicant.conf file by running wpa_passphrase (your ssid) >> wpa_supplicant.conf [Enter]
(your matching password) [Enter]
Now edit the wpa_supplicant.conf file and between the ssid line and psk line add the following 5 lines:
pairwise= CCMP TKIP

When you’re done, your wpa_supplicant.conf file should look something like this:
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

reading passphrase from stdin

pairwise=CCMP TKIP

Now, to bring the wifi online, type ifup wlan0 [Enter], and you should be good to go