FlightAware Discussions

Why do I seem to lose reception when a/c is very close?

I can see a/c maneuvering on the ground at a nearby airstrip and starting their take-off run, but I seem to lose reception as they fly very close and low. See example screen-grab for example - assuming that a dotted line represents lost signal.

What is happening there ? Is it possible the receiver is being swamped ?

Either something in the way between receiver and aircraft (trees, mountains, buildings, other signals) causing blind spots or the gain is that high that it’s a kind of “over” saturation of the receiver. It becomes “blind” if the signal is too strong.

Like if you’re in front of the speakers on a rock concert. At some point you will identify the whole thing as noise because it’s too loud.

Solution for the second issue is a reducement of gain.

Thanks. It’s definitely not a blind spot due to physical blocking - I can actually see the aircraft while not getting ADSB reports. It sounds like saturation, I wonder if there’s a software setting to reduce gain?

Yes, if you are using a Raspberry with dump1090 there is a setting to reduce gain.
Several Threads around this topic are available here.

In case you’re using a Flightfeeder from FA, you will need to check with their support.

Thanks, I’m using a Raspberry with dump1090. I will have a look at gain settings - but don’t want to reduce range.

dump1090 or dump1090-fa?

For dump1090-fa you can try this:
Automatic gain optimization for readsb and dump1090 fa · wiedehopf/adsb-scripts Wiki · GitHub

If it’s not dump1090-fa … i’d suggest upgrading to dump1090-fa or readsb, scripts to install either can be found here Raspbian Lite: ADS B receiver · wiedehopf/adsb-wiki Wiki · GitHub

dump1090 or dump1090-fa?

I don’t know! I downloaded the zip file from: PiAware on Raspbian Linux 5.0 ZIP

Wait! Looks like fa

sudo piaware-status
PiAware master process (piaware) is running with pid 569.
PiAware ADS-B client (faup1090) is running with pid 625.
PiAware ADS-B UAT client (faup978) is not running (disabled by configuration settings)
PiAware mlat client (fa-mlat-client) is running with pid 653.
Local ADS-B receiver (dump1090-fa) is running with pid 560.
dump1090-fa (pid 560) is listening for ES connections on port 30005.
faup1090 is connected to the ADS-B receiver.
piaware is connected to FlightAware.
dump1090 is producing data on localhost:30005.

Then you can use the automatic thing if you want:
Automatic gain optimization for readsb and dump1090 fa · wiedehopf/adsb-scripts Wiki · GitHub

This is useful to monitor your range … GitHub - wiedehopf/graphs1090: Graphs for dump1090 (based on dump1090-tools by mutability)

1 Like

The scripts provided by @wiedehopf are pretty useful and with it you should be able to identify issues.

It’s one of the first things i install on a fresh device setup.

Thanks both, very helpful, I have installed graphs1090.

I have looked at the gain optimization scripts (I am impressed at all that in bash!), but I don’t think the script’s logic will work well for me. I am in a very sparsely over-flown area with very few contacts and mostly at extreme range, but a handful of flights per day operate from an airstrip a couple of Km away, and fly right over my head at a few 100 feet. It looks like the script tries to adjust the gain according to the fraction of messages with strong signals, so it would wind-up the gain to max for all those very weak and distant signals.

I will have a play with the config file (can anyone tell the values allowed for rtlsdr-gain ? The manual says a numeric gain value in dB, or “max” for AGC , what numeric range is allowed ?

Perhaps I will also try to deconstruct the gain scripts and customize something. I am surprised there seems to be no way to adjust gain on the fly in response to excess signal.

This are the gain settings that can be set

# gains = 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
# gain = -10 is max gain (55.0 with AGC)

The rtl-sdr library doesn’t allow on the fly changing of the gain, you’d have to restart the data collection.

Here is how to change gain, find the section for the piaware sd-card:
For Beginners - How to Set / Change Gain

Then you can manually adjust which might indeed be necessary.

I’m actually implementing something to do this at the moment.

It will be optional because the tradeoff is that you will lose distant reception when there are nearby aircraft.

That would be perfect for me - in practice there would rarely be a tradeoff as gain would only be have to be reduced for a few minutes each day as an a/c takes-off or lands and the nearby airstrip.

Dynamic range on the RTL-SDR is your problem. A better solution would be to invest in an Airspy that has a higher dynamic range, I.e. it will receive local planes without being blocked as well as the distant ones. (I assume you don’t have a LNA before the receiver that can also be overloaded by strong signals)

1 Like

I assume it would be possible to have two RTL-SDR receivers, one with gain turned down (or small antenna) to capture very local signals.

1 Like

The days i had my Raspberry outdoor with the blue ProPlus FA stick i never had any issues with very close aircraft (2000 ft or lower)

Only the short moment where the aircraft is exactly 90° above the antenna it was “invisble”, but a second later it appeared again. If it passed a little left or right, it was displayed the whole time. This might be the “blind spot” right above the antenna.

Maybe the blue stick is able to cover this better.
My AirSquitter also does not have that problem.

You didn’t have it on -10 / max gain did you? … yawn

No i did not. During that time i had it on something around 42
Should have mentioned it additionally in my original post