When is this 12 month old bug going to be fixed?


#1

I reported this approx 1 year ago and it still hasn’t been fixed. It’s the bug that blocks your screen when you try to access the flight tracking window and comes up with “the host name does not match the certificate” with accept or deny options. It’s coming from quantserve.com.

Isn’t it about time it was fixed as it’s the sort of thing you’d expect from a 2-bit site hosted from a kid’s bedroom, not a professional website.


#2

So how would flightaware be expected to ‘fix’ it ? Other than removing the quantserve parasite which they won’t do (lose $$).

Get AdBlockPlus or something similar and condemn these spies to purgatory, where they belong :wink: .


#3

It’s an infrequent bug (depends which quantcast node you hit) that can appear for only a very small number of users (those on https). The intrusiveness of the warning also depends a lot on your browser.

We put in a change we expected to fix it a while ago and haven’t seen it or had it reported since, but if you’re still seeing it we can try a more extensive fix.


#4

As it’s not actually an ad, the various blocking software/tools won’t do anything.


#5

It has been frequent (numerous times per day) for me since I originally reported it. It just occured to me today that I’ve been cancelling it whenever it popped up for 12 months now and it’s about time that it got fixed!

I’ve not been paying much attention to the hows/whys/whens etc, but today I noticed it always came up when your servers diverted me from the main site to the uk site.


#6

Yes, they will block all access to named or partial URLs; the name is misleading.


#7

I have added quantserve.com/](http://quantserve.com/) to my urlfilter.ini and will see what happens. I have my doubts though…


#8

Interesting, we’ll disable the quantcast tag for the small number of https users.


#9

Why do you keep on saying https Mark? We had this discussion a year ago where you claimed I was using https, that was until I provided you with screenshots clearly showing a normal http url with the certificate “mismatch” error box displayed at the same time. It’s nothing to do with https…

The bottom line is that you need to ditch the shitbox company that is Quantcast and tell them to sort out their software.

And jfyi, type in “quantserve certificate” into google and see the 3 million pages that appear from people having the exact same problem… and yes it is edge.quantserve.com that I get, same as other people.


#10

If you’re not on https, there’s no certificates to mismatch. Can you paste the source of the page when you get the error?