What are folks using for admin of remote PiAware boxes?


#1

How are folks accessing remote PiAware machines for admin? I have a server with ssh, openvpn and stunnel exposed to the internet so I can make use of those. What are others doing? TIA.


#2

https://www.dataplicity.com/ works well for me.


#3

I can’t get past the code copy/paste page at dataplicity. I put the code into terminal (SSH) on my Mac and does something, but not what it should. I get a line that said sudo: python: command not found and I think that’s the problem.


#4

webmin



sudo apt-get install perl libnet-ssleay-perl openssl libauthen-pam-perl libpam-runtime libio-pty-perl apt-show-versions python
cd /home/pi
wget http://www.webmin.com/jcameron-key.asc
sudo apt-key add jcameron-key.asc
sudo su
sh -c "echo 'deb http://download.webmin.com/download/repository sarge contrib' >> /etc/apt/sources.list"
exit
sudo apt-get update
sudo apt-get install webmin



#5

My piaware box runs a docker image downloaded via resin.io.
There’s no need for any device access this way. You configure everything through a web interface.
The thread starts at ads-b-flight-tracking-f21/raspberry-pi-docker-from-blank-sd-to-feeding-in-15-mins-t36459.html but the author has an updated version somewhere.


#6

The default PiAware image doesn’t include python. To install:


sudo apt-get install python


#7

Thanks for the line of code. I had done a google search and the stuff I found didn’t work. No clue what I’ve done to the Pi by now, but it still works. “curl” still doesn’t work but swapping it with “wget” does.

Still stuck on the line of code page at dataplicity. I recopied their line into terminal and that worked this time with no error messages, but still stuck on their page. It says it can take 15 minutes for their system to do its thing so let’s see what happens.

Thanks again!


#8

If you just want remote access, use VNCViewer. They grant 5 free licenses for Pi users that allows you to access from anywhere: a bit like teamviewer.


#9

did you ever figure out the issue? Im stuck in the same place.


#10

I did fix it but I don’t remember how! Once I got everything up and running I never touched it again. Honestly can’t remember how I got through it.


#11

if you need gui, tightvncserver works for me on Pi3 with full jessie.
if not mobaxterm more advanced than putty, allows copy/paste and a lot of other features as copy files from/to (like filezilla).
all work as sudo (superuser).
HTH


#12

After some conversation with dataplicity support I finally figured out how to get it up and running. You need to use wget to download the installation file using the link they provide. Then you need to use sudo python to run the file you just downloaded. After that everything should download and run. Haven’t had much of a chance to play with it but it appears to be working.


#13

Another vote for Resin.io, here…

I have it running on two RPi’s, one in Switzerland and one in Australia.

The only issue I have is a hardware (PSU) failure on the one in Australia, there’s no remote solution for that!


#14

Remote hardware repair/replacement is not a far reality looking at the way Robotics & Drones are developing. :slight_smile:


#15

I use zerotier: https://zerotier.com