FlightAware Discussions

Want to reduce your CPU load (and therefore temperature) and network bandwidth?

A short while ago I disabled IPV6 on my two receivers. I don’t use it here, my ISP doesn’t support it, my router doesn’t support it and so I decided to disable it. I’ve done it on my two feeders.

Straight away, my CPU load dropped by a little over 2% but my network bandwidth by around 50%!

The slight reduction in CPU will help a tiny bit with temperatures, the reduced network bandwidth won’t have much of an effect to anything but it’s interesting that despite nothing here being configured to use IPV6, it clearly has been trying to talk. If and when my ISP ever supports it, I’ll re-enable it but for the time being, it’s staying off.

To disable it, I did the following:

sudo nano /etc/sysctl.conf

Scroll to the bottom and add the following lines:

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1
net.ipv6.conf.eth0.disable_ipv6 = 1
net.ipv6.conf.wlan0.disable_ipv6 = 1

Save the file and either reboot or use this comand:

sudo sysctl -p

If you get an error saying a fie can’t be found, that’s because you either don’t have an eth0 or a wlan0 port.

1 Like

That really doesn’t make any sense.

Does this survive a reboot?
Does the bandwidth magically reappear when enabling ipv6?

Yes, I rebooted one of them and both CPU and bandwidth have stayed down. I haven’t tried re-enabling ipv6.

I could imagine some stateless configuration sending some useless messages around the network.
But 40 kByte/s? Hard to believe.

Maybe some double accounting going on?
CPU usage looks consistent with the change though.

I know, right. If you don’t use ipv6, give it a try. See what happens.

I have all the kByte/s accounted for.
Remember when i checked the different feeders for bandwidth?

Anyway it seems to be something to disable if you really don’t need it.