FlightAware Discussions

V5.0.5-airspy dump1090-fa with native AirSpy support now available

i shall be running mini  with sample of 20  soon as i got it working

Those shouldn’t have the <> around them.

PIAWARE_LAT=52.2475
PIAWARE_LON=0.7103
all corrected now 
still nothing working

What was the output of journalctl this time?

sudo journalctl -o cat -fu dump1090-fa
Failed to read wisdom file /etc/dump1090-fa/wisdom.local: Permission denied
dump1090-fa.service: Main process exited, code=exited, status=1/FAILURE
dump1090-fa.service: Failed with result 'exit-code'.
dump1090-fa.service: Service RestartSec=30s expired, scheduling restart.
dump1090-fa.service: Scheduled restart job, restart counter is at 386.
Stopped dump1090 ADS-B receiver (FlightAware customization).
Started dump1090 ADS-B receiver (FlightAware customization).
Failed to read wisdom file /etc/dump1090-fa/wisdom.local: Permission denied
dump1090-fa.service: Main process exited, code=exited, status=1/FAILURE
dump1090-fa.service: Failed with result 'exit-code'.
dump1090-fa.service: Service RestartSec=30s expired, scheduling restart.
dump1090-fa.service: Scheduled restart job, restart counter is at 387.
Stopped dump1090 ADS-B receiver (FlightAware customization).
Started dump1090 ADS-B receiver (FlightAware customization).
Failed to read wisdom file /etc/dump1090-fa/wisdom.local: Permission denied
dump1090-fa.service: Main process exited, code=exited, status=1/FAILURE
dump1090-fa.service: Failed with result 'exit-code'.

OK, that’s my fault. Run the following command.
sudo chmod a+r /etc/dump1090-fa/wisdom.local

there is no wisdom.local in that folder  
im sure it should be in /usrdump1090-fa   

The installer copies it to /etc/dump1090-fa but the permissions were wrong. That may be why you can’t see it.

Run these two commands instead…

sudo chmod a+rx /etc/dump1090-fa
sudo chmod a+r /etc/dump1090-fa/wisdom.local

Yes working before i did  above 2 links  never the less i did both  links still wisdom.local  file in there 
but working now  thanks 
------------------------
AirSpy: FIFO FULL!  Dropped 98304 samples.  Current Dropped: 98304
AirSpy: FIFO FULL!  Dropped 98304 samples.  Current Dropped: 98304
AirSpy: FIFO FULL!  Dropped 98304 samples.  Current Dropped: 98304
AirSpy: FIFO FULL!  Dropped 98304 samples.  Current Dropped: 98304
AirSpy: FIFO FULL!  Dropped 98304 samples.  Current Dropped: 98304
AirSpy: FIFO FULL!  Dropped 98304 samples.  Current Dropped: 98304
AirSpy: FIFO FULL!  Dropped 98304 samples.  Current Dropped: 98304
AirSpy: FIFO FULL!  Dropped 98304 samples.  Current Dropped: 98304
AirSpy: FIFO FULL!  Dropped 98304 samples.  Current Dropped: 98304
AirSpy: FIFO FULL!  Dropped 98304 samples.  Current Dropped: 98304
AirSpy: FIFO FULL!  Dropped 98304 samples.  Current Dropped: 98304

pi@raspberrypi:~ $ sudo journalctl -o cat -fu dump1090-fa
sample-format    : u16o12
lna_gain         : -1 (not set)
mixer_gain       : -1 (not set)
vga_gain         : -1 (not set)
linearity_gain   : 21
sensitivity_gain : -1 (not set)
lna_agc    : off
mixer_agc  : off
packing    : on
rf_bias    : off


``` :

Is this with the settings you posted above or something else?

I altered sample rate to 20 and i got  errors above  so  put it back to  12 
im reading  the whole section 
im tickling  things  but  need to read up  first 

Sorry for the delay, later than promised, real life got in the way :grimacing:

Here are 8 hr graphs and the config files from both test airspy mini and reference (FA Orange dongle) systems.

8 hr signal level airspy mini

##          Airspy testing settings for 20210721 graphs
# dump1090-fa won't automatically start unless ENABLED=yes
ENABLED=yes
RECEIVER_GAIN=" --airspy-lna-gain 15 --airspy-mixer-gain 15 --airspy-vga-gain 15"
RECEIVER_FORMAT="--sample-rate 6 --sample-format sc16"
RECEIVER_OPTIONS="--device-type airspy --airspy-enable-packing ${RECEIVER_GAIN} ${RECEIVER_FORMAT} --modeac --stats --stats-every 60"
DEMOD_OPTIONS=" --demod hirate --demod-preamble-threshold 0.9  --demod-smoother-window 2 --demod-msg-window -7:7 "
WISDOM_OPTIONS=" --wisdom /etc/dump1090-fa/wisdom-airspy.armv7"
DECODER_OPTIONS=" ${DEMOD_OPTIONS} ${WISDOM_OPTIONS} --lat 1234566 --lon 7890123 --max-range 350 --no-fix --no-modeac-auto"
NET_OPTIONS="--net --net-heartbeat 60 --net-ro-size 1300 --net-ro-interval 0.2 --net-ri-port 0 --net-ro-port 30002 --net-sbs-port 30003 --net-bi-port 30004,30104 --net-bo-port 30005 "
JSON_OPTIONS="--json-location-accuracy 2 --write-json-every 1 "

and the reference system

8 hr signal level FA orange dongle

##       Reference system settings for 20210721 graphs
# dump1090-fa won't automatically start unless ENABLED=yes
ENABLED=yes
RECEIVER_OPTIONS="--device-index 0 --gain 38.6 --ppm 0 --modeac"
DECODER_OPTIONS="--lat 123456 --lon 67890 --max-range 360 --no-fix"
NET_OPTIONS="--net --net-heartbeat 60 --net-ro-size 1300 --net-ro-interval 0.2 --net-ri-port 0 --net-ro-port 30002 --net-sbs-port 30003 --net-bi-port 30004,30104 --net-bo-port 30005"
JSON_OPTIONS="--json-location-accuracy 1"
# Use a machine-specific wisdom file if it exists
if [ -f /etc/dump1090-fa/wisdom.local ]
then
  RECEIVER_OPTIONS="${RECEIVER_OPTIONS} --wisdom /etc/dump1090-fa/wisdom.local"
fi

Hope that helps. If you need more info / graphs / data, just ask :slight_smile:

WOW! Those are some really high levels, especially the reference system. I’m not even sure how that’s working. Is the uptronics’s filter before or after its LNA?

The reference system is rtl-sdr … those levels are pretty normal for rtl-sdrs.
I’ve seen rtl-sdrs set at a gain of 5 because there were so many LNAs in front of it … still worked fine.
Or what exactly do you mean?

uputronics is LNA → filter

Attached is a snip with left using LNA and right when I removed LAN and splitter and changed FA Orange dongle to gain -10 just for info.

lnaout-gain-10

The Uptronics LNA is located before the SAW filter. I only got the LNA because I wanted to insert a splitter to do A / B testing from the same input. I live in a quiet location 1090Mhz noise-wise, so don’t need the LNA for normal use.

Hmmm. I didn’t see that with mine but it’s all about the environment.

The right side is more what I’d expect although the noise floor is still above the weakest signals. Is the Uptronics an LNA and filter in one package or is the filter separate? If separate, can you swap their positions so the filter is before the LNA? I’m in a very noisy environment so I have to have the filter first but I’m curious what having the filter first in your environment will do.

Did you have an LNA in front or not?
Of course it also depends which gain you run.

The weakest signals can be inaccurate with dump1090-fa, signal -49.5 is assumed for MLAT results for example, as an average is made for each aircraft, that confuses things.
Also an aircraft with less than 8 messages with show a signal level less than it actually is.

To not depend on local SDRs being used, the weakest / strongest signal level and quartiles are calculated via aircraft.json aircraft signal levels.

The noise level is everything that couldn’t be decoded.
This is only available with a builtin demodulator and it’s problematic as overlapping messages that can’t be decoded will count as noise.

Hi all fixed now
SkyAware 6.0-dev running airspy_adsb

skyaware 5.0.5 running dump1090-fa

I will have to edit and adjust mixes and gain settings to get a much better output
but 5.0.5 and me both in learning stages :slight_smile:

1 Like

zero strength (e.g mlat) signals are not counted towards the average: dump1090/track.c at master · flightaware/dump1090 · GitHub