FlightAware Discussions

Using Beast GPS receiver from broken FlighFeeder on windows via USB


#61

yep… it works… again thank you for everything bro :wink:


#62

if you put in the feeder-id correctly you don’t even need to set a position
(the flightfeeder took care of that)

not sure if you would even make the GPS work or it just works again… not sure :slight_smile:

maybe piaware gets the receiver position via the usb.
probably it actually does.

yay.


#63

yes… GPS is over USB, and the green indicator on receiver is on… seems that everything is COOL :smiley:


#64

it seems it automatically created a new site.

you didn’t use the old feeder-id i guess?

anyway it’s not that important a new site is fine as well.


#65

yeah… i’ve used a new one…


#66

let’s see if it will set it’s position automatically.

otherwise you can just set it via the gray button on the right side of the orange bar on the flightaware stats page for the new site.

GPS takes some time to get its position.


#67

ok… why FlightAware can’t send commands to my device…??? it says that this function is turned of on local device…


#68

you need to enable it with piaware-config

(https://flightaware.com/adsb/piaware/advanced_configuration)

allow-manual-updates yes or no
allow-auto-updates yes or no

you can set that with piaware-config

Also it seems you put in some completely different position from the old receiver, was that on purpose?

(regarding the update stuff… it won’t work you need to recompile to update. not that i would foresee the strict need to update piaware/dump1090 they should work just fine for quite some time ;))


#69

For now I’m “suffering” from GPS position setting… i don"t know how to pick correct long lat… picking long lat from OSM gives me 30-50 meters wrong on PiAware’s map… it’s just a nonsence…


#70

then ignore piawares map. getting the coordinates right is more important.

if you know OSM is correct for your location just use those coordinates.

oh and the local dump1090-fa map position isn’t displayed precisely.
for that you need to change the config
/etc/default/dump1090-fa

and at the very end it needs to be 2 instead of 1 for the accuracy :slight_smile:


#71

That did the job… thanks you :slight_smile: for now i see, that everything is setted up and running correctly… thanks to you of course :wink: you’re amazing…


#72

actually with all the screenshots you made it easy.

it’s only hard when people just say the command doesn’t work but don’t even give you the error message :slight_smile:

I see you are already synchronized on MLAT so setting the position on the stats page seems to have worked.

Not sure how you would use the automatic receiver position but i mean it’s not exactly a feature that is important anyway.


#73

@abcd567

i’m curious can you run piaware armhf images in the VM you are using?
or only x86 stuff?


#74

I’ve setted my position manually, on the stats page :slight_smile: