Ubuntu 22.04 (Jammy): Install Pre-built Packages of piaware 8.2

 

1 Like

BONUS: How to feed data from Ubuntu 22.04 amd64 to:

Flightradar24
Planefinder
AdsbExchange

1 of 3: Install Flightradar24 feeder on amd64/x86_64 computer:

wget https://repo-feed.flightradar24.com/linux_x86_64_binaries/fr24feed_1.0.25-3_amd64.deb  

sudo dpkg -i fr24feed_1.0.25-3_amd64.deb  

## Run following command to signup/configure
## Do NOT select receiver type "1 - DVB-T"
## Select "4 - AVR-TCP"

sudo fr24feed --signup   

 

2 of 3 : Install Planefinder feeder on amd64/x86_64 computer:

wget http://client.planefinder.net/pfclient_5.0.162_amd64.deb

sudo dpkg -i pfclient_5.0.162_amd64.deb

To signup / configure Plane finder,

Go to web page

  • On Ubuntu computer:
    localhost:30053
  • SSH from another computer:
    IP-OF-Ubuntu-VM:30053

 

3 of 3 : Install Adsbexchange feeder on amd64/x86_64 computer:

curl -L -o /tmp/axfeed.sh https://adsbexchange.com/feed.sh

sudo bash /tmp/axfeed.sh

 

 

1 Like

I am trying to install piaware/dump1090-fa onto my Raspberry Pi 4B running Ubuntu 23.04 beta using your instructions above. When I run ‘sudo apt install piaware’ I get the following message:

The following packages have unmet dependencies:
piaware : Depends: libboost-regex1.74.0-icu67 but it is not installable
Depends: libffi7 (>= 3.3~20180313) but it is not installable
Depends: libmpdec3 but it is not installable
Depends: libssl1.1 (>= 1.1.1) but it is not installable
It all worked great on Ubuntu 22.04 ARM64 but will not install on 23.04 because of these missing dependencies. Trying to install them independently is unsuccessful.

These packages were built for Ubuntu 22, and are not compatible for Ubuntu 23.

For Ubuntu 23, Debian 12, and Kali 2023, I have tried to build piaware package from Flightaware source code, and all failed with exactly same error.

Unless Flightaware programmers (@obj & @eric1tran ) upgrade the piaware source code, the piaware package wont be available for Debian 12 Bookworm and other OS based on Debian 12 Bookworm (e.g… Ubuntu 23 Lunar Lobster, Kali 2023 etc)

OK, now how do we get their programmers attention to fix this?

I guess you will have to be patient since Bookworm is in alpha and beta stage of development.
As soon as Bookworm is released they will develop the software on that level. During alpha and beta stages software still changes so it makes more sense to develop against a stable release

2 Likes

We target specific OS releases – essentially, the Pi Foundation’s images which are based on Debian 11.

Until those images shift to being based on Debian 12, it’s unlikely I can find much time to look at the underlying problem.

piaware and mlat-client are open source so I’d encourage you, if you have the time and inclination to look into the problem, to work out a fix and submit a PR. I can merge PRs with a lot less effort than what a full investigation would need.

(The short version is that Debian 12 has a newer Python which is incompatible with the version of cxfreeze that the piaware build uses. You’ll need to upgrade cxfreeze and resolve any build issues – cxfreeze tends to be quite fragile which is why we use a specific version, not just the latest)

3 Likes

Thanks @obj for your detailed responce.

I am happy with Debian 11 Ubuntu 22 and Kali 2022. I tried beta versions only out of curiocity. Since I dont have enough programming knowlede, I cant find the fix. So I decided to wait till these OS are released as regular versions.

However when some users try to install piaware on beta versions, and get stuck, they start posting in forum for solution. I tell them that piaware is not yet compatible to these beta releases.

Ubuntu 23.04 will be realeased in a week or two .

@obj
@shull895

Due to cx_Freeze issue (which I could not resolve), I build piaware without building fa-mlat-client

 

CLICK ON SCREENSHOT TO SEE LARGER SIZE

 

CLICK ON SCREENSHOT TO SEE LARGER SIZE

 

git clone https://github.com/flightaware/piaware_builder
cd piaware_builder

sudo ./sensible-build.sh bullseye

cd piaware_builder/package-bullseye

## HACK #1
sudo sed -i 's/include <eval.h>/include <ceval.h>/' cx_Freeze-6.8.3/source/bases/Common.c   

## HACK #2
sudo sed -i  's/ clean_mlat-client / /' debian/rules
sudo sed -i  's/ build_mlat-client / /' debian/rules
sudo sed -i  's/ install_mlat-client / /' debian/rules
sudo sed -i '/cd mlat-client/s/^/#/' debian/rules
sudo sed -i '/fa-mlat-client/s/^/#/' debian/rules
sudo sed -i '/freeze-mlat-client/s/^/#/' debian/rules

sudo dpkg-buildpackage -b --no-sign 

PIAWARE_VER=$(grep "Version:" debian/piaware/DEBIAN/control | sed 's/^Version: //')
cd ../
sudo dpkg -i piaware_${PIAWARE_VER}_*.deb

 

@obj

[SOLVED] MLAT-CLIENT FAILS TO BUILD ON DEBIAN 12 BOOKWORM

sudo apt update
sudo apt install -y git
sudo apt install -y curl 
sudo apt install -y build-essential 
sudo apt install -y debhelper 
sudo apt install -y python3-dev 
sudo apt install -y dh-python 

git clone https://github.com/mutability/mlat-client
cd mlat-client
sudo dpkg-buildpackage -b -uc  

image

 

WORKAROND

cd mlat-client
sudo sed -i '/dh $@ --with python3/s/$/ --buildsystem=pybuild/' debian/rules  

image

 

sudo dpkg-buildpackage -b -uc  

image

 

image

NEXT WORKAROUND:

Workaround:

 sudo ln -sf /usr/bin/fa-mlat-client /usr/lib/piaware/helpers/

Result: failure

sudo systemctl restart piaware

sudo systemctl status piaware
Apr 11 17:21:00 debian-12 piaware[3692]: Starting multilateration client: /usr/lib/piaware/helpers/fa-mlat-client --input-connect localhost:30005 --input->
Apr 11 17:21:00 debian-12 piaware[3692]: mlat-client(3770): Traceback (most recent call last):
Apr 11 17:21:00 debian-12 piaware[3692]: mlat-client(3770):   File "/usr/lib/piaware/helpers/fa-mlat-client", line 10, in <module>
Apr 11 17:21:00 debian-12 piaware[3692]: mlat-client(3770):     from mlat.client.coordinator import Coordinator
Apr 11 17:21:00 debian-12 piaware[3692]: mlat-client(3770):   File "/usr/local/lib/python3.11/dist-packages/MlatClient-0.2.12-py3.11-linux-x86_64.egg/mlat>
Apr 11 17:21:00 debian-12 piaware[3692]: mlat-client(3770):     import _modes
Apr 11 17:21:00 debian-12 piaware[3692]: mlat-client(3770): ImportError: /usr/local/lib/python3.11/dist-packages/MlatClient-0.2.12-py3.11-linux-x86_64.egg>
Apr 11 17:21:00 debian-12 piaware[3692]: got EOF from multilateration client
Apr 11 17:21:01 debian-12 piaware[3692]: fa-mlat-client exited with EXIT 1

This was EXTREMELY helpful, thank you! The Pis are great, but all the read/write takes a tool on performance so I bought a mini-PC, installed Ubuntu (couldn’t get RaspPiOS working) and then struggled to get the components installed and running for FA/FR24, etc. so thank you!! Now I just need to figure out why I can’t get tightvnc to accept connections. On to the next challenge…

@abcd567 I’m super late to this thread. It seems that you found a workaround for Ubuntu 23.xx. Presumably when Ubuntu 24.04LTS comes out in the next 4-5 months the workaround will work for that too?

Please see this thread:

Ubuntu 24.04 Noble Numbat (Desktop & Server): Install piaware, dump1090-fa, dump978-fa, and piaware-web

1 Like

You are the best. I guess I need to remember the first rule- don’t fix what isn’t broken by not upgrading the second 24.04lts is available.