FlightAware Discussions

Ubuntu 20.04.1 crashed

I upgraded to Ubuntu version 20.04 and a few weeks was perfect until this morning. I find black screen full of errors, also I saw: Busybox v1.30.1.
The only thing that I changed on the laptop was that I upgraded to flight-aware version 4.0

I tried to use the advanced ubuntu boot in order to use the recovery boot, but it doesn’t work get me (initramfs).

Booted in Ubuntu from USB (try now option that boots a live linux).
‘sudo fdisk -l’ gives me the list of partitions.
I tried to fix the problem using ‘fsck’ but I get the reply ‘fsck from util-linux 2.34’.
When I write ‘sudo fsck /dev/sda1’ I get ‘fsck from util-linux 2.34’.
‘sudo tune2fs -c 1 /dev/sda’ says ‘Bad magic number in super-block while trying to open /dev/sda Found a dos partitiontable in /dev/sda’
Well, that’s true, I am dual booting in Windows 10 on this machine.

if I select to boot in Windows 10, it boots fine but it crashes during updates.

Any ideas?!

This is my partition list:

20201004_113924|690x388

And after fsck on Linux partition:

It still hangs in (initramfs)

In Live Ubuntu, also can’t read superblock on the Linux partition (sda5, 23GB).

Tried to get a recovery superblock:
dumpe2fs /dev/sda2 | grep superblock
fsck -b 32768 /dev/sda5

This didn’t work either:

Oh, well… too much effort, nothing works.
I’ll wipe everything and start clean. Disappointing…

LE: I can’t even wipe this SSD!!! I had just order a new 128GB SSD for $20 from Amazon! Man, those things got so cheap!

1 Like

Sounds like hardware failure - note how fsck et al were getting i/o errors whenever they tried to write to the disk (this is a very low level write, so it’s not merely filesystem corruption - the hardware itself is reporting an error)

This is fsck being smart about not destroying data. You told it to run against the entire raw disk (/dev/sda), not a single partition containing a filesystem (/dev/sda2 etc). It told you that this was probably a bad idea :slight_smile:

2 Likes